aboutsummaryrefslogtreecommitdiff
path: root/java/infobus/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-09-27 06:02:24 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-09-27 06:02:24 +0000
commit8b64d1fa966f751fb01e0391c1bf7cec189b30c7 (patch)
tree5563b8c59e0f53de5c267edd6433d6ce03b81ba1 /java/infobus/Makefile
parentdcf5694956a76b6352197b1108a8ab44fb611e86 (diff)
downloadports-8b64d1fa966f751fb01e0391c1bf7cec189b30c7.tar.gz
ports-8b64d1fa966f751fb01e0391c1bf7cec189b30c7.zip
. Fix RUN_DEPENDS (JAVAJARDIR -> JAVALIBDIR).
. Respect NOPORTDOCS. . Split "docs" into examples and docs as appropriate and install them in the relevant directories. . Use PORTDOCS. . Use appropriate macros in the packing list (%%JAVAJARDIR%% and %%EXAMPLESDIR%%) and adjust it appropriately for the previous two changes. . Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=143609
Diffstat (limited to 'java/infobus/Makefile')
-rw-r--r--java/infobus/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/java/infobus/Makefile b/java/infobus/Makefile
index 73e37e914310..9ccbf83f73ea 100644
--- a/java/infobus/Makefile
+++ b/java/infobus/Makefile
@@ -7,13 +7,14 @@
PORTNAME= infobus
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= java devel
DISTNAME= ib12
MAINTAINER= java@freebsd.org
COMMENT= Enables dynamic exchange of data between JavaBeans(TM)
-RUN_DEPENDS= ${JAVAJARDIR}/collections.jar:${PORTSDIR}/java/collections
+RUN_DEPENDS= ${JAVALIBDIR}/collections.jar:${PORTSDIR}/java/collections
USE_ZIP= YES
USE_JAVA= YES
@@ -23,17 +24,29 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
NO_CDROM= "See the license"
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE= You must manually fetch the distribution from http://java.sun.com/products/archive/javabeans/infobus/downloads.html and place it in ${DISTDIR} then run make again
.endif
do-install:
- @cd ${WRKSRC}; \
- ${MKDIR} ${PREFIX}/share/java/classes/; \
- ${CP} ${WRKSRC}/infobus.jar ${PREFIX}/share/java/classes/; \
- ${MKDIR} ${PREFIX}/share/java/${PKGNAME}/; \
- ${CP} LICENSE.HTML *.java *.html coffee6.gif examples.mak makefile moneyman.mf ${PREFIX}/share/java/${PKGNAME}/; \
- ${CP} -R doc ${PREFIX}/share/java/${PKGNAME}/
+ ${INSTALL_DATA} ${WRKSRC}/infobus.jar ${JAVAJARDIR}/
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.java ${EXAMPLESDIR}
+.for i in examples.mak makefile moneyman.mf ReadMe.html ReadRowset.html coffee6.gif
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in LICENSE.HTML ReadMe.html coffee6.gif
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+ cd ${WRKSRC}/doc && \
+ ${FIND} . | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+.endif
.include <bsd.port.post.mk>