aboutsummaryrefslogtreecommitdiff
path: root/java/intellij-fsnotifier
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-02-27 19:54:46 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-02-27 19:54:46 +0000
commit0ccad4810ba43bb56731d7f90b37dde795a0bc9e (patch)
treee092ff053c6d39ef1d1c66aa94d8a0f469f2e4e1 /java/intellij-fsnotifier
parent261593e7c5c6111fe6dc1cef8211b1cf8fec4777 (diff)
downloadports-0ccad4810ba43bb56731d7f90b37dde795a0bc9e.tar.gz
ports-0ccad4810ba43bb56731d7f90b37dde795a0bc9e.zip
java/intellij: 15.0.3 -> 15.0.4
- Thanks to Jiri B <jirib@devio.us> and Roman Shevchenko [1] for contributing a libinotify-based replacement for IntelliJ's fsnotifier. IntelliJ now has native (faster) file notification support on FreeBSD (and OpenBSD). - Because of remaining problems with watching large trees with libinotify [2], fsnotifier is still disabled by default. - fsnotifier and native pty4j support need to be compiled. In the interest of reducing port complexity, the building of pty support and fsnotifier is moved to separate ports: - java/intellij-pty4j - java/intellij-fsnotifier [1] https://youtrack.jetbrains.com/issue/IDEA-151815 [2] https://github.com/dmatveev/libinotify-kqueue/pull/34 PR: 207474 Submitted by: Tobias Kortkamp <t@tobik.me> (maintainer)
Notes
Notes: svn path=/head/; revision=409684
Diffstat (limited to 'java/intellij-fsnotifier')
-rw-r--r--java/intellij-fsnotifier/Makefile31
-rw-r--r--java/intellij-fsnotifier/distinfo2
-rw-r--r--java/intellij-fsnotifier/pkg-descr6
3 files changed, 39 insertions, 0 deletions
diff --git a/java/intellij-fsnotifier/Makefile b/java/intellij-fsnotifier/Makefile
new file mode 100644
index 000000000000..ef415eddb678
--- /dev/null
+++ b/java/intellij-fsnotifier/Makefile
@@ -0,0 +1,31 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= intellij-fsnotifier
+PORTVERSION= 20160221
+CATEGORIES= java devel
+
+MAINTAINER= t@tobik.me
+COMMENT= Replacement for IntelliJ's fsnotifier
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libinotify.so:${PORTSDIR}/devel/libinotify
+
+USE_GITHUB= yes
+GH_ACCOUNT= idea4bsd
+GH_PROJECT= fsnotifier
+GH_TAGNAME= a04fbff6e21d58fea7a3ed2a6a21e53cbef4b7af
+
+USES= compiler:c11
+
+.include "${.CURDIR}/../intellij/common.mk"
+
+PLIST_FILES= ${IDEA_HOME}/bin/fsnotifier
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${IDEA_HOME}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/fsnotifier ${STAGEDIR}${IDEA_HOME}/bin
+
+.include <bsd.port.mk>
diff --git a/java/intellij-fsnotifier/distinfo b/java/intellij-fsnotifier/distinfo
new file mode 100644
index 000000000000..d23d1be15855
--- /dev/null
+++ b/java/intellij-fsnotifier/distinfo
@@ -0,0 +1,2 @@
+SHA256 (idea4bsd-fsnotifier-20160221-a04fbff6e21d58fea7a3ed2a6a21e53cbef4b7af_GH0.tar.gz) = 03e217ea5aba24f0ad89c868e4b680f6ec517bcfb35132e5b7a961e0a2505396
+SIZE (idea4bsd-fsnotifier-20160221-a04fbff6e21d58fea7a3ed2a6a21e53cbef4b7af_GH0.tar.gz) = 12520
diff --git a/java/intellij-fsnotifier/pkg-descr b/java/intellij-fsnotifier/pkg-descr
new file mode 100644
index 000000000000..b877d9d7bfea
--- /dev/null
+++ b/java/intellij-fsnotifier/pkg-descr
@@ -0,0 +1,6 @@
+The fsnotifier is used by IntelliJ for detecting file changes. This
+version supports FreeBSD and OpenBSD via libinotify and is a
+replacement for the bundled Linux-only version coming with the
+IntelliJ IDEA Community Edition.
+
+WWW: https://github.com/idea4bsd/fsnotifier/