aboutsummaryrefslogtreecommitdiff
path: root/java/jakarta-commons-discovery
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-04-18 06:18:19 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-04-18 06:18:19 +0000
commitb97389634f41dd9f981861ec37988bbfc0a797cf (patch)
treec0089875e27a5310353fc1ac6ccb23b2c97ed01a /java/jakarta-commons-discovery
parent99b8b64f4da3dcbcad1d6eda2659220e80a88d86 (diff)
downloadports-b97389634f41dd9f981861ec37988bbfc0a797cf.tar.gz
ports-b97389634f41dd9f981861ec37988bbfc0a797cf.zip
Add a port of jakarta-commons-discovery.
The Discovery Component is about discovering, or finding, implementations for pluggable interfaces. It provides facilities intantiating classes in general, and for lifecycle management of singleton (factory) classes. Fundamentally, Discovery locates classes that implement a given Java interface. The discovery pattern, though not necessarily this package, is used in many projects including JAXP (SaxParserFactory and others) and commons-logging (LogFactory). By extracting this pattern, other projects can (re)use it and take advantage of improvements to the pattern as Discovery evolves. Discovery improves over previous implementations by establishing facilities for working within managed environments. These allow configuration and property overrides without appealing to the global System properties (which are scoped across an entire JVM). PR: 65490 Submitted by: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
Notes
Notes: svn path=/head/; revision=107393
Diffstat (limited to 'java/jakarta-commons-discovery')
-rw-r--r--java/jakarta-commons-discovery/Makefile48
-rw-r--r--java/jakarta-commons-discovery/distinfo2
-rw-r--r--java/jakarta-commons-discovery/pkg-descr16
3 files changed, 66 insertions, 0 deletions
diff --git a/java/jakarta-commons-discovery/Makefile b/java/jakarta-commons-discovery/Makefile
new file mode 100644
index 000000000000..85f9c19dcbc3
--- /dev/null
+++ b/java/jakarta-commons-discovery/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: jakarta-commons-discovery
+# Date created: 2004-04-13
+# Whom: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= commons-discovery
+PORTVERSION= 0.2
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/binaries
+PKGNAMEPREFIX= jakarta-
+
+MAINTAINER= herve.quiroz@esil.univ-mrs.fr
+COMMENT= A Java library for locating resources (including classes)
+
+USE_JAVA= YES
+JAVA_VERSION= 1.3+
+JAVA_RUN= JDK
+NO_BUILD= YES
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= api LICENSE
+.endif
+JARFILE= ${PORTNAME}.jar
+PLIST_FILES+= ${JAVAJARDIR:S,^${PREFIX}/,,}/${JARFILE}
+
+post-extract:
+ @${MV} ${WRKSRC}/LICENSE ${WRKSRC}/docs/
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${JARFILE}..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${JAVAJARDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+.for DOCFILE in ${PORTDOCS}
+ @${CP} -r ${WRKSRC}/docs/${DOCFILE} ${DOCSDIR}/
+ @${ECHO_MSG} -n " ${DOCFILE}"
+.endfor
+ @${CHOWN} -h -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/java/jakarta-commons-discovery/distinfo b/java/jakarta-commons-discovery/distinfo
new file mode 100644
index 000000000000..0cce006a8d57
--- /dev/null
+++ b/java/jakarta-commons-discovery/distinfo
@@ -0,0 +1,2 @@
+MD5 (commons-discovery-0.2.tar.gz) = 2273f5f83a477f4f18fccf3a00e2b48c
+SIZE (commons-discovery-0.2.tar.gz) = 118701
diff --git a/java/jakarta-commons-discovery/pkg-descr b/java/jakarta-commons-discovery/pkg-descr
new file mode 100644
index 000000000000..57f754aac21a
--- /dev/null
+++ b/java/jakarta-commons-discovery/pkg-descr
@@ -0,0 +1,16 @@
+The Discovery Component is about discovering, or finding, implementations for
+pluggable interfaces. It provides facilities intantiating classes in general,
+and for lifecycle management of singleton (factory) classes.
+
+Fundamentally, Discovery locates classes that implement a given Java interface.
+The discovery pattern, though not necessarily this package, is used in many
+projects including JAXP (SaxParserFactory and others) and commons-logging
+(LogFactory). By extracting this pattern, other projects can (re)use it and
+take advantage of improvements to the pattern as Discovery evolves.
+
+Discovery improves over previous implementations by establishing facilities for
+working within managed environments. These allow configuration and property
+overrides without appealing to the global System properties (which are scoped
+across an entire JVM).
+
+WWW: http://jakarta.apache.org/commons/discovery/