aboutsummaryrefslogtreecommitdiff
path: root/java/janosvm/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-18 21:03:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-18 21:03:57 +0000
commitdaea70d3ff57e447a652720fb0d27df68c326b8e (patch)
tree489eb0f7f661d96474470b8e0849d61da6064e81 /java/janosvm/Makefile
parent98befe8fa7c6e0fb60133630499d4bad013ceed2 (diff)
downloadports-daea70d3ff57e447a652720fb0d27df68c326b8e.tar.gz
ports-daea70d3ff57e447a652720fb0d27df68c326b8e.zip
add janosvm
A virtual machine for executing Java bytecodes
Notes
Notes: svn path=/head/; revision=44189
Diffstat (limited to 'java/janosvm/Makefile')
-rw-r--r--java/janosvm/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/java/janosvm/Makefile b/java/janosvm/Makefile
new file mode 100644
index 000000000000..e84a7760f129
--- /dev/null
+++ b/java/janosvm/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: janosvm
+# Date created: Jun 19, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= janosvm
+PORTVERSION= 0.5.1
+CATEGORIES= java
+MASTER_SITES= http://www.cs.utah.edu/flux/janos/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${DISTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MAN1= janosvm.1 jsihey.1
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${PREFIX}/share/doc/janosvm
+ ${CP} -R ${WRKSRC}/FAQ ${PREFIX}/share/doc/janosvm
+ ${CP} -R ${WRKSRC}/doc ${PREFIX}/share/doc/janosvm
+.endif
+
+.include <bsd.port.mk>