aboutsummaryrefslogtreecommitdiff
path: root/java/javavmwrapper
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-04-11 21:22:43 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-04-11 21:22:43 +0000
commitd964895873082e16a7712d483f62c3bd9547fc10 (patch)
treebd6a2c22a80a85b20ab3c6620fb13ae20ed88c1c /java/javavmwrapper
parent7ea5326d8eb7b8b747c5c90b141541374e2de00f (diff)
downloadports-d964895873082e16a7712d483f62c3bd9547fc10.tar.gz
ports-d964895873082e16a7712d483f62c3bd9547fc10.zip
. Install manual pages for javavmwrapper.
. Bump PORTREVISION. PR: 27075
Notes
Notes: svn path=/head/; revision=133092
Diffstat (limited to 'java/javavmwrapper')
-rw-r--r--java/javavmwrapper/Makefile16
-rw-r--r--java/javavmwrapper/src/checkvms.156
-rw-r--r--java/javavmwrapper/src/javavm.1111
-rw-r--r--java/javavmwrapper/src/javavms.557
-rw-r--r--java/javavmwrapper/src/registervm.179
5 files changed, 318 insertions, 1 deletions
diff --git a/java/javavmwrapper/Makefile b/java/javavmwrapper/Makefile
index f6e5ae7c8033..bfe2f5112b76 100644
--- a/java/javavmwrapper/Makefile
+++ b/java/javavmwrapper/Makefile
@@ -9,7 +9,7 @@
PORTNAME= javavmwrapper
PORTVERSION= 2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java
MASTER_SITES= # none
DISTFILES= # none
@@ -24,6 +24,9 @@ NO_WRKSUBDIR= yes
PKGINSTALL= ${WRKDIR}/pkg-install
+MAN1= checkvms.1 javavm.1 registervm.1 unregistervm.1
+MAN5= javavms.5
+
SRC= ${.CURDIR}/src
SCRIPTS= classpath javavmwrapper
# This is normally defined by bsd.java.mk when USE_JAVA is defined, but
@@ -41,6 +44,11 @@ do-configure:
.endfor
${SED} -e 's|%%LOCALBASE%%|${LOCALBASE}|;' \
${FILESDIR}/pkg-install.in > ${PKGINSTALL}
+.for _man in checkvms.1 javavm.1 registervm.1 ${MAN5}
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|;' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|;' \
+ ${SRC}/${_man} > ${WRKDIR}/${_man}
+.endfor
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/classpath.sh ${PREFIX}/bin/classpath
@@ -48,6 +56,12 @@ do-install:
${LN} -sf ${PREFIX}/bin/javavm ${PREFIX}/bin/registervm
${LN} -sf ${PREFIX}/bin/javavm ${PREFIX}/bin/unregistervm
${LN} -sf ${PREFIX}/bin/javavm ${PREFIX}/bin/checkvms
+.for _man in checkvms.1 javavm.1 registervm.1
+ ${INSTALL_MAN} ${WRKDIR}/${_man} ${MAN1PREFIX}/man/man1
+.endfor
+ ${INSTALL_MAN} ${WRKDIR}/registervm.1 \
+ ${MAN1PREFIX}/man/man1/unregistervm.1
+ ${INSTALL_MAN} ${WRKDIR}/${MAN5} ${MAN5PREFIX}/man/man5
post-install:
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} \
diff --git a/java/javavmwrapper/src/checkvms.1 b/java/javavmwrapper/src/checkvms.1
new file mode 100644
index 000000000000..7e1e44d781bd
--- /dev/null
+++ b/java/javavmwrapper/src/checkvms.1
@@ -0,0 +1,56 @@
+.\"
+.\" Copyright (C) 2005 Greg Lewis. All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+.\" ARE DISCLAIMED. IN NO EVENT SHALL AUTHOR OR CONTRIBUTORS BE LIABLE
+.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+.\" SUCH DAMAGE.
+.\"
+.\" $FreeBSD$
+.\"
+.Dd February 24, 2005
+.Os
+.Dt CHECKVMS 1
+.Sh NAME
+.Nm checkvms
+.Nd sanity check registered Java VMs
+.Sh SYNOPSIS
+.Nm checkvms
+.Sh DESCRIPTION
+Each registered Java VM is checked to ensure that it exists and that
+all appropriate symbolic links for it have been created.
+Non-existent Java VMs are unregistered and missing symbolic links are created.
+The Java VMs are also sorted using a hard-coded ordering that will
+sort them by version and affinity with
+.Fx .
+.Sh FILES
+.Bl -tag -width indent
+.It %%PREFIX%%/etc/javavms
+The location of the Java VM wrapper configuration file.
+.El
+.Sh SEE ALSO
+.Xr javavm 1 ,
+.Xr registervm 1 ,
+.Xr unregistervm 1 ,
+.Xr javavms 5
+.Sh BUGS
+The
+.Nm
+utility removes both blank lines and purely comment lines from
+the Java VM wrapper configuration file.
diff --git a/java/javavmwrapper/src/javavm.1 b/java/javavmwrapper/src/javavm.1
new file mode 100644
index 000000000000..2cf49d9f0ec7
--- /dev/null
+++ b/java/javavmwrapper/src/javavm.1
@@ -0,0 +1,111 @@
+.\"
+.\" Copyright (C) 2005 Greg Lewis. All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+.\" ARE DISCLAIMED. IN NO EVENT SHALL AUTHOR OR CONTRIBUTORS BE LIABLE
+.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+.\" SUCH DAMAGE.
+.\"
+.\" $FreeBSD$
+.\"
+.Dd February 24, 2005
+.Os
+.Dt JAVAVM 1
+.Sh NAME
+.Nm javavm
+.Nd convenient wrapper for switching Java VMs
+.Sh SYNOPSIS
+.Nm
+.Op Ar arguments ...
+.Sh DESCRIPTION
+The Java VM wrapper provides a convenient system for switching between
+different Java VMs.
+It also provides symbolic links in %%LOCALBASE%%/bin to allow the use of
+the Java executables without having to add the specific Java VM executable
+directories to the PATH environment variable.
+.Pp
+The
+.Nm
+utility itself is currently a synonym for "java". However, this behaviour
+is deprecated and is provided only for compatibility with the previous
+version of
+.Nm .
+This functionality may be removed in a future version and should not be
+relied upon.
+.Pp
+By default,
+.Nm
+will select the most "native" and up to date version of the Java VM when
+a given symbolic link is used, invoking and passing the arguments to the
+matching executable within the chosen Java VM.
+The choice of Java VM may also be influenced by using environment variables
+to constrain the version, vendor and operating system of the Java VM.
+.Sh ENVIRONMENT
+.Bl -tag -width indent
+.It JAVA_HOME
+The presence of this variable in the environment when executing
+.Nm
+will override all other considerations regarding the Java VM to be used
+and the Java VM located at ${JAVA_HOME}/bin/java will be used.
+.Pp
+This variable is set by
+.Nm
+when executing the actual Java VM and will be available to it and all of
+its child processes.
+.It JAVA_OS
+The operating system that the Java VM was created for.
+.Pp
+Currently allowed values are "native" and "linux".
+.It JAVA_VENDOR
+The vendor that created the Java VM.
+.Pp
+Currently allowed values are "bsdjava", "freebsd", "blackdown", "ibm" and
+"sun".
+.It JAVA_VERSION
+The version of the Java VM that should be used. By appending a '+' to
+the version, any Java VM with a version greater than or equals to the
+given version will be used.
+.Pp
+Currently allowed values are 1.1, 1.1+, 1.2, 1.2+, 1.3, 1.3+, 1.4, 1.4+,
+1.5 and 1.5+.
+.El
+.Sh FILES
+.Bl -tag -width indent
+.It %%PREFIX%%/etc/javavms
+The location of the Java VM wrapper configuration file.
+.El
+.Sh EXAMPLES
+.Bl -tag -width indent
+.It %%LOCALBASE%%/bin/java
+Execute the most up to date and "native" Java VM registered with
+.Nm .
+.It JAVA_VERSION=1.4+ %%LOCALBASE%%/bin/javac MyClass.java
+Compile MyClass.java with a registered Java VM's javac that is at least
+version 1.4.
+.It JAVA_OS=native %%LOCALBASE%%/bin/java -jar MyApp.jar
+Execute MyApp with the most up to date native Java VM that is registered
+with
+.Nm .
+This is necessary if MyApp uses JNI, for instance.
+.El
+.Sh SEE ALSO
+.Xr checkvms 1 ,
+.Xr registervm 1 ,
+.Xr unregistervm 1 ,
+.Xr javavms 5
diff --git a/java/javavmwrapper/src/javavms.5 b/java/javavmwrapper/src/javavms.5
new file mode 100644
index 000000000000..01c6049d99ef
--- /dev/null
+++ b/java/javavmwrapper/src/javavms.5
@@ -0,0 +1,57 @@
+.\"
+.\" Copyright (C) 2005 Greg Lewis. All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+.\" ARE DISCLAIMED. IN NO EVENT SHALL AUTHOR OR CONTRIBUTORS BE LIABLE
+.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+.\" SUCH DAMAGE.
+.\"
+.\" $FreeBSD$
+.\"
+.Dd February 24, 2005
+.Os
+.Dt JAVAVMS 5
+.Sh NAME
+.Nm javavms
+.Nd the Java VM wrapper configuration file.
+.Sh DESCRIPTION
+The
+.Nm
+file contains a list of the registered Java VMs which are available to be
+used by
+.Nm javavm .
+Each Java VM is listed by specifying the location of the main 'java'
+executable on a line.
+.Pp
+The
+.Nm
+file may also contains comments.
+Comments must start with the '#' character, and can be both lines by
+themselves or the trailing portion of a line containing a registered
+Java VM.
+.Sh FILES
+.Bl -tag -width indent
+.It %%PREFIX%%/etc/javavms
+The location of the Java VM wrapper configuration file.
+.El
+.Sh SEE ALSO
+.Xr checkvms 1 ,
+.Xr javavm 1 ,
+.Xr registervm 1 ,
+.Xr unregistervm 1
diff --git a/java/javavmwrapper/src/registervm.1 b/java/javavmwrapper/src/registervm.1
new file mode 100644
index 000000000000..12f9e9f24f96
--- /dev/null
+++ b/java/javavmwrapper/src/registervm.1
@@ -0,0 +1,79 @@
+.\"
+.\" Copyright (C) 2005 Greg Lewis. All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+.\" ARE DISCLAIMED. IN NO EVENT SHALL AUTHOR OR CONTRIBUTORS BE LIABLE
+.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+.\" SUCH DAMAGE.
+.\"
+.\" $FreeBSD$
+.\"
+.Dd February 24, 2005
+.Os
+.Dt REGISTERVM 1
+.Sh NAME
+.Nm registervm ,
+.Nm unregistervm
+.Nd register/unregister a Java VM
+.Sh SYNOPSIS
+.Nm
+.Ar /path/to/java
+.Nm unregistervm
+.Ar /path/to/java
+.Sh DESCRIPTION
+The
+.Nm registervm
+and
+.Nm unregistervm
+utilities allow a Java VM to be registered and unregistered as a possible
+Java VM that
+.Nm javavm
+can use.
+The registration process places the registered VM in the Java VM wrapper
+configuration file in sorted order.
+When unregistering the Java VM is removed from the Java VM wrapper
+configuration file and will no longer be a possible choice for
+.Nm javavm .
+.Sh FILES
+.Bl -tag -width indent
+.It %%PREFIX%%/etc/javavms
+The location of the Java VM wrapper configuration file.
+.El
+.Sh EXAMPLES
+.Bl -tag -width indent
+.It %%PREFIX%%/bin/registervm %%LOCALBASE%%/jdk.1.4.2/bin/java
+Register %%LOCALBASE%%/jdk1.4.2/bin/java as a possible choice of
+Java VM for
+.Nm javavm .
+.It %%PREFIX%%/bin/unregistervm %%LOCALBASE%%/jdk.1.4.2/bin/java
+Remove %%LOCALBASE%%/jdk1.4.2/bin/java as a possible choice of
+Java VM for
+.Nm javavm .
+.El
+.Sh SEE ALSO
+.Xr checkvms 1 ,
+.Xr javavm 1 ,
+.Xr javavms 5
+.Sh BUGS
+The
+.Nm
+and
+.Nm unregistervm
+utilities remove both blank lines and purely comment lines from
+the Java VM wrapper configuration file.