aboutsummaryrefslogtreecommitdiff
path: root/java/jlint
diff options
context:
space:
mode:
authorErnst de Haan <znerd@FreeBSD.org>2003-03-03 21:36:44 +0000
committerErnst de Haan <znerd@FreeBSD.org>2003-03-03 21:36:44 +0000
commita127113f1b163f4adc6fd80eb09db1aa85ea8442 (patch)
tree4129dffa446def3801041e5bd160df51f10f9ab2 /java/jlint
parente1992c34cff8991a0f7fd535d811a4a2757aa730 (diff)
downloadports-a127113f1b163f4adc6fd80eb09db1aa85ea8442.tar.gz
ports-a127113f1b163f4adc6fd80eb09db1aa85ea8442.zip
Fixes:
- unbreak with new gcc on -current ('using namespace std') - CFLAGS/env police - condense port's Makefile - install additional shell script - install documentation (honour NOPORTDOCS) PR: 48464 Submitted by: Volker Stolz <stolz@i2.informatik.rwth-aachen.de> Tested on: -STABLE, -CURRENT
Notes
Notes: svn path=/head/; revision=76819
Diffstat (limited to 'java/jlint')
-rw-r--r--java/jlint/Makefile17
-rw-r--r--java/jlint/files/patch-Makefile22
-rw-r--r--java/jlint/files/patch-field_desc.hh13
-rw-r--r--java/jlint/pkg-plist8
4 files changed, 52 insertions, 8 deletions
diff --git a/java/jlint/Makefile b/java/jlint/Makefile
index 4c6616fc5fa5..c9fd07038848 100644
--- a/java/jlint/Makefile
+++ b/java/jlint/Makefile
@@ -13,15 +13,20 @@ MASTER_SITES= http://artho.com/jlint/ \
MAINTAINER= znerd@FreeBSD.org
-PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
-TARGET_DIR?= ${PREFIX}/bin
+USE_REINPLACE= YES
.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' ${WRKSRC}/jlint.sh
+
do-install:
- ${MKDIR} ${TARGET_DIR}
- ${CP} ${WRKSRC}/jlint ${TARGET_DIR}
- ${CP} ${WRKSRC}/antic ${TARGET_DIR}
- ${CHMOD} 755 ${TARGET_DIR}/jlint ${TARGET_DIR}/antic
+ ${INSTALL_PROGRAM} ${WRKSRC}/jlint ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/antic ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/jlint.sh ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manual.pdf ${WRKSRC}/manual.html ${DOCSDIR}
+.endif
.include <bsd.port.post.mk>
diff --git a/java/jlint/files/patch-Makefile b/java/jlint/files/patch-Makefile
new file mode 100644
index 000000000000..9cae9f698201
--- /dev/null
+++ b/java/jlint/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Wed Feb 19 17:20:06 2003
++++ Makefile Wed Feb 19 17:21:13 2003
+@@ -3,8 +3,8 @@
+ # Makefile for Unix and GNU/Linux with gcc/g++ compiler
+ # Edit here:
+
+-CC=gcc
+-CPP=g++
++CC?=gcc
++CPP=$(CXX)
+
+ # Hints:
+ # if you use egcs-2.90.* version of GCC please add option -fno-exceptions
+@@ -18,7 +18,7 @@
+
+ # Optimized version
+
+-CFLAGS = -c -Wall -O2 -g -DSLIST
++CFLAGS += -c
+ # add -DHASH_TABLE for extra speed (may sometimes produce inconsistent results)
+
+ # Optimized version with switched off asserts
diff --git a/java/jlint/files/patch-field_desc.hh b/java/jlint/files/patch-field_desc.hh
new file mode 100644
index 000000000000..0781d51567c5
--- /dev/null
+++ b/java/jlint/files/patch-field_desc.hh
@@ -0,0 +1,13 @@
+--- field_desc.hh.orig Wed Feb 19 17:20:15 2003
++++ field_desc.hh Wed Feb 19 17:22:10 2003
+@@ -1,10 +1,7 @@
+ #ifndef FIELD_DESC_HH
+ #define FIELD_DESC_HH
+
+-#ifdef VISUAL_CPP
+ using namespace std;
+-#pragma warning (disable : 4786)
+-#endif
+
+ #include "component_desc.hh"
+ #include "utf_string.hh"
diff --git a/java/jlint/pkg-plist b/java/jlint/pkg-plist
index 467963f76e8c..a56afeeabbcc 100644
--- a/java/jlint/pkg-plist
+++ b/java/jlint/pkg-plist
@@ -1,2 +1,6 @@
-%%T%%/jlint
-%%T%%/antic
+bin/jlint
+bin/jlint.sh
+bin/antic
+%%PORTDOCS%%share/doc/jlint/manual.pdf
+%%PORTDOCS%%share/doc/jlint/manual.html
+%%PORTDOCS%%@dirrm share/doc/jlint