aboutsummaryrefslogtreecommitdiff
path: root/java/jrosetta
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
commitc7c32639cce504dbfefa9d1a09034d60600acaca (patch)
tree542278ecb4449b3df78960fd5f6cf7d8be50914f /java/jrosetta
parent42aab3eb75f5152697ee03e5e8457ce58906e2c1 (diff)
downloadports-c7c32639cce504dbfefa9d1a09034d60600acaca.tar.gz
ports-c7c32639cce504dbfefa9d1a09034d60600acaca.zip
Convert my ports to new options helpers
Notes
Notes: svn path=/head/; revision=395231
Diffstat (limited to 'java/jrosetta')
-rw-r--r--java/jrosetta/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/java/jrosetta/Makefile b/java/jrosetta/Makefile
index 423d3c08b817..476a8cf21996 100644
--- a/java/jrosetta/Makefile
+++ b/java/jrosetta/Makefile
@@ -20,7 +20,7 @@ PLIST_FILES= %%JAVAJARDIR%%/jrosetta-api.jar \
%%JAVAJARDIR%%/jrosetta-engine.jar
OPTIONS_DEFINE= COMPILE
-COMPILE_DESC= Download and compile source instead of binaries
+COMPILE_DESC= Download and compile source instead of using provided binaries
.include <bsd.port.options.mk>
@@ -41,27 +41,24 @@ EXTRACT_ONLY=
NO_BUILD= yes
.endif
-.if ${PORT_OPTIONS:MCOMPILE}
-post-patch:
+post-patch-COMPILE-on:
${MKDIR} ${WRKDIR}/m2
${CP} ${FILESDIR}/settings.xml ${WRKDIR}
${REINPLACE_CMD} -e "s|WORK|${WRKDIR}|" ${WRKDIR}/settings.xml
-do-build:
+do-build-COMPILE-on:
(cd ${WRKSRC} && ${LOCALBASE}/bin/mvn -gs "${WRKDIR}/settings.xml" clean install)
-.endif
-do-install:
-.if ${PORT_OPTIONS:MCOMPILE}
+do-install-COMPILE-on:
${INSTALL_DATA} ${OUTPUT}/jrosetta-api/${PORTVERSION}/jrosetta-api-${PORTVERSION}.jar \
${STAGEDIR}${JAVAJARDIR}/jrosetta-api.jar
${INSTALL_DATA} ${OUTPUT}/jrosetta-engine/${PORTVERSION}/jrosetta-engine-${PORTVERSION}.jar \
${STAGEDIR}${JAVAJARDIR}/jrosetta-engine.jar
-.else
+
+do-install-COMPILE-off:
${INSTALL_DATA} ${DISTDIR}/jrosetta-api-${PORTVERSION}.jar \
${STAGEDIR}${JAVAJARDIR}/jrosetta-api.jar
${INSTALL_DATA} ${DISTDIR}/jrosetta-engine-${PORTVERSION}.jar \
${STAGEDIR}${JAVAJARDIR}/jrosetta-engine.jar
-.endif
.include <bsd.port.mk>