aboutsummaryrefslogtreecommitdiff
path: root/java/netbeans
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-12-15 14:12:33 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-12-15 14:12:33 +0000
commitb55e62e4a6044f6588e3b189aee29cfac7a17187 (patch)
treefabe2dccddccb2af01c281579b529332719ba2f6 /java/netbeans
parent15b47a7129736d3e52d9635ab82096d5704b5d1c (diff)
downloadports-b55e62e4a6044f6588e3b189aee29cfac7a17187.tar.gz
ports-b55e62e4a6044f6588e3b189aee29cfac7a17187.zip
- Refactor executable script [1]
- Add dependency on gconf2 - Bump PORTREVISION Reported by: Mats Andreassen <matsa@pvv.ntnu.no> (via private e-mail)
Notes
Notes: svn path=/head/; revision=224270
Diffstat (limited to 'java/netbeans')
-rw-r--r--java/netbeans/Makefile8
-rw-r--r--java/netbeans/files/patch-platform9-lib_nbexec55
2 files changed, 62 insertions, 1 deletions
diff --git a/java/netbeans/Makefile b/java/netbeans/Makefile
index 7474b6006ab4..b93b64d41e5f 100644
--- a/java/netbeans/Makefile
+++ b/java/netbeans/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netbeans
PORTVERSION= 6.5
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.netbeans.org/netbeans/6.5/final/zip/ \
http://dlc.sun.com.edgesuite.net/netbeans/6.5/final/zip/
@@ -17,14 +18,19 @@ COMMENT= A full-featured integrated environment for Java
USE_ZIP= yes
USE_JAVA= yes
+USE_GNOME= gconf2
JAVA_VERSION= 1.5+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/netbeans
-do-patch:
+post-patch:
@${REINPLACE_CMD} -i "" -e '19s|#||;19s|/path/to/jdk|${JAVA_HOME}|' \
${WRKSRC}/etc/netbeans.conf
+ @${REINPLACE_CMD} -i "" -e 's|%%GCONFTOOL2%%|${LOCALBASE}/bin/gconftool-2|g; \
+ s|%%GREP%%|${GREP}|g;s|%%SED%%|${SED}|g;s|%%AWK%%|${AWK}|g' \
+ ${WRKSRC}/platform9/lib/nbexec && \
+ ${RM} ${WRKSRC}/platform9/lib/nbexec.orig
do-install:
@${MKDIR} ${PREFIX}/netbeans65
diff --git a/java/netbeans/files/patch-platform9-lib_nbexec b/java/netbeans/files/patch-platform9-lib_nbexec
new file mode 100644
index 000000000000..4bfb91818b27
--- /dev/null
+++ b/java/netbeans/files/patch-platform9-lib_nbexec
@@ -0,0 +1,55 @@
+--- platform9/lib/nbexec.orig 2008-12-15 14:20:13.000000000 +0100
++++ platform9/lib/nbexec 2008-12-15 14:29:44.000000000 +0100
+@@ -330,7 +330,7 @@
+ }
+
+ detect_gnome_proxy () {
+- gconftool=/usr/bin/gconftool-2
++ gconftool=%%GCONFTOOL2%%
+ if [ -x $gconftool ] ; then
+ proxy_mode=`$gconftool --get /system/proxy/mode 2>/dev/null`
+ if [ "$proxy_mode" = "manual" ] ; then
+@@ -362,18 +362,18 @@
+ detect_kde_proxy () {
+ kioslaverc="${HOME}/.kde/share/config/kioslaverc"
+ if [ -f $kioslaverc ] ; then
+- if /bin/grep -q 'ProxyType=1' "$kioslaverc" ; then
+- http_proxy_tmp=`/bin/grep 'httpProxy=http://' "$kioslaverc"`
++ if %%GREP%% -q 'ProxyType=1' "$kioslaverc" ; then
++ http_proxy_tmp=`%%GREP%% 'httpProxy=http://' "$kioslaverc"`
+ if [ $? ] ; then
+- http_proxy_tmp=`echo $http_proxy_tmp | /bin/sed 's/httpProxy=http:\/\///'`
++ http_proxy_tmp=`echo $http_proxy_tmp | %%SED%% 's/httpProxy=http:\/\///'`
+ return 0
+ fi
+- http_non_proxy_hosts=`/bin/grep 'NoProxyFor=' "$kioslaverc"`
++ http_non_proxy_hosts=`%%GREP%% 'NoProxyFor=' "$kioslaverc"`
+ if [ $? ] ; then
+- http_non_proxy_hosts=`echo $http_non_proxy_hosts | /bin/sed 's/NoProxyFor=//'`
++ http_non_proxy_hosts=`echo $http_non_proxy_hosts | %%SED%% 's/NoProxyFor=//'`
+ fi
+ else
+- if /bin/grep -q 'ProxyType=0' "$kioslaverc" ; then
++ if %%GREP%% -q 'ProxyType=0' "$kioslaverc" ; then
+ detect_system_proxy
+ if [ -z "$http_proxy_tmp" ]; then
+ http_proxy_tmp="DIRECT"
+@@ -397,14 +397,14 @@
+ close
+ EOF
+
+- if /usr/bin/grep -q "ProxyAuto.*: *1" ${scutil_out} >/dev/null ; then
++ if %%GREP%% -q "ProxyAuto.*: *1" ${scutil_out} >/dev/null ; then
+ rm ${scutil_out}
+ return 1
+ fi
+
+- if /usr/bin/grep -q "HTTPEnable *: *1" ${scutil_out} ; then
+- http_proxy_host=`/usr/bin/grep HTTPProxy ${scutil_out} | /usr/bin/awk '{print $3}'`
+- http_proxy_port=`/usr/bin/grep HTTPPort ${scutil_out} | /usr/bin/awk '{print $3} '`
++ if %%GREP%% -q "HTTPEnable *: *1" ${scutil_out} ; then
++ http_proxy_host=`%%GREP%% HTTPProxy ${scutil_out} | %%AWK%% '{print $3}'`
++ http_proxy_port=`%%GREP%% HTTPPort ${scutil_out} | %%AWK%% '{print $3} '`
+ http_proxy_tmp=$http_proxy_host:$http_proxy_port
+ rm ${scutil_out}
+ return 0