aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk14
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-07-24 17:10:51 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-07-24 17:10:51 +0000
commit5bc1617efc876b99a806f7de78a9fe94a07304b7 (patch)
treebfbfce29f0c9b229834a1f0536dd6d8022ce8104 /java/openjdk14
parentd841eb94b16fac58b307b35f0c2849842e5eea54 (diff)
downloadports-5bc1617efc876b99a806f7de78a9fe94a07304b7.tar.gz
ports-5bc1617efc876b99a806f7de78a9fe94a07304b7.zip
Multiple ports: improve regex compliance (part 2)
This is again a part of the project to stop extraneous escaping of ordinary characters and redefine some ordinary escapes as special behavior. Most of these ports are pushed over to use textproc/gsed because they want to use GNU extensions. Others are fixed to either escape appropriately (e.g. $$ rather than \$ in Makefiles!) or just remove redundant escapes (e.g. backtick in single quotes doesn't need escaped). PR: 229925 MFH: no (invasive risk)
Notes
Notes: svn path=/head/; revision=543267
Diffstat (limited to 'java/openjdk14')
-rw-r--r--java/openjdk14/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/java/openjdk14/Makefile b/java/openjdk14/Makefile
index 32aad21281b3..711006f7de16 100644
--- a/java/openjdk14/Makefile
+++ b/java/openjdk14/Makefile
@@ -16,7 +16,8 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc64
BUILD_DEPENDS= zip:archivers/zip \
autoconf>0:devel/autoconf \
${LOCALBASE}/include/cups/cups.h:print/cups \
- bash:shells/bash
+ bash:shells/bash \
+ gsed:textproc/gsed
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -64,7 +65,8 @@ JDK_BUG_URL= https://bugs.freebsd.org/bugzilla/enter_bug.cgi?product=Ports%20%26
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC=${CC} \
CXX=${CXX} \
- CPP=${CPP}
+ CPP=${CPP} \
+ ac_cv_path_SED=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR} \
--disable-ccache \
--disable-javac-server \