aboutsummaryrefslogtreecommitdiff
path: root/java/wildfly90/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-05-11 10:52:41 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-05-11 10:52:41 +0000
commit9eedf80c44bafd7bcf9912ba8b957c00a5312758 (patch)
tree78aaa13507365257a62c21a462fec22e8302e2db /java/wildfly90/Makefile
parent3d0fba850df708107b79d5266bda351756c32ef8 (diff)
downloadports-9eedf80c44bafd7bcf9912ba8b957c00a5312758.tar.gz
ports-9eedf80c44bafd7bcf9912ba8b957c00a5312758.zip
Upgrade wildfly90 to 9.0.0.CR1.
Also, for all wildfly ports: - Remove stray .orig files from plist. - Fix rc.conf settings in pkg-message files; use pkg-message.in everywhere. - Add @dir entries to fix directory permissions. - Make configuration writable by user www (fix startup errors). PR: 200092 Submitted by: olgeni Approved by: maintainer
Notes
Notes: svn path=/head/; revision=386063
Diffstat (limited to 'java/wildfly90/Makefile')
-rw-r--r--java/wildfly90/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/java/wildfly90/Makefile b/java/wildfly90/Makefile
index 81b229aa3b97..219582ed7199 100644
--- a/java/wildfly90/Makefile
+++ b/java/wildfly90/Makefile
@@ -20,7 +20,8 @@ GROUP= www
VAR_DIR?= /var
LOG_DIR?= ${VAR_DIR}/log/${PORTNAME}
PID_FILE= ${VAR_DIR}/run/${PORTNAME}.pid
-WILDFLY_VERSION=9.0.0.Alpha1
+WILDFLY_VERSION=9.0.0.CR1
+SUB_FILES= pkg-message
SUB_LIST= APP_SHORTNAME=${PORTNAME} \
LOG_DIR=${LOG_DIR} \
@@ -30,8 +31,12 @@ SUB_LIST= APP_SHORTNAME=${PORTNAME} \
APP_HOME=${PREFIX}/wildfly-${PORTVERSION}
PLIST_SUB= APP_HOME=wildfly-${PORTVERSION}
+post-patch:
+ ${RM} ${WRKSRC}/bin/add-user.sh.orig
+
do-build:
${RM} ${WRKSRC}/bin/*.bat
+ ${RM} ${WRKSRC}/bin/*.ps1
${RM} -rf ${WRKSRC}/bin/service
${RM} -rf ${WRKSRC}/bin/init.d