aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-12-04 14:02:03 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-12-04 14:02:03 +0000
commit3d4abbd1b6acfd360d34a8a51550c88864dad29a (patch)
tree8a03796812055475542632f708bed2e1cb030d50 /java
parentd82645b562669388299a8f86a497ee3438b7c030 (diff)
downloadports-3d4abbd1b6acfd360d34a8a51550c88864dad29a.tar.gz
ports-3d4abbd1b6acfd360d34a8a51550c88864dad29a.zip
- Update to 7.3 Beta 2
Release notes: http://netbeans.org/community/releases/73/relnotes.html - Add LICENSE - Depend on Java 7 - Disable splash screen until png gets fixed in OpenJDK 7 Feature safe: yes
Notes
Notes: svn path=/head/; revision=308240
Diffstat (limited to 'java')
-rw-r--r--java/netbeans-devel/Makefile11
-rw-r--r--java/netbeans-devel/distinfo4
-rw-r--r--java/netbeans-devel/files/patch-netbeans18
-rw-r--r--java/netbeans-devel/pkg-plist43
4 files changed, 48 insertions, 28 deletions
diff --git a/java/netbeans-devel/Makefile b/java/netbeans-devel/Makefile
index c78b0b9a2db7..900518cf2444 100644
--- a/java/netbeans-devel/Makefile
+++ b/java/netbeans-devel/Makefile
@@ -2,18 +2,21 @@
# $FreeBSD$
PORTNAME= netbeans
-DISTVERSION= 7.3beta
+DISTVERSION= 7.3beta2
CATEGORIES= java devel
-MASTER_SITES= http://dlc.sun.com.edgesuite.net/netbeans/7.3/beta/zip/
+MASTER_SITES= http://dlc.sun.com.edgesuite.net/netbeans/7.3/beta2/zip/
PKGNAMESUFFIX= -devel
-DISTNAME= netbeans-${DISTVERSION}-201210011125
+DISTNAME= netbeans-${DISTVERSION}-201211062253
MAINTAINER= gahr@FreeBSD.org
COMMENT= A full-featured integrated environment for Java
+LICENSE= CDDL GPLv2
+LICENSE_COMB= dual
+
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.5+
+JAVA_VERSION= 1.7+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/netbeans
diff --git a/java/netbeans-devel/distinfo b/java/netbeans-devel/distinfo
index da9127dea220..adf46305da2c 100644
--- a/java/netbeans-devel/distinfo
+++ b/java/netbeans-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netbeans-7.3beta-201210011125.zip) = 7577fd6a3f54c200e08b935ad506d340f7e8bcf0b48fd710fb2f711243bc5f2d
-SIZE (netbeans-7.3beta-201210011125.zip) = 330579915
+SHA256 (netbeans-7.3beta2-201211062253.zip) = 44dc9e0bbf74405e89807bef3d273e3e565df9915677f6cf8e6b219776bad108
+SIZE (netbeans-7.3beta2-201211062253.zip) = 323081304
diff --git a/java/netbeans-devel/files/patch-netbeans b/java/netbeans-devel/files/patch-netbeans
index c51b689277ec..ffbb1270e106 100644
--- a/java/netbeans-devel/files/patch-netbeans
+++ b/java/netbeans-devel/files/patch-netbeans
@@ -1,6 +1,6 @@
---- bin/netbeans.orig 2011-09-26 01:36:52.000000000 +0200
-+++ bin/netbeans 2012-01-04 16:50:05.000000000 +0100
-@@ -131,6 +131,10 @@
+--- bin/netbeans.orig 2012-11-07 00:53:26.000000000 +0100
++++ bin/netbeans 2012-12-04 14:42:26.000000000 +0100
+@@ -161,6 +161,10 @@
mem=`/usr/sbin/sysctl hw.memsize | tr -d [:alpha:][:space:].:`
mem=`expr $mem / 1048576`
;;
@@ -11,12 +11,20 @@
*)
;;
esac
-@@ -158,7 +162,7 @@
+@@ -188,7 +192,7 @@
if grep -v -- "-J-XX:MaxPermSize" >/dev/null <<EOF ; then
${netbeans_default_options}
EOF
- netbeans_default_options="-J-XX:MaxPermSize=384m ${netbeans_default_options}"
-+ netbeans_default_options="-J-XX:MaxPermSize=512m ${netbeans_default_options}"
++ netbeans_default_options="-J-XX:MaxPermSize=512m ${netbeans_default_options} --nosplash"
fi
launchNbexec() {
+@@ -237,6 +241,7 @@
+ --jdkhome '"$netbeans_jdkhome"' \
+ --branding nb \
+ --clusters '"$netbeans_clusters"' \
++ --nosplash \
+ -J-Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade \
+ -J-Dnetbeans.accept_license_class=org.netbeans.license.AcceptLicense \
+ ${netbeans_default_options} \
diff --git a/java/netbeans-devel/pkg-plist b/java/netbeans-devel/pkg-plist
index 97849d18ca4a..0f9f145d7f2d 100644
--- a/java/netbeans-devel/pkg-plist
+++ b/java/netbeans-devel/pkg-plist
@@ -143,6 +143,7 @@ netbeans-%%PORTVERSION%%/cnd/config/Modules/org-netbeans-modules-cnd-editor.xml
netbeans-%%PORTVERSION%%/cnd/config/Modules/org-netbeans-modules-cnd-folding.xml
netbeans-%%PORTVERSION%%/cnd/config/Modules/org-netbeans-modules-cnd-gotodeclaration.xml
netbeans-%%PORTVERSION%%/cnd/config/Modules/org-netbeans-modules-cnd-highlight.xml
+netbeans-%%PORTVERSION%%/cnd/config/Modules/org-netbeans-modules-cnd-indexing.xml
netbeans-%%PORTVERSION%%/cnd/config/Modules/org-netbeans-modules-cnd-kit.xml
netbeans-%%PORTVERSION%%/cnd/config/Modules/org-netbeans-modules-cnd-lexer.xml
netbeans-%%PORTVERSION%%/cnd/config/Modules/org-netbeans-modules-cnd-litemodel.xml
@@ -374,6 +375,7 @@ netbeans-%%PORTVERSION%%/cnd/modules/org-netbeans-modules-cnd-editor.jar
netbeans-%%PORTVERSION%%/cnd/modules/org-netbeans-modules-cnd-folding.jar
netbeans-%%PORTVERSION%%/cnd/modules/org-netbeans-modules-cnd-gotodeclaration.jar
netbeans-%%PORTVERSION%%/cnd/modules/org-netbeans-modules-cnd-highlight.jar
+netbeans-%%PORTVERSION%%/cnd/modules/org-netbeans-modules-cnd-indexing.jar
netbeans-%%PORTVERSION%%/cnd/modules/org-netbeans-modules-cnd-kit.jar
netbeans-%%PORTVERSION%%/cnd/modules/org-netbeans-modules-cnd-lexer.jar
netbeans-%%PORTVERSION%%/cnd/modules/org-netbeans-modules-cnd-litemodel.jar
@@ -420,6 +422,7 @@ netbeans-%%PORTVERSION%%/cnd/update_tracking/org-netbeans-modules-cnd-editor.xml
netbeans-%%PORTVERSION%%/cnd/update_tracking/org-netbeans-modules-cnd-folding.xml
netbeans-%%PORTVERSION%%/cnd/update_tracking/org-netbeans-modules-cnd-gotodeclaration.xml
netbeans-%%PORTVERSION%%/cnd/update_tracking/org-netbeans-modules-cnd-highlight.xml
+netbeans-%%PORTVERSION%%/cnd/update_tracking/org-netbeans-modules-cnd-indexing.xml
netbeans-%%PORTVERSION%%/cnd/update_tracking/org-netbeans-modules-cnd-kit.xml
netbeans-%%PORTVERSION%%/cnd/update_tracking/org-netbeans-modules-cnd-lexer.xml
netbeans-%%PORTVERSION%%/cnd/update_tracking/org-netbeans-modules-cnd-litemodel.xml
@@ -1362,6 +1365,7 @@ netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-cnd-edit
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-cnd-folding.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-cnd-gotodeclaration.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-cnd-highlight.xml
+netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-cnd-indexing.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-cnd-kit.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-cnd-makeproject.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-cnd-modeldiscovery.xml
@@ -1388,8 +1392,8 @@ netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-findbugs
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-form-kit.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-form.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-glassfish-javaee.xml
+netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-antproject.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-editor.xml
-netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-ejbproject.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-grails.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-grailsproject.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-gsp.xml
@@ -1397,7 +1401,6 @@ netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-k
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-refactoring.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-samples.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-support.xml
-netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-groovy-webproject.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-hibernate.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-html-navigator.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-i18n.xml
@@ -1478,8 +1481,6 @@ netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-javascri
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-javawebstart.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-junit.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-languages-apacheconf.xml
-netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-languages-ini.xml
-netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-languages-neon.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-maven-checkstyle.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-maven-coverage.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-maven-grammar.xml
@@ -1547,6 +1548,7 @@ netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-testng.x
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-tomcat5.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-web-beans.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-web-client-rest.xml
+netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-web-client-samples.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-web-clientproject-helpset.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-web-clientproject.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-web-core-syntax.xml
@@ -1594,7 +1596,6 @@ netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-websvc-r
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-websvc-restlib.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-websvc-saas-api.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-websvc-saas-codegen-j2ee.xml
-netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-websvc-saas-codegen-php.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-websvc-saas-codegen.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-websvc-saas-kit.xml
netbeans-%%PORTVERSION%%/ergonomics/config/Modules/org-netbeans-modules-websvc-saas-services-amazon.xml
@@ -1623,8 +1624,8 @@ netbeans-%%PORTVERSION%%/etc/netbeans.conf
netbeans-%%PORTVERSION%%/etc/netbeans.import
netbeans-%%PORTVERSION%%/groovy/.lastModified
netbeans-%%PORTVERSION%%/groovy/VERSION.txt
+netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-antproject.xml
netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-editor.xml
-netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-ejbproject.xml
netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-grails.xml
netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-grailsproject.xml
netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-gsp.xml
@@ -1632,7 +1633,6 @@ netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-kit.x
netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-refactoring.xml
netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-samples.xml
netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-support.xml
-netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-groovy-webproject.xml
netbeans-%%PORTVERSION%%/groovy/config/Modules/org-netbeans-modules-maven-groovy.xml
netbeans-%%PORTVERSION%%/groovy/modules/ext/groovy-all.jar
netbeans-%%PORTVERSION%%/groovy/modules/locale/org-netbeans-modules-groovy-editor_ja.jar
@@ -1671,8 +1671,8 @@ netbeans-%%PORTVERSION%%/groovy/modules/locale/org-netbeans-modules-maven-groovy
netbeans-%%PORTVERSION%%/groovy/modules/locale/org-netbeans-modules-maven-groovy_pt_BR.jar
netbeans-%%PORTVERSION%%/groovy/modules/locale/org-netbeans-modules-maven-groovy_ru.jar
netbeans-%%PORTVERSION%%/groovy/modules/locale/org-netbeans-modules-maven-groovy_zh_CN.jar
+netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-antproject.jar
netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-editor.jar
-netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-ejbproject.jar
netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-grails.jar
netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-grailsproject.jar
netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-gsp.jar
@@ -1680,10 +1680,9 @@ netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-kit.jar
netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-refactoring.jar
netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-samples.jar
netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-support.jar
-netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-groovy-webproject.jar
netbeans-%%PORTVERSION%%/groovy/modules/org-netbeans-modules-maven-groovy.jar
+netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-antproject.xml
netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-editor.xml
-netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-ejbproject.xml
netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-grails.xml
netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-grailsproject.xml
netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-gsp.xml
@@ -1691,7 +1690,6 @@ netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-kit.
netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-refactoring.xml
netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-samples.xml
netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-support.xml
-netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-groovy-webproject.xml
netbeans-%%PORTVERSION%%/groovy/update_tracking/org-netbeans-modules-maven-groovy.xml
netbeans-%%PORTVERSION%%/harness/.lastModified
netbeans-%%PORTVERSION%%/harness/README
@@ -1833,28 +1831,33 @@ netbeans-%%PORTVERSION%%/harness/update_tracking/org-netbeans-modules-nbjunit.xm
netbeans-%%PORTVERSION%%/ide/.lastModified
netbeans-%%PORTVERSION%%/ide/VERSION.txt
netbeans-%%PORTVERSION%%/ide/ant/nblib/org-netbeans-modules-web-browser-api.jar
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86/pty
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86/sigqueue
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86/stat
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86/unbuffer.so
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86_64/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86_64/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86_64/pty
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86_64/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86_64/sigqueue
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86_64/stat
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Linux-x86_64/unbuffer.so
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86/pty
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86/stat
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86/unbuffer.dylib
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86_64/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86_64/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86_64/pty
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86_64/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86_64/stat
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/MacOSX-x86_64/unbuffer.dylib
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc/privp
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc/pty
@@ -1862,6 +1865,7 @@ netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc/sigqueue
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc/stat
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc/unbuffer.so
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc_64/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc_64/privp
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc_64/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc_64/pty
@@ -1869,6 +1873,7 @@ netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc_64/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc_64/sigqueue
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc_64/stat
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-sparc_64/unbuffer.so
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86/privp
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86/pty
@@ -1876,17 +1881,20 @@ netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86/sigqueue
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86/stat
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86/unbuffer.so
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86_64/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86_64/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86_64/pty
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86_64/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86_64/sigqueue
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86_64/stat
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/SunOS-x86_64/unbuffer.so
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86/pty
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86/pty_open
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86/sigqueue
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86/unbuffer.dll
+netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86_64/killall
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86_64/process_start
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86_64/pty
netbeans-%%PORTVERSION%%/ide/bin/nativeexecution/Windows-x86_64/pty_open
@@ -4311,8 +4319,8 @@ netbeans-%%PORTVERSION%%/java/modules/ext/jaxws22/stax-ex.jar
netbeans-%%PORTVERSION%%/java/modules/ext/jaxws22/stax2-api.jar
netbeans-%%PORTVERSION%%/java/modules/ext/jaxws22/streambuffer.jar
netbeans-%%PORTVERSION%%/java/modules/ext/jaxws22/woodstox-core-asl.jar
-netbeans-%%PORTVERSION%%/java/modules/ext/maven/indexer-artifact-4.1.3.jar
-netbeans-%%PORTVERSION%%/java/modules/ext/maven/indexer-core-4.1.3.jar
+netbeans-%%PORTVERSION%%/java/modules/ext/maven/indexer-artifact-5.0.0.jar
+netbeans-%%PORTVERSION%%/java/modules/ext/maven/indexer-core-5.0.0.jar
netbeans-%%PORTVERSION%%/java/modules/ext/maven/jdom-1.0.jar
netbeans-%%PORTVERSION%%/java/modules/ext/maven/lucene-core-3.6.1.jar
netbeans-%%PORTVERSION%%/java/modules/ext/maven/lucene-highlighter-3.6.1.jar
@@ -6606,9 +6614,9 @@ netbeans-%%PORTVERSION%%/platform/modules/ext/locale/updater_pt_BR.jar
netbeans-%%PORTVERSION%%/platform/modules/ext/locale/updater_ru.jar
netbeans-%%PORTVERSION%%/platform/modules/ext/locale/updater_zh_CN.jar
netbeans-%%PORTVERSION%%/platform/modules/ext/nsProxyAutoConfig.js
-netbeans-%%PORTVERSION%%/platform/modules/ext/org.eclipse.osgi_3.7.1.R37x_v20110808-1106.jar
+netbeans-%%PORTVERSION%%/platform/modules/ext/org.eclipse.osgi_3.8.0.v20120529-1548.jar
netbeans-%%PORTVERSION%%/platform/modules/ext/osgi.cmpn-4.2.jar
-netbeans-%%PORTVERSION%%/platform/modules/ext/osgi.core-4.3.jar
+netbeans-%%PORTVERSION%%/platform/modules/ext/osgi.core-5.0.0.jar
netbeans-%%PORTVERSION%%/platform/modules/ext/platform-3.4.0.jar
netbeans-%%PORTVERSION%%/platform/modules/ext/swing-layout-1.0.4.jar
netbeans-%%PORTVERSION%%/platform/modules/ext/testng-6.5.1-dist.jar
@@ -7319,12 +7327,12 @@ netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-javascrip
netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-languages-apacheconf.xml
netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-languages-ini.xml
netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-languages-neon.xml
+netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-web-client-samples.xml
netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-web-clientproject-api.xml
netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-web-clientproject-helpset.xml
netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-web-clientproject.xml
netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-web-inspect.xml
netbeans-%%PORTVERSION%%/webcommon/config/Modules/org-netbeans-modules-web-javascript-debugger.xml
-netbeans-%%PORTVERSION%%/webcommon/modules/docs/org-netbeans-modules-web-clientproject-helpset.jar
netbeans-%%PORTVERSION%%/webcommon/modules/ext/libs.jstestdriver-ext.jar
netbeans-%%PORTVERSION%%/webcommon/modules/locale/org-netbeans-modules-languages-apacheconf_ja.jar
netbeans-%%PORTVERSION%%/webcommon/modules/locale/org-netbeans-modules-languages-apacheconf_pt_BR.jar
@@ -7340,6 +7348,7 @@ netbeans-%%PORTVERSION%%/webcommon/modules/org-netbeans-modules-javascript-jstes
netbeans-%%PORTVERSION%%/webcommon/modules/org-netbeans-modules-languages-apacheconf.jar
netbeans-%%PORTVERSION%%/webcommon/modules/org-netbeans-modules-languages-ini.jar
netbeans-%%PORTVERSION%%/webcommon/modules/org-netbeans-modules-languages-neon.jar
+netbeans-%%PORTVERSION%%/webcommon/modules/org-netbeans-modules-web-client-samples.jar
netbeans-%%PORTVERSION%%/webcommon/modules/org-netbeans-modules-web-clientproject-api.jar
netbeans-%%PORTVERSION%%/webcommon/modules/org-netbeans-modules-web-clientproject-helpset.jar
netbeans-%%PORTVERSION%%/webcommon/modules/org-netbeans-modules-web-clientproject.jar
@@ -7351,6 +7360,7 @@ netbeans-%%PORTVERSION%%/webcommon/update_tracking/org-netbeans-modules-javascri
netbeans-%%PORTVERSION%%/webcommon/update_tracking/org-netbeans-modules-languages-apacheconf.xml
netbeans-%%PORTVERSION%%/webcommon/update_tracking/org-netbeans-modules-languages-ini.xml
netbeans-%%PORTVERSION%%/webcommon/update_tracking/org-netbeans-modules-languages-neon.xml
+netbeans-%%PORTVERSION%%/webcommon/update_tracking/org-netbeans-modules-web-client-samples.xml
netbeans-%%PORTVERSION%%/webcommon/update_tracking/org-netbeans-modules-web-clientproject-api.xml
netbeans-%%PORTVERSION%%/webcommon/update_tracking/org-netbeans-modules-web-clientproject-helpset.xml
netbeans-%%PORTVERSION%%/webcommon/update_tracking/org-netbeans-modules-web-clientproject.xml
@@ -7467,7 +7477,6 @@ netbeans-%%PORTVERSION%%/websvccommon/update_tracking/org-netbeans-modules-websv
@dirrm netbeans-%%PORTVERSION%%/webcommon/update_tracking
@dirrm netbeans-%%PORTVERSION%%/webcommon/modules/locale
@dirrm netbeans-%%PORTVERSION%%/webcommon/modules/ext
-@dirrm netbeans-%%PORTVERSION%%/webcommon/modules/docs
@dirrm netbeans-%%PORTVERSION%%/webcommon/modules
@dirrm netbeans-%%PORTVERSION%%/webcommon/config/Modules
@dirrm netbeans-%%PORTVERSION%%/webcommon/config