aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-05-04 05:58:31 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-05-04 05:58:31 +0000
commit701860de0cc2cd8a96332dcc56a473beeafbbab5 (patch)
treee6fcfe8257b7720be719c135166df00961fb220a /java
parentaa40e313dbe4b4bce606a1af3041eac7a53eb7bd (diff)
downloadports-701860de0cc2cd8a96332dcc56a473beeafbbab5.tar.gz
ports-701860de0cc2cd8a96332dcc56a473beeafbbab5.zip
. Fix the specifications of MASTER_SITES -- fixes the fetching of the ANT
distribution at least. . Copy the bundles into the plugin directory during install, otherwise the install creates symlinks to the bundles in the actually port's working directory, which it means it stops working after a 'make clean'. Reported by: Ronald Klop <ronald-freebsd8@thuis.klop.ws>
Notes
Notes: svn path=/head/; revision=253659
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-devel/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/java/eclipse-devel/Makefile b/java/eclipse-devel/Makefile
index a312b187301c..71d63c5e5ef5 100644
--- a/java/eclipse-devel/Makefile
+++ b/java/eclipse-devel/Makefile
@@ -7,13 +7,14 @@
PORTNAME= eclipse-devel
PORTVERSION= 3.5.2
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/technology/linuxtools/eclipse-build/:1 \
http://download.eclipse.org/tools/orbit/downloads/drops/R20090825191606/bundles/:2 \
http://download.eclipse.org/tools/orbit/downloads/drops/S20100308015149/bundles/:3 \
- ${MASTER_SITE_APACHE:S,%SUBDIR%/,ant/binaries/,}:4 \
- ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,junit/junit/${JUNIT3_VERSION}/,}:5 \
- ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,junit/junit/${JUNIT4_VERSION}/,}:6
+ ${MASTER_SITE_APACHE:S,%SUBDIR%/,ant/binaries/:4,} \
+ ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,junit/junit/${JUNIT3_VERSION}/:5,} \
+ ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,junit/junit/${JUNIT4_VERSION}/:6,}
DISTFILES= ${ECLIPSE_BUILD_SRCFILE}:1 \
${ECLIPSE_SRCFILE}:1 \
${ANT_SRCFILE}:4 \
@@ -207,6 +208,8 @@ do-install:
${BUILD_WRKSRC}/eclipse.tmp
.endif
@${INSTALL_SCRIPT} ${WRKSRC}/eclipse.tmp ${PREFIX}/bin/${PORTNAME}
+ @cd ${BUILD_WRKSRC}/bundles && \
+ ${COPYTREE_SHARE} . ${PORTDESTDIR}/plugins/
@${PREFIX}/bin/${PORTNAME} -initialize -consolelog
-@update-desktop-database
@(cd ${PREFIX}; ${FIND} -s lib/${PORTNAME} -not -type d) >> ${TMPPLIST}