aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2019-08-23 09:08:52 +0000
committerAlex Dupre <ale@FreeBSD.org>2019-08-23 09:08:52 +0000
commit7efb3db29fa879e46a72d7bb912c55041c950e2f (patch)
tree86ad5a59c564d81d0c4d99f6bec5d85e9bf4e5bf /java
parent6f595e2bc08cf9ede8a33dacb583ca9d6b8d1b07 (diff)
downloadports-7efb3db29fa879e46a72d7bb912c55041c950e2f.tar.gz
ports-7efb3db29fa879e46a72d7bb912c55041c950e2f.zip
Various improvements:
- remove unneeded intellij-pty4j dependency - install native library for jansi - fix the "Typeahead timeout is exceeded" error - general cleanup PR: 239787
Notes
Notes: svn path=/head/; revision=509636
Diffstat (limited to 'java')
-rw-r--r--java/intellij-ultimate/Makefile27
-rw-r--r--java/intellij-ultimate/files/pkg-message.in4
-rw-r--r--java/intellij-ultimate/pkg-plist3
3 files changed, 22 insertions, 12 deletions
diff --git a/java/intellij-ultimate/Makefile b/java/intellij-ultimate/Makefile
index fadc0c31a48d..2af5d7aa735b 100644
--- a/java/intellij-ultimate/Makefile
+++ b/java/intellij-ultimate/Makefile
@@ -5,6 +5,7 @@
PORTNAME= intellij-ultimate
PORTVERSION= 2019.2
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= https://download-cf.jetbrains.com/idea/
DISTNAME= ideaIU-${PORTVERSION}-no-jbr
@@ -18,13 +19,12 @@ LICENSE_NAME= Subscription license agreement for business and organizations
LICENSE_TEXT= See: https://www.jetbrains.com/store/license.html
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-RUN_DEPENDS= intellij-fsnotifier>0:java/intellij-fsnotifier \
- intellij-pty4j>0:java/intellij-pty4j
+RUN_DEPENDS= intellij-fsnotifier>0:java/intellij-fsnotifier
USES= python:run shebangfix
USE_JAVA= yes
-JAVA_VERSION= 1.8+
+JAVA_VERSION= 8+
SHEBANG_FILES= bin/printenv.py bin/restart.py \
plugins/spy-js/server/node_modules/node-uuid/benchmark/bench.sh \
@@ -32,12 +32,12 @@ SHEBANG_FILES= bin/printenv.py bin/restart.py \
plugins/spy-js/server/proxy-osx.sh
NO_ARCH= yes
+NO_ARCH_IGNORE= libjansi.so
NO_BUILD= yes
WRKSRC= ${WRKDIR}/idea-IU-192.5728.98
SUB_FILES= idea idea.desktop pkg-message
-SUB_LIST= DATADIR=${DATADIR}
CONFLICTS= intellij-20*
do-install:
@@ -45,23 +45,30 @@ do-install:
@${RM} -r ${WRKSRC}/bin/fsnotifier \
${WRKSRC}/bin/fsnotifier-arm \
${WRKSRC}/bin/fsnotifier64 \
+ ${WRKSRC}/bin/libdbm64.so \
+ ${WRKSRC}/lib/pty4j-native/ \
${WRKSRC}/plugins/android/lib/libwebp \
- ${WRKSRC}/plugins/maven/lib/maven3/lib/jansi-native \
+ ${WRKSRC}/plugins/maven/lib/maven3/lib/jansi-native/linux32/ \
+ ${WRKSRC}/plugins/maven/lib/maven3/lib/jansi-native/linux64/ \
+ ${WRKSRC}/plugins/maven/lib/maven3/lib/jansi-native/osx/ \
+ ${WRKSRC}/plugins/maven/lib/maven3/lib/jansi-native/windows32/ \
+ ${WRKSRC}/plugins/maven/lib/maven3/lib/jansi-native/windows64/ \
${WRKSRC}/plugins/performanceTesting/bin
-# Remove the bundled native Pty4J support libraries, they are replaced
-# by java/intellij-pty4j
- @${RM} -r ${WRKSRC}/lib/pty4j-native
-# Remove bundled linux JetBrains Runtime and OpenJDK
- @${RM} -r ${WRKSRC}/jbr ${WRKSRC}/jre64
${MKDIR} ${STAGEDIR}${DATADIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} \
"! -name *\.so ! -name *\.dll ! -name *\.dylib ! -name *\.pdb ! -name *\.sh")
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} "-name *\.so")
+ @${STRIP_CMD} \
+ ${STAGEDIR}${DATADIR}/plugins/maven/lib/maven3/lib/jansi-native/freebsd32/libjansi.so \
+ ${STAGEDIR}${DATADIR}/plugins/maven/lib/maven3/lib/jansi-native/freebsd64/libjansi.so
@(cd ${WRKSRC} && ${COPYTREE_BIN} . ${STAGEDIR}${DATADIR} "-name *\.sh")
${INSTALL_SCRIPT} ${WRKDIR}/idea ${STAGEDIR}${PREFIX}/bin/idea
${INSTALL_MAN} ${FILESDIR}/idea.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKDIR}/idea.desktop ${STAGEDIR}${PREFIX}/share/applications/
# Use fsnotifier replacement provided by java/intellij-fsnotifier
${ECHO} "idea.filewatcher.executable.path=${PREFIX}/intellij/bin/fsnotifier" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
+# Fix "Typeahead timeout is exceeded" error
+ ${ECHO} "action.aware.typeAhead=false" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
# Fix slow render
${ECHO} "-Dsun.java2d.xrender=false" >> ${STAGEDIR}${DATADIR}/bin/idea.vmoptions
${ECHO} "-Dsun.java2d.xrender=false" >> ${STAGEDIR}${DATADIR}/bin/idea64.vmoptions
diff --git a/java/intellij-ultimate/files/pkg-message.in b/java/intellij-ultimate/files/pkg-message.in
index ead7a9044942..05839729a7e0 100644
--- a/java/intellij-ultimate/files/pkg-message.in
+++ b/java/intellij-ultimate/files/pkg-message.in
@@ -3,8 +3,8 @@
message: <<EOM
There is a native (faster) file watching support backed by kqueue which is
enabled by default. If you encounter problems with watching large
-trees, you can disable it by appending the following property into
-%%DATADIR%%/bin/idea.properties:
+trees, you can disable it by adding the following property via the menu
+entry Help -> Edit Custom Properties...
idea.filewatcher.disabled=true
EOM
diff --git a/java/intellij-ultimate/pkg-plist b/java/intellij-ultimate/pkg-plist
index 3bb66647b5bd..7f6c1db8a72f 100644
--- a/java/intellij-ultimate/pkg-plist
+++ b/java/intellij-ultimate/pkg-plist
@@ -10303,6 +10303,9 @@ share/applications/idea.desktop
%%DATADIR%%/plugins/maven/lib/maven3/lib/guice-4.2.1-no_aop.jar
%%DATADIR%%/plugins/maven/lib/maven3/lib/j2objc-annotations-1.1.jar
%%DATADIR%%/plugins/maven/lib/maven3/lib/jansi-1.17.1.jar
+%%DATADIR%%/plugins/maven/lib/maven3/lib/jansi-native/README.txt
+%%DATADIR%%/plugins/maven/lib/maven3/lib/jansi-native/freebsd32/libjansi.so
+%%DATADIR%%/plugins/maven/lib/maven3/lib/jansi-native/freebsd64/libjansi.so
%%DATADIR%%/plugins/maven/lib/maven3/lib/javax.inject-1.jar
%%DATADIR%%/plugins/maven/lib/maven3/lib/jcl-over-slf4j-1.7.25.jar
%%DATADIR%%/plugins/maven/lib/maven3/lib/jcl-over-slf4j.license