aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2015-04-15 15:30:07 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2015-04-15 15:30:07 +0000
commit90ddbe704571a5d6925b262855bdac5abe2637fe (patch)
treeafcb9a5a8ea1e2ab8c153db146e6d1cbb0f4561e /java
parentcbf24eb38f5ed298e29f4a9f4e7e4f4d782e1dd4 (diff)
downloadports-90ddbe704571a5d6925b262855bdac5abe2637fe.tar.gz
ports-90ddbe704571a5d6925b262855bdac5abe2637fe.zip
Fix build with GCC with recent head kernel by disabling PCH for GCC.
The case for this is a recent head kernel building an older branch that uses GCC in a jail. This is discussed at https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html It may be possible to fix GCC to do the right thing with mmap(2) but it would not be simple to make ports use a fixed GCC on older releases and without needlessly building a ports compiler when the system one would otherwise be fine without PCH. With hat: portmgr
Notes
Notes: svn path=/head/; revision=384056
Diffstat (limited to 'java')
-rw-r--r--java/openjdk7/Makefile7
-rw-r--r--java/openjdk8/Makefile5
2 files changed, 11 insertions, 1 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index a879e6f8efb2..5d2dcdf981a4 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -26,7 +26,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= dos2unix iconv gmake zip
+USES= compiler dos2unix iconv gmake zip
USE_XORG+= x11 xext xi xrender xt xtst
MAKE_ARGS= CC=${CC:Q} CXX=${CXX:Q} HOST_CC=${CC:Q}
@@ -125,6 +125,11 @@ BUILD_DEPENDS+= ${BOOTSTRAPJDKDIR}/bin/javac:${PORTSDIR}/java/bootstrap-openjdk
.include <bsd.port.pre.mk>
+# GCC is broken with PCH: https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html
+.if ${COMPILER_TYPE} == gcc
+MAKE_ENV+= USE_PRECOMPILED_HEADER=0
+.endif
+
.if empty(ICONV_LIB)
MAKE_ENV+= EXTRA_CFLAGS=-DLIBICONV_PLUG
.endif
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index 4a170fa7b888..65bbd36aeab1 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -192,6 +192,11 @@ CONFIGURE_ENV= LIBCXX="-lc++"
.endif
.endif
+# GCC is broken with PCH: https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html
+.if ${COMPILER_TYPE} == gcc
+MAKE_ARGS+= USE_PRECOMPILED_HEADER=0
+.endif
+
.if empty(ICONV_LIB)
ICONV_CPPFLAGS= -DLIBICONV_PLUG
.else