aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2019-07-26 20:46:53 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2019-07-26 20:46:53 +0000
commitea8c8ec7da96df12146a2cc428077258141791cf (patch)
tree4948f43cc5526726a30e3663b43b32a1dd49399a /java
parent9d240807dd6ea2b16bf2e56c8bda56c8e619f6b2 (diff)
downloadports-ea8c8ec7da96df12146a2cc428077258141791cf.tar.gz
ports-ea8c8ec7da96df12146a2cc428077258141791cf.zip
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3 to GCC 9.1 under most circumstances now after revision 507371. This includes ports - with USE_GCC=yes or USE_GCC=any, - with USES=fortran, - using Mk/bsd.octave.mk which in turn features USES=fortran, and - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang, c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib plus, everything INDEX-11 shows with a dependency on lang/gcc9 now. PR: 238330
Notes
Notes: svn path=/head/; revision=507372
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile1
-rw-r--r--java/intellij-fsnotifier/Makefile2
-rw-r--r--java/openjdk11/Makefile1
-rw-r--r--java/openjfx8-devel/Makefile1
-rw-r--r--java/sigar/Makefile2
-rw-r--r--java/veditor/Makefile2
6 files changed, 6 insertions, 3 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 0dbc3eb584a0..4fd8db4b40c6 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -3,6 +3,7 @@
PORTNAME= eclipse
PORTVERSION= 4.11
+PORTREVISION= 1
CATEGORIES= java devel
# Update to git-tag on git.eclipse.org
diff --git a/java/intellij-fsnotifier/Makefile b/java/intellij-fsnotifier/Makefile
index 87b62a1f6097..9ab8f8499d8a 100644
--- a/java/intellij-fsnotifier/Makefile
+++ b/java/intellij-fsnotifier/Makefile
@@ -3,7 +3,7 @@
PORTNAME= intellij-fsnotifier
PORTVERSION= 20160221
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= java devel
MAINTAINER= ports@FreeBSD.org
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index 3a32b4788455..3babfd9d528a 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openjdk
DISTVERSIONPREFIX= jdk-
DISTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
diff --git a/java/openjfx8-devel/Makefile b/java/openjfx8-devel/Makefile
index 5e6a2db083b2..43c82baa7593 100644
--- a/java/openjfx8-devel/Makefile
+++ b/java/openjfx8-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openjfx8
DISTVERSION= 8u202-b07
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= java x11-toolkits devel
MASTER_SITES= https://github.com/t6/openjfx/releases/download/release/ \
diff --git a/java/sigar/Makefile b/java/sigar/Makefile
index d30e62f27eda..5406fd3be61d 100644
--- a/java/sigar/Makefile
+++ b/java/sigar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sigar
PORTVERSION= 1.7.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= java devel
PKGNAMEPREFIX= java-
diff --git a/java/veditor/Makefile b/java/veditor/Makefile
index 473cc400c428..c2d8abadd4c5 100644
--- a/java/veditor/Makefile
+++ b/java/veditor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= veditor
PORTVERSION= 1.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java cad
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20runtime/VEditor%20${PORTVERSION}
DISTNAME= net.sourceforge.${PORTNAME}_${PORTVERSION}