aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2009-02-23 03:15:29 +0000
committerMaho Nakata <maho@FreeBSD.org>2009-02-23 03:15:29 +0000
commitebe2efd71a7503e5e21e04d71c549ec8d8138d76 (patch)
tree2c74a4d6330aa75fee1c2b26a339068fc75dda63 /java
parent8a8e6abdbdf2c631b1cd7a1dc381a1b7f0609173 (diff)
downloadports-ebe2efd71a7503e5e21e04d71c549ec8d8138d76.tar.gz
ports-ebe2efd71a7503e5e21e04d71c549ec8d8138d76.zip
OpenJDK is an open-source implementation of the Java Platform, Standard Edition.
The version has all of Sun's bug fixes up to JDK 6 Release 11 and should be the runtime equivelent to JDK6 Release 11. Much of the OpenJDK code is licensed under the GPL version 2 with the Classpath exception. The Java Hotspot virtual machine source code is licensed under the GPL version 2 only. OpenJDK 6 should supercede the java/jdk16 port at some point in time. WWW: http://openjdk.java.net/ Submitted by: Brian Gardner <brian@experts-exchange.com>
Notes
Notes: svn path=/head/; revision=228859
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/openjdk6/Makefile129
-rw-r--r--java/openjdk6/distinfo9
-rw-r--r--java/openjdk6/files/cacertsbin0 -> 40624 bytes
-rw-r--r--java/openjdk6/pkg-descr12
5 files changed, 151 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index 161a4333c405..28d6b9f718bb 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -147,6 +147,7 @@
SUBDIR += netbeans61
SUBDIR += netcomponents
SUBDIR += netrexx
+ SUBDIR += openjdk6
SUBDIR += openjit
SUBDIR += phpeclipse
SUBDIR += poseidon
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
new file mode 100644
index 000000000000..463fb1d8aedc
--- /dev/null
+++ b/java/openjdk6/Makefile
@@ -0,0 +1,129 @@
+# New ports collection makefile for: openjdk6
+# Date created: 2009/2/21
+# Whom: Brian Gardner <brian@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openjdk6
+PORTVERSION= b14
+CATEGORIES= java devel
+MASTER_SITES= http://filedb.experts-exchange.com/incoming/2009/02_w07/104611/ \
+ http://filedb.experts-exchange.com/incoming/2009/02_w08/108800/
+DISTNAME= openjdk-6-src-${PORTVERSION}-${OPENJDK_BUILDDATE}
+DISTFILES= ${DISTNAME}.zip ${CUSTOM_PATCH_NAME}.zip
+
+MAINTAINER= brian@experts-exchange.com
+COMMENT= Sun\'s java 6 virtual machine release under the GNUV2 license
+
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
+
+PATCHVERSION= 0.2.1
+OPENJDK_BUILDDATE=10-feb-2009
+CUSTOM_PATCHES_PREFIX= jdk7_bsd_changes_20090203
+CUSTOM_PATCH_NAME= patch-${PORTNAME}-freebsd-${PATCHVERSION}
+CUSTOM_UNZIPPED_PATCH_NAME= patch_${PORTNAME}_freebsd_${PATCHVERSION}
+CUSTOM_PATCH_WRKSRC= $(WRKDIR)/$(CUSTOM_UNZIPPED_PATCH_NAME)
+
+OPTIONS= DEBUG "Enable debugging support" off \
+ IPV6 "Enable IPv6 support" off \
+ WEB "Enable the browser plugin and Java Web Start" on \
+ POLICY "Install the Unlimited Strength Policy Files" off \
+
+# java extracts directly to the cwd
+WRKSRC= $(WRKDIR)
+
+USE_GMAKE= yes
+USE_JAVA= yes
+JAVA_VENDOR= freebsd bsdjava
+JAVA_VERSION= 1.6
+USE_MOTIF= yes
+
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+BUILD_DEPENDS+= $(LOCALBASE)/include/X11/Xlib.h:${PORTSDIR}/x11/xorg-libraries
+BUILD_DEPENDS+= $(LOCALBASE)/include/freetype2/freetype/freetype.h:${PORTSDIR}/print/freetype2
+BUILD_DEPENDS+= $(JAVAJARDIR)/jdk-7-icedtea-plugs/jre/lib/rt-closed.jar:${PORTSDIR}/java/icedtea6-stubs
+#BUILD_DEPENDS+= ${LOCALBASE}/bin/ant:${PORTSDIR}/devel/apache-ant
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_IPV6)
+CATEGORIES+= ipv6
+.endif
+
+# we set the arch to i586 to simulate linux.
+# there is probably a better way to due this
+.if ${ARCH} == "i386"
+ARCH= i586
+.endif
+
+OPENJDK_OSARCH= bsd-${ARCH}
+
+ONLY_FOR_ARCHS= amd64 i586
+
+BOOTSTRAP_JDKS= ${LOCALBASE}/diablo-jdk1.6.0
+
+MAKE_ENV= LANG=C LC_ALL=C ALT_BOOTDIR=${BOOTSTRAP_JDKS} \
+ ALT_HOTSPOT_IMPORT_PATH=${BOOTSTRAP_JDKS} \
+ ALT_JDK_IMPORT_PATH=${BOOTSTRAP_JDKS} \
+ ALT_FREETYPE_HEADERS_PATH=${LOCALBASE}/include \
+ ALT_FREETYPE_LIB_PATH=${LOCALBASE}/lib \
+ ALT_BINARY_PLUGS_PATH=$(JAVAJARDIR)/jdk-7-icedtea-plugs \
+ ANT_HOME=${LOCALBASE} NO_DOCS=true ALT_CUPS_HEADERS_PATH=${LOCALBASE}/include
+
+.if !defined(WITH_IPV6)
+MAKE_ENV+= DONT_ENABLE_IPV6="YES"
+.endif
+
+.if defined(WITH_DEBUG)
+MAKE_ENV+= SKIP_DEBUG_BUILD="false"
+.endif
+
+# perhaps we could check to see how many processors are availble and set this equivelent to that
+MAKE_ENV+= HOTSPOT_BUILD_JOBS=4
+
+JDK_MAJOR_VERSION= 6
+POLICYFILE= jce_policy-${JDK_MAJOR_VERSION}.zip
+
+.if defined(WITH_POLICY)
+DISTFILES+= ${POLICYFILE}
+.endif
+
+.if defined(WITH_POLICY) && !exists(${DISTDIR}/${POLICYFILE})#{
+DISTFILE_INSTRUCTIONS =\n\
+Due to licensing restrictions, certain files must be fetched manually.\n\n
+DISTFILE_INSTRUCTIONS += Please open http://java.sun.com/javase/downloads/index.jsp\n\
+in a web browser and follow the \"Download\" link for\n\
+\"Other Downloads\" to obtain the JCE policy file, ${POLICYFILE}.\n\
+This file must be placed is ${PORTSDIR}/distfiles\n\n
+.endif#}
+
+pre-fetch:
+.if defined(DISTFILE_INSTRUCTIONS)
+ @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
+ @exit 1
+.endif
+
+pre-patch:
+ (cd $(CUSTOM_PATCH_WRKSRC)/$(CUSTOM_PATCHES_PREFIX).newfiles/ && ${CP} -Rp ./ $(WRKSRC))
+ (cd $(CUSTOM_PATCH_WRKSRC)/$(CUSTOM_PATCHES_PREFIX).linuxfiles/ && ${CP} -Rp ./ $(WRKSRC))
+ (cd $(CUSTOM_PATCH_WRKSRC)/$(CUSTOM_PATCHES_PREFIX).linuxmakefiles/ && ${CP} -Rp ./ $(WRKSRC))
+ # these are expected to fail
+ ((cd $(WRKSRC) && ${CAT} $(CUSTOM_PATCH_WRKSRC)/$(CUSTOM_PATCHES_PREFIX).makepatches/*.patch | ${PATCH} -p1) || true)
+ ((cd $(WRKSRC) && ${CAT} $(CUSTOM_PATCH_WRKSRC)/$(CUSTOM_PATCHES_PREFIX).linuxpatches/*.patch | ${PATCH} -p1) || true)
+ ((cd $(WRKSRC) && ${CAT} $(CUSTOM_PATCH_WRKSRC)/$(CUSTOM_PATCHES_PREFIX).patches/*.patch | ${PATCH} -p1) || true)
+ # these patches should apply cleanly
+ ((cd $(WRKSRC) && ${CAT} $(CUSTOM_PATCH_WRKSRC)/custom_patches_$(PATCHVERSION)/*.patch | ${PATCH} -p1) || true)
+
+do-install:
+ $(MKDIR) ${PREFIX}/openjdk6/
+ ${CP} -Rp $(WRKSRC)/build/$(OPENJDK_OSARCH)/j2sdk-image/ ${PREFIX}/openjdk6/
+ ${INSTALL_DATA} ${FILESDIR}/cacerts \
+ ${PREFIX}/openjdk6/jre/lib/security/cacerts
+.if defined(WITH_POLICY)
+ ${INSTALL_DATA} ${WRKDIR}/jce/*.jar ${PREFIX}/openjdk6/jre/lib/security
+.endif
+ @${FIND} -s ${PREFIX}/openjdk6 -not -type d | \
+ ${SED} -e 's#^${PREFIX}/##' >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/java/openjdk6/distinfo b/java/openjdk6/distinfo
new file mode 100644
index 000000000000..ea5485f3f8ac
--- /dev/null
+++ b/java/openjdk6/distinfo
@@ -0,0 +1,9 @@
+MD5 (openjdk-6-src-b14-10-feb-2009.zip) = 81293479575ff7ad101b76135e28cf1c
+SHA256 (openjdk-6-src-b14-10-feb-2009.zip) = cbdc14995c1a9aaa569cf24b3f9bd32e031cd199d0715deb9bcebfd3d25bc3d8
+SIZE (openjdk-6-src-b14-10-feb-2009.zip) = 211790484
+MD5 (patch-openjdk6-freebsd-0.2.1.zip) = b29c4d2e86693623e4d62fa8f5b4627e
+SHA256 (patch-openjdk6-freebsd-0.2.1.zip) = bdaff8de3f7823b610c10bff4c2b48316aefe87112a2c2db88290b6767138a61
+SIZE (patch-openjdk6-freebsd-0.2.1.zip) = 951855
+MD5 (jce_policy-6.zip) = b20f9d6ed14e55d73a5ed204bca01e7a
+SHA256 (jce_policy-6.zip) = d0c2258c3364120b4dbf7dd1655c967eee7057ac6ae6334b5ea8ceb8bafb9262
+SIZE (jce_policy-6.zip) = 9101
diff --git a/java/openjdk6/files/cacerts b/java/openjdk6/files/cacerts
new file mode 100644
index 000000000000..9375c5eb4130
--- /dev/null
+++ b/java/openjdk6/files/cacerts
Binary files differ
diff --git a/java/openjdk6/pkg-descr b/java/openjdk6/pkg-descr
new file mode 100644
index 000000000000..fdfbcaea649d
--- /dev/null
+++ b/java/openjdk6/pkg-descr
@@ -0,0 +1,12 @@
+OpenJDK is an open-source implementation of the Java Platform, Standard Edition.
+
+The version has all of Sun's bug fixes up to JDK 6 Release 11 and should be
+the runtime equivelent to JDK6 Release 11.
+
+Much of the OpenJDK code is licensed under the GPL version 2 with the
+Classpath exception. The Java Hotspot virtual machine source code is
+licensed under the GPL version 2 only.
+
+OpenJDK 6 should supercede the java/jdk16 port at some point in time.
+
+WWW: http://openjdk.java.net/