aboutsummaryrefslogtreecommitdiff
path: root/korean
diff options
context:
space:
mode:
authorCHOI Junho <cjh@FreeBSD.org>2001-03-23 06:54:07 +0000
committerCHOI Junho <cjh@FreeBSD.org>2001-03-23 06:54:07 +0000
commitef3502c4973d80511bd2dd6bc7a1958718ac0370 (patch)
tree3a6d55b1bbfebf2d04edaee0cc83079a86177497 /korean
parent40b14bc2c0825e8b7d2abc77a2238490df4a3f3c (diff)
downloadports-ef3502c4973d80511bd2dd6bc7a1958718ac0370.tar.gz
ports-ef3502c4973d80511bd2dd6bc7a1958718ac0370.zip
ko-mkisofs, with Korean charset conversion support, activated.
Notes
Notes: svn path=/head/; revision=40250
Diffstat (limited to 'korean')
-rw-r--r--korean/Makefile1
-rw-r--r--korean/mkisofs/Makefile47
-rw-r--r--korean/mkisofs/distinfo2
-rw-r--r--korean/mkisofs/files/patch-ac11
-rw-r--r--korean/mkisofs/files/patch-ad31
-rw-r--r--korean/mkisofs/files/patch-aj41
-rw-r--r--korean/mkisofs/files/patch-bb13
-rw-r--r--korean/mkisofs/files/patch-bc42
-rw-r--r--korean/mkisofs/files/patch-bd47
-rw-r--r--korean/mkisofs/files/patch-be33
-rw-r--r--korean/mkisofs/pkg-comment1
-rw-r--r--korean/mkisofs/pkg-descr11
-rw-r--r--korean/mkisofs/pkg-plist7
13 files changed, 287 insertions, 0 deletions
diff --git a/korean/Makefile b/korean/Makefile
index 1f057c5fc432..6f5b78ff2e7c 100644
--- a/korean/Makefile
+++ b/korean/Makefile
@@ -49,6 +49,7 @@
SUBDIR += linuxdoc-sgml
SUBDIR += linux_locale
SUBDIR += mizifont
+ SUBDIR += mkisofs
SUBDIR += mule-freewnn
SUBDIR += munhwafonts-cid
SUBDIR += netscape3
diff --git a/korean/mkisofs/Makefile b/korean/mkisofs/Makefile
new file mode 100644
index 000000000000..a4bd30e81f50
--- /dev/null
+++ b/korean/mkisofs/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: mkisofs
+# Date created: 23 Mar 2001
+# Whom: cjh
+#
+# $FreeBSD$
+#
+
+PORTNAME= mkisofs
+PORTVERSION= 1.13
+CATEGORIES= korean sysutils
+MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/cdrecord/mkisofs/ \
+ ftp://ftp.gwdg.de/pub/linux/misc/cdrecord/mkisofs/ \
+ ftp://ftp.cs.tu-berlin.de/pub/misc/cdrecord/mkisofs/
+
+PATCH_SITES= ftp://ftp.kr.FreeBSD.org/pub/FreeBSD-kr/distfiles/
+PATCHFILES= mkisofs-1.13-cp949.diff.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= cjh@FreeBSD.org
+
+MAN8= apple_driver.8 isoinfo.8 mkhybrid.8 mkisofs.8
+USE_GMAKE= yes
+MAKE_ENV= COPTX="-DBSD_SCSI_SENSE_BUG"
+
+.if ${MACHINE_ARCH} == "alpha"
+post-extract:
+ ${LN} -s ${WRKSRC}/RULES/i386-freebsd-cc.rul \
+ ${WRKSRC}/RULES/alpha-freebsd-cc.rul
+.endif
+
+post-build:
+ @(cd ${WRKSRC}/mkisofs; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} apple_driver)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/OBJ/${ARCH}-freebsd-cc/mkisofs ${PREFIX}/bin
+ @${LN} ${PREFIX}/bin/mkisofs ${PREFIX}/bin/mkhybrid
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/apple_driver ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/diag/OBJ/${ARCH}-freebsd-cc/devdump ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/diag/OBJ/${ARCH}-freebsd-cc/isodump ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/diag/OBJ/${ARCH}-freebsd-cc/isoinfo ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mkisofs/diag/OBJ/${ARCH}-freebsd-cc/isovfy ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/mkisofs/mkisofs.8 ${PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/mkisofs/mkhybrid.8 ${PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/mkisofs/apple_driver.8 ${PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/mkisofs/diag/isoinfo.8 ${PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/korean/mkisofs/distinfo b/korean/mkisofs/distinfo
new file mode 100644
index 000000000000..719b02913ffb
--- /dev/null
+++ b/korean/mkisofs/distinfo
@@ -0,0 +1,2 @@
+MD5 (mkisofs-1.13.tar.gz) = 8d802d9f5892c214562c6af71e6a5714
+MD5 (mkisofs-1.13-cp949.diff.gz) = f2b05d7fbfa60506016ec9af8feb6857
diff --git a/korean/mkisofs/files/patch-ac b/korean/mkisofs/files/patch-ac
new file mode 100644
index 000000000000..c729a75dfe76
--- /dev/null
+++ b/korean/mkisofs/files/patch-ac
@@ -0,0 +1,11 @@
+--- include/schily.h.orig Mon Aug 30 16:50:46 1999
++++ include/schily.h Sat Sep 18 17:25:57 1999
+@@ -34,7 +34,7 @@
+ #define _SCHILY_H
+
+ #ifndef _STANDARD_H
+-#include <standard.h.h>
++#include <standard.h>
+ #endif
+
+ #if defined(_SIZE_T) || defined(_T_SIZE_) || defined(_T_SIZE) || \
diff --git a/korean/mkisofs/files/patch-ad b/korean/mkisofs/files/patch-ad
new file mode 100644
index 000000000000..7b89394c29d7
--- /dev/null
+++ b/korean/mkisofs/files/patch-ad
@@ -0,0 +1,31 @@
+--- RULES/i386-freebsd-cc.rul.orig Sun Aug 29 16:09:56 1999
++++ RULES/i386-freebsd-cc.rul Wed Sep 22 13:21:08 1999
+@@ -24,7 +24,8 @@
+ ###########################################################################
+
+ CPPFLAGS= $(CPPOPTS) $(CPPOPTX)
+-CFLAGS= $(COPTS) $(CWARNOPTS) $(COPTOPT) $(COPTX)
++XCFLAGS:= $(CFLAGS)
++CFLAGS= $(COPTS) $(CWARNOPTS) $(XCFLAGS) $(COPTX)
+
+ CPPOPTS= -I. -I$(ARCHDIR) -I$(OINCSDIR) $(INCDIRS:%=-I%) $(OSDEFS)
+ COPTS=
+@@ -57,14 +58,13 @@
+
+ FLOAT_OPTIONS=
+
+-CC= @echo " ==> COMPILING \"$@\""; gcc
+-LDCC= @echo " ==> LINKING \"$@\""; gcc
+-DYNLD= @echo " ==> LINKING dynamic library \"$@\""; gcc
+-RANLIB= @echo " ==> RANDOMIZING ARCHIVE \"$@\""; ranlib
++LDCC= $(CC)
++DYNLD= $(CC)
++RANLIB= ranlib
+ ARFLAGS= cr
+ LORDER= lorder
+ TSORT= tsort
+
+ RMDEP= :
+-MKDEP= @echo " ==> MAKING DEPENDENCIES \"$@\""; $(RMDEP); gcc -M
++MKDEP= $(CC) -M
+ MKDEP_OUT=
diff --git a/korean/mkisofs/files/patch-aj b/korean/mkisofs/files/patch-aj
new file mode 100644
index 000000000000..9e9fcadc63f8
--- /dev/null
+++ b/korean/mkisofs/files/patch-aj
@@ -0,0 +1,41 @@
+--- lib/cvt.c.orig Wed Sep 8 15:03:20 1999
++++ lib/cvt.c Sun Feb 25 10:06:50 2001
+@@ -31,7 +31,7 @@
+ #include <standard.h>
+
+ #ifdef HAVE_DTOA /* 4.4BSD floating point implementation */
+-extern char *__dtoa __PR((double value, int mode, int ndigit, int *decpt, int *sign, char **ep));
++extern char *__dtoa __PR((double value, int mode, int ndigit, int *decpt, int *sign, char **ep, char **resultp));
+ #endif
+
+ #ifndef HAVE_ECVT
+@@ -57,7 +57,13 @@
+ static char *buf;
+ char *bufend;
+ char *ep;
+- char *bp = __dtoa(value, 2, ndigit, decpt, sign, &ep);
++ char *bp;
++ static char *dtoaresult = NULL;
++
++ free(dtoaresult);
++ dtoaresult = NULL;
++
++ bp = __dtoa(value, 2, ndigit, decpt, sign, &ep, &dtoaresult);
+
+ if (value == 0.0) {
+ /*
+@@ -102,7 +108,13 @@
+ static char *buf;
+ char *bufend;
+ char *ep;
+- char *bp = __dtoa(value, 3, ndigit, decpt, sign, &ep);
++ char *bp;
++ static char *dtoaresult = NULL;
++
++ free(dtoaresult);
++ dtoaresult = NULL;
++
++ bp = __dtoa(value, 3, ndigit, decpt, sign, &ep, &dtoaresult);
+
+ if (value == 0.0) {
+ /*
diff --git a/korean/mkisofs/files/patch-bb b/korean/mkisofs/files/patch-bb
new file mode 100644
index 000000000000..b37ea2f81308
--- /dev/null
+++ b/korean/mkisofs/files/patch-bb
@@ -0,0 +1,13 @@
+--- mkisofs/tree.c.orig Thu Apr 27 11:44:57 2000
++++ mkisofs/tree.c Sat Apr 29 11:34:23 2000
+@@ -538,8 +538,8 @@
+ table->de_flags |= INHIBIT_JOLIET_ENTRY;
+ /* table->name = strdup("<translation table>");*/
+ table->name = strdup(trans_tbl);
+- table->table = (char *) e_malloc(ISO_ROUND_UP(tablesize));
+- memset(table->table, 0, ISO_ROUND_UP(tablesize));
++ table->table = (char *) e_malloc(ISO_ROUND_UP(tablesize+1));
++ memset(table->table, 0, ISO_ROUND_UP(tablesize+1));
+ iso9660_file_length(trans_tbl, table, 0);
+
+ if (use_RockRidge) {
diff --git a/korean/mkisofs/files/patch-bc b/korean/mkisofs/files/patch-bc
new file mode 100644
index 000000000000..b8e8c1f84a8f
--- /dev/null
+++ b/korean/mkisofs/files/patch-bc
@@ -0,0 +1,42 @@
+--- mkisofs/modes.c.orig Sun May 7 14:49:37 2000
++++ mkisofs/modes.c Thu Aug 17 21:02:57 2000
+@@ -58,7 +58,7 @@
+ int hdlen;
+ int len = 1; /* Nach SCSI Norm */
+ int try = 0;
+- struct scsi_mode_page_header *mp;
++ struct scg_scsi_mode_page_header *mp;
+
+ again:
+ fillbytes((caddr_t)mode, sizeof(mode), '\0');
+@@ -77,7 +77,7 @@
+ scgp->silent--;
+ return (FALSE);
+ } else {
+- len = ((struct scsi_mode_header *)mode)->sense_data_len + 1;
++ len = ((struct scg_scsi_mode_header *)mode)->sense_data_len + 1;
+ }
+ if (mode_sense(scgp, mode, len, page, 0) < 0) { /* Page n current */
+ scgp->silent--;
+@@ -87,9 +87,9 @@
+
+ if (scgp->verbose)
+ scsiprbytes("Mode Sense Data", mode, len - scsigetresid(scgp));
+- hdlen = sizeof(struct scsi_mode_header) +
+- ((struct scsi_mode_header *)mode)->blockdesc_len;
+- mp = (struct scsi_mode_page_header *)(mode + hdlen);
++ hdlen = sizeof(struct scg_scsi_mode_header) +
++ ((struct scg_scsi_mode_header *)mode)->blockdesc_len;
++ mp = (struct scg_scsi_mode_page_header *)(mode + hdlen);
+ if (scgp->verbose)
+ scsiprbytes("Mode Page Data", (u_char *)mp, mp->p_len+2);
+
+@@ -223,7 +223,7 @@
+ ((struct scsi_modesel_header *)modep)->sense_data_len = 0;
+ ((struct scsi_modesel_header *)modep)->res2 = 0;
+
+- i = ((struct scsi_mode_header *)modep)->blockdesc_len;
++ i = ((struct scg_scsi_mode_header *)modep)->blockdesc_len;
+ if (i > 0) {
+ i_to_3_byte(
+ ((struct scsi_mode_data *)modep)->blockdesc.nlblock,
diff --git a/korean/mkisofs/files/patch-bd b/korean/mkisofs/files/patch-bd
new file mode 100644
index 000000000000..12e64251973f
--- /dev/null
+++ b/korean/mkisofs/files/patch-bd
@@ -0,0 +1,47 @@
+--- libscg/scg/scsireg.h.orig Sun May 28 23:31:20 2000
++++ libscg/scg/scsireg.h Thu Aug 17 20:31:45 2000
+@@ -170,7 +170,7 @@
+
+ #if defined(_BIT_FIELDS_LTOH) /* Intel byteorder */
+
+-struct scsi_mode_header {
++struct scg_scsi_mode_header {
+ Ucbit sense_data_len : 8;
+ u_char medium_type;
+ Ucbit res2 : 4;
+@@ -182,7 +182,7 @@
+
+ #else /* Motorola byteorder */
+
+-struct scsi_mode_header {
++struct scg_scsi_mode_header {
+ Ucbit sense_data_len : 8;
+ u_char medium_type;
+ Ucbit write_prot : 1;
+@@ -244,7 +244,7 @@
+
+ #if defined(_BIT_FIELDS_LTOH) /* Intel byteorder */
+
+-struct scsi_mode_page_header {
++struct scg_scsi_mode_page_header {
+ Ucbit p_code : 6;
+ Ucbit res : 1;
+ Ucbit parsave : 1;
+@@ -262,7 +262,7 @@
+
+ #else /* Motorola byteorder */
+
+-struct scsi_mode_page_header {
++struct scg_scsi_mode_page_header {
+ Ucbit parsave : 1;
+ Ucbit res : 1;
+ Ucbit p_code : 6;
+@@ -988,7 +988,7 @@
+
+
+ struct scsi_mode_data {
+- struct scsi_mode_header header;
++ struct scg_scsi_mode_header header;
+ struct scsi_mode_blockdesc blockdesc;
+ union pagex {
+ struct acb_mode_data acb;
diff --git a/korean/mkisofs/files/patch-be b/korean/mkisofs/files/patch-be
new file mode 100644
index 000000000000..422bb3d976fa
--- /dev/null
+++ b/korean/mkisofs/files/patch-be
@@ -0,0 +1,33 @@
+--- mkisofs/scsi_cdr.c.orig Sun Jul 2 23:11:23 2000
++++ mkisofs/scsi_cdr.c Thu Aug 17 21:02:04 2000
+@@ -1791,7 +1791,7 @@
+ int secsize;
+ {
+ struct scsi_mode_data md;
+- int count = sizeof(struct scsi_mode_header) +
++ int count = sizeof(struct scg_scsi_mode_header) +
+ sizeof(struct scsi_mode_blockdesc);
+
+ (void)test_unit_ready(scgp); /* clear any error situation */
+@@ -2462,8 +2462,8 @@
+ return (NULL);
+
+ mp = (struct cd_mode_page_2A *)
+- (mode + sizeof(struct scsi_mode_header) +
+- ((struct scsi_mode_header *)mode)->blockdesc_len);
++ (mode + sizeof(struct scg_scsi_mode_header) +
++ ((struct scg_scsi_mode_header *)mode)->blockdesc_len);
+
+ /*
+ * Do some heuristics against pre SCSI-3/mmc VU page 2A
+@@ -2481,8 +2481,8 @@
+ if (val != 0 && val < 176)
+ return (NULL);
+
+- len -= sizeof(struct scsi_mode_header) +
+- ((struct scsi_mode_header *)mode)->blockdesc_len;
++ len -= sizeof(struct scg_scsi_mode_header) +
++ ((struct scg_scsi_mode_header *)mode)->blockdesc_len;
+ if (modep)
+ mp2 = (struct cd_mode_page_2A *)modep;
+ else
diff --git a/korean/mkisofs/pkg-comment b/korean/mkisofs/pkg-comment
new file mode 100644
index 000000000000..2f575388e578
--- /dev/null
+++ b/korean/mkisofs/pkg-comment
@@ -0,0 +1 @@
+Create iso9660/Rock Ridge/Joliet filesystems supporting Korean
diff --git a/korean/mkisofs/pkg-descr b/korean/mkisofs/pkg-descr
new file mode 100644
index 000000000000..66470bef7aaf
--- /dev/null
+++ b/korean/mkisofs/pkg-descr
@@ -0,0 +1,11 @@
+mkisofs is effectively a pre-mastering program to generate the iso9660
+filesystem - it takes a snapshot of a given directory tree, and generates
+a binary image which will correspond to an iso9660 filesystem when written
+to a block device.
+
+This patched version supports CP949/Unicode conversion.
+
+--
+CHOI Junho <cjh@FreeBSD.org>
+
+WWW: http://natural.chonnam.ac.kr/linux/mkisofs/
diff --git a/korean/mkisofs/pkg-plist b/korean/mkisofs/pkg-plist
new file mode 100644
index 000000000000..a22bb4037b45
--- /dev/null
+++ b/korean/mkisofs/pkg-plist
@@ -0,0 +1,7 @@
+bin/apple_driver
+bin/devdump
+bin/isodump
+bin/isoinfo
+bin/isovfy
+bin/mkhybrid
+bin/mkisofs