aboutsummaryrefslogtreecommitdiff
path: root/lang/afnix
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2006-10-07 18:36:44 +0000
committerJohan van Selst <johans@FreeBSD.org>2006-10-07 18:36:44 +0000
commit43204e4ee3f058d289212b1f05e5fa7e31534111 (patch)
tree0a1f8fe81cc667a577467327c5f51e78146ef478 /lang/afnix
parent00d220aa14aca171c04ca02b11f6a798da898681 (diff)
downloadports-43204e4ee3f058d289212b1f05e5fa7e31534111.tar.gz
ports-43204e4ee3f058d289212b1f05e5fa7e31534111.zip
- Fix build on FreeBSD 4.x
Reported by: krismail
Notes
Notes: svn path=/head/; revision=174833
Diffstat (limited to 'lang/afnix')
-rw-r--r--lang/afnix/Makefile2
-rw-r--r--lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak14
2 files changed, 12 insertions, 4 deletions
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 990f679ea9ae..c42122b1416b 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -42,5 +42,7 @@ post-patch:
@${REINPLACE_CMD} -e '/\.rtf/d' ${WRKSRC}/etc/Makefile
@${REINPLACE_CMD} -e '/^MANDIR/s/SHRDIR/MANPREFIX/' \
${WRKSRC}/cnf/mak/afnix-defs.mak
+ @${REINPLACE_CMD} -e '/uname -r/s/\\\./[.-]/' \
+ ${WRKSRC}/cnf/bin/afnix-guess
.include <bsd.port.post.mk>
diff --git a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
index baaecc60cb34..fbd65ddeb202 100644
--- a/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
+++ b/lang/afnix/files/patch-cnf_mak_afnix-freebsd.mak
@@ -1,5 +1,5 @@
---- cnf/mak/afnix-freebsd.mak.orig Wed Aug 31 21:59:00 2005
-+++ cnf/mak/afnix-freebsd.mak Wed Aug 31 22:00:29 2005
+--- cnf/mak/afnix-freebsd.mak.orig Sat Oct 7 20:11:57 2006
++++ cnf/mak/afnix-freebsd.mak Sat Oct 7 20:14:17 2006
@@ -18,21 +18,21 @@
# - compiler and linker section -
# ----------------------------------------------------------------------------
@@ -27,7 +27,7 @@
DBGDEFINES = -DDEBUG
OPTDEFINES =
STDINCLUDE =
-@@ -75,8 +75,8 @@
+@@ -75,14 +75,11 @@
# adjust for freebsd platform
ifeq ($(PLATNAME),freebsd)
@@ -38,7 +38,13 @@
ARFLAGS = rc
LDFLAGS = -shared
AFXCPPLIBS =
-@@ -93,7 +93,7 @@
+-ifeq ($(LKMODE),soname)
+-LDFLAGS += -Wl,-soname,$(SONAME)
+-endif
+ endif
+
+ # ----------------------------------------------------------------------------
+@@ -93,7 +90,7 @@
# adjust linker flags for freebsd
ifeq ($(PLATNAME),freebsd)