aboutsummaryrefslogtreecommitdiff
path: root/lang/angelscript/Makefile
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2013-08-12 07:56:01 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2013-08-12 07:56:01 +0000
commit16c9d3878153f27580e3e8e5fa780558fb957076 (patch)
tree6d591862660d54bc47cb959d1143b197734934a3 /lang/angelscript/Makefile
parentb163cd506ca7aa54dc1f0718f1df2028a52891f8 (diff)
downloadports-16c9d3878153f27580e3e8e5fa780558fb957076.tar.gz
ports-16c9d3878153f27580e3e8e5fa780558fb957076.zip
The AngelCode Scripting Library, or AngelScript as it is also known, is an
extremely flexible cross-platform scripting library designed to allow applications to extend their functionality through external scripts. It has been designed from the beginning to be an easy to use component, both for the application programmer and the script writer. Efforts have been made to let it call standard C functions and C++ methods with little to no need for proxy functions. The application simply registers the functions, objects, and methods that the scripts should be able to work with and nothing more has to be done with your code. The same functions used by the application internally can also be used by the scripting engine, which eliminates the need to duplicate functionality. For the script writer the scripting language follows the widely known syntax of C/C++, but without the need to worry about pointers and memory leaks. Contrary to most scripting languages, AngelScript uses the common C/C++ datatypes for more efficient communication with the host application. WWW: http://www.angelcode.com/angelscript/ PR: ports/178078 Submitted by: vg Approved by: osa (mentor)
Notes
Notes: svn path=/head/; revision=324616
Diffstat (limited to 'lang/angelscript/Makefile')
-rw-r--r--lang/angelscript/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/lang/angelscript/Makefile b/lang/angelscript/Makefile
new file mode 100644
index 000000000000..3b7a6dcac835
--- /dev/null
+++ b/lang/angelscript/Makefile
@@ -0,0 +1,44 @@
+# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= angelscript
+PORTVERSION= 2.27.0
+CATEGORIES= lang
+MASTER_SITES= http://www.angelcode.com/angelscript/sdk/files/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= vg@FreeBSD.org
+COMMENT= AngelCode Scripting Library
+
+LICENSE= ZLIB
+
+MAKEFILE= makefile
+MAKE_ARGS= LOCAL=${PREFIX}
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/sdk/angelscript/projects/gnuc/
+
+PLIST_FILES= include/angelscript.h
+
+OPTIONS_SINGLE= TYPE
+OPTIONS_SINGLE_TYPE= STATIC SHARED
+STATIC_DESC= Build static library
+SHARED_DESC= Build shared library
+OPTIONS_DEFAULT= STATIC
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSHARED}
+LIB_VERSION= 2
+MAKE_ARGS+= SHARED=1 VERSION=${LIB_VERSION}
+PLIST_FILES+= lib/libangelscript.so.${LIB_VERSION} \
+ lib/libangelscript-${LIB_VERSION}.so \
+ lib/libangelscript.so
+
+.else
+PLIST_FILES+= lib/libangelscript.a
+.endif
+
+.include <bsd.port.mk>