aboutsummaryrefslogtreecommitdiff
path: root/lang/asis
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-16 22:30:16 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-16 22:30:16 +0000
commit4a91b3d9c866697b0c2205ffbce022eef755eb63 (patch)
tree5c43472b5365367f33389f110ff7bbfddbb46711 /lang/asis
parent675c00402155825928c68f2c6fc46086814f810a (diff)
downloadports-4a91b3d9c866697b0c2205ffbce022eef755eb63.tar.gz
ports-4a91b3d9c866697b0c2205ffbce022eef755eb63.zip
lang/asis: Fix build on gcc5-aux
The OpenVMS support was removed on gcc5's GNAT so the GPL 2014 version of ASIS won't build unless the references to OpenVMS are removed. Rather than use EXTRA_PATCHES, just remove them unconditionally. This doesn't cause any issue for gcc-aux-built ASIS and the ports that use it.
Notes
Notes: svn path=/head/; revision=381453
Diffstat (limited to 'lang/asis')
-rw-r--r--lang/asis/Makefile10
-rw-r--r--lang/asis/files/patch-no-OpenVMS.diff70
2 files changed, 80 insertions, 0 deletions
diff --git a/lang/asis/Makefile b/lang/asis/Makefile
index b75055067406..1abd86769fa9 100644
--- a/lang/asis/Makefile
+++ b/lang/asis/Makefile
@@ -3,6 +3,7 @@
PORTNAME= asis
PORTVERSION= 2014
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://downloads.dragonlace.net/src/
DISTNAME= ${PORTNAME}-gpl-${PORTVERSION}-src
@@ -28,6 +29,15 @@ post-extract:
${WRKSRC}/Makefile \
${WRKSRC}/Makefile.stub \
${WRKSRC}/common.gpr
+ @${REINPLACE_CMD} -e 's|Hostparm.OpenVMS|False|' \
+ ${WRKSRC}/asis/a4g-a_types.adb \
+ ${WRKSRC}/tools/gnatmetric/asis_ul-env* \
+ ${WRKSRC}/tools/tool_utils/asis_ul-environment.adb \
+ ${WRKSRC}/tools/tool_utils/asis_ul-projects.adb \
+ ${WRKSRC}/tools/tool_utils/asis_ul-common.adb \
+ ${WRKSRC}/tools/gnatpp/gnatpp-processing.adb \
+ ${WRKSRC}/tools/gnatpp/gnatpp-output.ad[sb]
+
@${RM} -rf ${WRKSRC}/gnat
do-build:
diff --git a/lang/asis/files/patch-no-OpenVMS.diff b/lang/asis/files/patch-no-OpenVMS.diff
new file mode 100644
index 000000000000..847aed3e3fed
--- /dev/null
+++ b/lang/asis/files/patch-no-OpenVMS.diff
@@ -0,0 +1,70 @@
+OpenVMS Support was removed from gcc5-aux, so remove Name_AST_Entry
+This patch can be applied to gcc-aux version too.
+
+--- asis/a4g-a_sem.adb.orig 2014-04-10 13:38:35 UTC
++++ asis/a4g-a_sem.adb
+@@ -1317,14 +1317,12 @@ package body A4G.A_Sem is
+ Name_Complex_Representation |
+ Name_CPP_Class |
+ Name_CPP_Constructor |
+- Name_Export_Exception |
+ Name_Export_Function |
+ Name_Export_Object |
+ Name_Export_Procedure |
+ Name_Export_Valued_Procedure |
+ Name_Favor_Top_Level |
+ Name_Finalize_Storage_Only |
+- Name_Import_Exception |
+ Name_Import_Function |
+ Name_Import_Object |
+ Name_Import_Procedure |
+@@ -1371,22 +1369,6 @@ package body A4G.A_Sem is
+ end if;
+
+ -- Cases when a specific processing is needed
+- when Name_Float_Representation =>
+- Pragma_Arg := First (Pragma_Argument_Associations (Pragma_Node));
+-
+- if Present (Next (Pragma_Arg)) then
+- Pragma_Arg := Next (Pragma_Arg);
+- end if;
+-
+- Pragma_Arg := Sinfo.Expression (Pragma_Arg);
+-
+- if Entity (Pragma_Arg) = Entity_Node
+- or else
+- Chars (Pragma_Arg) = Chars (Entity_Node)
+- then
+- Result := True;
+- end if;
+-
+ when Name_Obsolescent =>
+
+ if Is_Obsolescent (Entity_Node) then
+@@ -1633,8 +1615,6 @@ package body A4G.A_Sem is
+ if not (
+ N in First_Pragma_Name .. Last_Pragma_Name
+ or else
+- N = Name_AST_Entry
+- or else
+ N = Name_CPU
+ or else
+ N = Name_Interface
+--- asis/a4g-mapping.adb.orig 2014-04-10 13:38:35 UTC
++++ asis/a4g-mapping.adb
+@@ -1884,7 +1884,6 @@ package body A4G.Mapping is
+ Attribute_Chars = Name_Address_Size or else
+ Attribute_Chars = Name_Asm_Input or else
+ Attribute_Chars = Name_Asm_Output or else
+- Attribute_Chars = Name_AST_Entry or else -- VMS
+ Attribute_Chars = Name_Bit or else
+ Attribute_Chars = Name_Bit_Position or else
+ Attribute_Chars = Name_Code_Address or else
+@@ -3169,7 +3168,6 @@ package body A4G.Mapping is
+
+ elsif Pragma_Chars in
+ First_Pragma_Name .. Last_Pragma_Name |
+- Name_AST_Entry |
+ Name_Interface
+ then
+ -- We have already checked for all the standard pragma names, so