aboutsummaryrefslogtreecommitdiff
path: root/lang/beignet
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-09-26 14:59:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-09-26 14:59:34 +0000
commit392c00ce87aeaa91bc15a6b3bb4496a608ded055 (patch)
tree40b130f8740a8ac8640b76c881955300acd59773 /lang/beignet
parent7b97259096b0df72f16568f5b49a9a33cf1b4958 (diff)
downloadports-392c00ce87aeaa91bc15a6b3bb4496a608ded055.tar.gz
ports-392c00ce87aeaa91bc15a6b3bb4496a608ded055.zip
Relax the BROKEN condition on 10.x.
libc++ on 10.1-R is too old for beignet to build, however beignet builds fine on 10.2-R. Since 10.1-R is use for building packages, this doesn't change the fact that there is no freebsd supplied package sadly.
Notes
Notes: svn path=/head/; revision=397985
Diffstat (limited to 'lang/beignet')
-rw-r--r--lang/beignet/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/beignet/Makefile b/lang/beignet/Makefile
index 2aeea643fcef..61e94d0a9e4a 100644
--- a/lang/beignet/Makefile
+++ b/lang/beignet/Makefile
@@ -29,7 +29,6 @@ CMAKE_ARGS+= -DLLVM_CONFIG_EXECUTABLE=${LOCALBASE}/bin/llvm-config${LLVMVER}
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= Beignet needs a graphics driver supported by the Intel KMS driver
-BROKEN_FreeBSD_10= Does not build. Help appreciated
BROKEN_FreeBSD_9= Beignet is only supported on FreeBSD 10.1 and newer
# running tests from makefile doesn't work quite yet, so comment them out for now.
@@ -38,6 +37,10 @@ BROKEN_FreeBSD_9= Beignet is only supported on FreeBSD 10.1 and newer
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && ${OSVERSION} < 1002000
+BROKEN= Beignet needs FreeBSD 10.2 or newer due to too old libc++ in 10.1-Release
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|llvm-dis|llvm-dis${LLVMVER}|g; \
s|clang |clang${LLVMVER} |g' \