aboutsummaryrefslogtreecommitdiff
path: root/lang/beignet
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /lang/beignet
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'lang/beignet')
-rw-r--r--lang/beignet/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/beignet/Makefile b/lang/beignet/Makefile
index ddd2d84b31d2..bcc119b0fbff 100644
--- a/lang/beignet/Makefile
+++ b/lang/beignet/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= opencl>=0:devel/opencl \
WRKSRC= ${WRKDIR}/Beignet-${PORTVERSION}-Source
-USES= cmake gmake ncurses pkgconfig shebangfix
+USES= cmake ncurses pkgconfig shebangfix
USE_XORG= sm ice x11 xext xfixes
USE_GL= gl egl
USE_LDCONFIG= ${LOCALBASE}/lib/${PORTNAME}