aboutsummaryrefslogtreecommitdiff
path: root/lang/bwbasic
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-01-19 00:33:50 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-01-19 00:33:50 +0000
commit5a576c483249647113f2a858392b654d4e97b34d (patch)
tree6f08293dbde507f7ad061f871c6048618a6f03be /lang/bwbasic
parentc3275f7d3228aa269df7ed5f6af27f46e0eb338a (diff)
downloadports-5a576c483249647113f2a858392b654d4e97b34d.tar.gz
ports-5a576c483249647113f2a858392b654d4e97b34d.zip
Change pre-patch rule slightly to extract everything under ${WRKSRC},
not ${.CURDIR}. Also remove HAS_CONFIGURE (GNU_CONFIGURE implies that).
Notes
Notes: svn path=/head/; revision=5380
Diffstat (limited to 'lang/bwbasic')
-rw-r--r--lang/bwbasic/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/lang/bwbasic/Makefile b/lang/bwbasic/Makefile
index 8713aec9970c..ae09ea0a76e4 100644
--- a/lang/bwbasic/Makefile
+++ b/lang/bwbasic/Makefile
@@ -3,31 +3,30 @@
# Date created: 16 Jan 1997
# Whom: msmith@gsoft.com.au
#
-# $Id: Makefile,v 1.5 1996/12/31 08:25:17 msmith Exp $
+# $Id: Makefile,v 1.6 1997/01/16 00:56:10 msmith Exp $
#
DISTNAME= bwbasic-2.20
CATEGORIES= lang
MASTER_SITES= ftp://ftp.rahul.net/pub/rhn/
DISTFILES= bwbasic-2.20.tar.Z bwb-2.20-patch01.tar.Z.uu.txt
-EXTRACT_ONLY= bwbasic-2.20.tar.Z
MAINTAINER= msmith@gsoft.com.au
-HAS_CONFIGURE= yes
GNU_CONFIGURE= yes
+EXTRACT_ONLY= bwbasic-2.20.tar.Z
# The patches come in a totally bizarre format; we have to
# uudecode them, unpack the resulting tarfile, and then replace
# some of the original files.
-#
-# This method pollutes the port directory temporarily.
pre-patch:
- uudecode ${DISTDIR}/bwb-2.20-patch01.tar.Z.uu.txt
- tar xzf bwb-2.20-patch01.tar.Z
+ ${MKDIR} ${WRKSRC}/tmp
+ cd ${WRKSRC}/tmp; \
+ uudecode ${DISTDIR}/bwb-2.20-patch01.tar.Z.uu.txt; \
+ tar xzf bwb-2.20-patch01.tar.Z; \
mv bwb-2.20-patch01/* ${WRKSRC}
- rm -rf bwb-2.20-patch01 bwb-2.20-patch01.tar.Z
+ ${RM} -rf ${WRKSRC}/tmp
# This puts the documentation in ${PREFIX}/share/bwbasic, and the
# test programs in ${PREFIX}/share/bwbasic/bwbtest.