aboutsummaryrefslogtreecommitdiff
path: root/lang/clisp/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-11-30 21:23:11 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-11-30 21:23:11 +0000
commit8e86b4cb2b74a7f5d043f7eea92344bf130917cf (patch)
tree0bf15f111ef347bdd63e8d9a19525862570239ee /lang/clisp/Makefile
parent32ddc123728a524eafdc621833ff46cbf7602025 (diff)
downloadports-8e86b4cb2b74a7f5d043f7eea92344bf130917cf.tar.gz
ports-8e86b4cb2b74a7f5d043f7eea92344bf130917cf.zip
- Use GCC 3.4 to build in FreeBSD >= 7 since it fails with GCC 4.x (the reason
and a proper fix will be evaluated later, together with the 2.42 update). PR: ports/117783 Submitted by: NIIMI Satoshi <sa2c@sa2c.net> Approved by: portmgr (linimon)
Notes
Notes: svn path=/head/; revision=202869
Diffstat (limited to 'lang/clisp/Makefile')
-rw-r--r--lang/clisp/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index c57a71ce0624..705c914a3268 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -52,8 +52,9 @@ MAN1= clisp.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700000 && defined(PACKAGE_BUILDING)
-BROKEN= coredumps when building on pointyhat with FreeBSD 7.x
+# Does not build with GCC 4.2.
+.if ${OSVERSION} >= 700000
+USE_GCC= 3.4
.endif
MODULES= BDB CLX_MIT CLX_NEW FASTCGI ORACLE PARI PCRE PGSQL RAWSOCK \