aboutsummaryrefslogtreecommitdiff
path: root/lang/clisp/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-05-29 09:07:21 +0000
committerJohn Marino <marino@FreeBSD.org>2014-05-29 09:07:21 +0000
commitac4ac4ee848592d1045fbf5da1ebfd8a1bbc9f2f (patch)
tree1a07ed737f9adacdb8b56c3834417bcdd12aab72 /lang/clisp/Makefile
parent27e02fd0b0f41e0e5778a398a762a51481d90311 (diff)
downloadports-ac4ac4ee848592d1045fbf5da1ebfd8a1bbc9f2f.tar.gz
ports-ac4ac4ee848592d1045fbf5da1ebfd8a1bbc9f2f.zip
lang/clisp: Unbreak by specifying proper iconv
Adding a configure argument for libiconv make clisps build with either libc or libiconv as appropriate. Fix verified on Redports on all supported platforms. PR: ports/187282 Submitted by: Robert Cina Fixed by: marino Approved by: maintainer timeout (due to impending death of port) Approved by: portmgr (implicit) Note that this port is still going to die in a few weeks, so I am not bothering to stage it.
Notes
Notes: svn path=/head/; revision=355678
Diffstat (limited to 'lang/clisp/Makefile')
-rw-r--r--lang/clisp/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index b37ab32a70fd..8c0ef7ac80cf 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -3,12 +3,12 @@
PORTNAME= clisp
PORTVERSION= 2.49
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang lisp
MASTER_SITES= GNU/${PORTNAME}/release/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Common Lisp implementation
+COMMENT= Common Lisp implementation
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GNU-GPL
@@ -28,7 +28,7 @@ WANT_GNOME= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --mandir="${MANPREFIX}/man" \
--elispdir="${DATADIR}/emacs" --vimdir="${DATADIR}/vim" \
- --docdir="${DOCSDIR}"
+ --docdir="${DOCSDIR}" --with-libiconv=${ICONV_PREFIX}
CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-portbld-freebsd${OSREL}
# Complaints if the environment changes between build stages.
MAKE_ENV= ${CONFIGURE_ENV}