aboutsummaryrefslogtreecommitdiff
path: root/lang/coffeescript
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2018-04-13 14:41:21 +0000
committerRenato Botelho <garga@FreeBSD.org>2018-04-13 14:41:21 +0000
commit666d46efbb20b534e39c4325901eee902c7c972f (patch)
tree16d8f4135fb7bd0f92e2692209c77a225c0d3250 /lang/coffeescript
parent212e367d7e6d36971388e8d5e570314785d6bbff (diff)
downloadports-666d46efbb20b534e39c4325901eee902c7c972f.tar.gz
ports-666d46efbb20b534e39c4325901eee902c7c972f.zip
CoffeeScript is a little language that compiles into JavaScript. Underneath that
awkward Java-esque patina, JavaScript has always had a gorgeous heart. It's an attempt to expose the good parts of JavaScript in a simple way. WWW: http://coffeescript.org/ PR: 227412 Submitted by: egypcio@googlemail.com Differential Revision: https://reviews.freebsd.org/D15025
Notes
Notes: svn path=/head/; revision=467243
Diffstat (limited to 'lang/coffeescript')
-rw-r--r--lang/coffeescript/Makefile38
-rw-r--r--lang/coffeescript/distinfo3
-rw-r--r--lang/coffeescript/pkg-descr5
-rw-r--r--lang/coffeescript/pkg-plist18
4 files changed, 64 insertions, 0 deletions
diff --git a/lang/coffeescript/Makefile b/lang/coffeescript/Makefile
new file mode 100644
index 000000000000..2c631b3fd188
--- /dev/null
+++ b/lang/coffeescript/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= coffeescript
+DISTVERSION= 2.2.4
+CATEGORIES= lang
+
+MAINTAINER= egypcio@googlemail.com
+COMMENT= Unfancy JavaScript
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= node:www/node
+
+USE_GITHUB= yes
+GH_ACCOUNT= jashkenas
+
+PORTEXAMPLES= *.coffee
+
+CONFLICTS_INSTALL= cake
+
+OPTIONS_DEFINE= EXAMPLES
+
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/node_modules/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/cake ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/coffee ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}/*.js \
+ ${STAGEDIR}${PREFIX}/lib/node_modules/${PORTNAME}
+
+do-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/documentation/examples/${PORTEXAMPLES} \
+ ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/lang/coffeescript/distinfo b/lang/coffeescript/distinfo
new file mode 100644
index 000000000000..9ca1df107370
--- /dev/null
+++ b/lang/coffeescript/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523012723
+SHA256 (jashkenas-coffeescript-2.2.4_GH0.tar.gz) = 933b6d761807fab47f72305b232fd38e50cb21b7268372b846c7c645abf4a3b4
+SIZE (jashkenas-coffeescript-2.2.4_GH0.tar.gz) = 1727657
diff --git a/lang/coffeescript/pkg-descr b/lang/coffeescript/pkg-descr
new file mode 100644
index 000000000000..79593263497c
--- /dev/null
+++ b/lang/coffeescript/pkg-descr
@@ -0,0 +1,5 @@
+CoffeeScript is a little language that compiles into JavaScript. Underneath that
+awkward Java-esque patina, JavaScript has always had a gorgeous heart. It's an
+attempt to expose the good parts of JavaScript in a simple way.
+
+WWW: http://coffeescript.org/
diff --git a/lang/coffeescript/pkg-plist b/lang/coffeescript/pkg-plist
new file mode 100644
index 000000000000..c93c6de17b6c
--- /dev/null
+++ b/lang/coffeescript/pkg-plist
@@ -0,0 +1,18 @@
+bin/cake
+bin/coffee
+lib/node_modules/coffeescript/browser.js
+lib/node_modules/coffeescript/cake.js
+lib/node_modules/coffeescript/coffeescript.js
+lib/node_modules/coffeescript/command.js
+lib/node_modules/coffeescript/grammar.js
+lib/node_modules/coffeescript/helpers.js
+lib/node_modules/coffeescript/index.js
+lib/node_modules/coffeescript/lexer.js
+lib/node_modules/coffeescript/nodes.js
+lib/node_modules/coffeescript/optparse.js
+lib/node_modules/coffeescript/parser.js
+lib/node_modules/coffeescript/register.js
+lib/node_modules/coffeescript/repl.js
+lib/node_modules/coffeescript/rewriter.js
+lib/node_modules/coffeescript/scope.js
+lib/node_modules/coffeescript/sourcemap.js