aboutsummaryrefslogtreecommitdiff
path: root/lang/diveintopython
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2001-09-04 11:31:05 +0000
committerJohann Visagie <wjv@FreeBSD.org>2001-09-04 11:31:05 +0000
commit74ca80fbcbdd2d4b9c08e9779f07cce2aaffa28c (patch)
treeff0e744e5cfc59d051616913fb91d9394c0581ac /lang/diveintopython
parenta679652400ce0b2d204185640d48b52bdf2a978d (diff)
downloadports-74ca80fbcbdd2d4b9c08e9779f07cce2aaffa28c.tar.gz
ports-74ca80fbcbdd2d4b9c08e9779f07cce2aaffa28c.zip
- Update to version 3.6
Notes
Notes: svn path=/head/; revision=47416
Diffstat (limited to 'lang/diveintopython')
-rw-r--r--lang/diveintopython/Makefile43
-rw-r--r--lang/diveintopython/distinfo11
-rw-r--r--lang/diveintopython/pkg-descr4
-rw-r--r--lang/diveintopython/pkg-plist26
4 files changed, 37 insertions, 47 deletions
diff --git a/lang/diveintopython/Makefile b/lang/diveintopython/Makefile
index ae5fc851f331..bbac0f832caf 100644
--- a/lang/diveintopython/Makefile
+++ b/lang/diveintopython/Makefile
@@ -6,52 +6,43 @@
#
PORTNAME= diveintopython
-PORTVERSION= 3.5
+PORTVERSION= 3.6
CATEGORIES= lang python
MASTER_SITES= http://diveintopython.org/download/
DISTNAME= ${PORTNAME}
-DISTFILES= ${DISTNAME}-html-${VERSIONSTR}.tgz \
- ${DISTNAME}-html-flat-${VERSIONSTR}.tgz \
- ${DISTNAME}-pdf-${VERSIONSTR}.tgz \
- ${DISTNAME}-text-${VERSIONSTR}.tgz \
- ${DISTNAME}-xml-${VERSIONSTR}.tgz \
- ${DISTNAME}-examples-${VERSIONSTR}.tgz
+DISTFILES= ${DISTNAME}-html-${VERSIONSTR}${EXTRACT_SUFX} \
+ ${DISTNAME}-html-flat-${VERSIONSTR}${EXTRACT_SUFX} \
+ ${DISTNAME}-pdf-${VERSIONSTR}${EXTRACT_SUFX} \
+ ${DISTNAME}-text-${VERSIONSTR}${EXTRACT_SUFX} \
+ ${DISTNAME}-examples-${VERSIONSTR}${EXTRACT_SUFX}
DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= ${DISTNAME}-html-${VERSIONSTR}.tgz \
- ${DISTNAME}-html-flat-${VERSIONSTR}.tgz \
- ${DISTNAME}-pdf-${VERSIONSTR}.tgz \
- ${DISTNAME}-text-${VERSIONSTR}.tgz
+EXTRACT_ONLY= ${DISTNAME}-html-${VERSIONSTR}${EXTRACT_SUFX}
MAINTAINER= wjv@FreeBSD.org
NO_BUILD= YES
-DIPDIR= ${PREFIX}/share/doc/diveintopython
-DIPDLDIR= ${DIPDIR}/download
+USE_ZIP= YES
+WRKSRC= ${WRKDIR}/html
+DIPDLDIR= ${DOCSDIR}/download
CPIO= cpio --quiet -pdum -R
VERSIONSTR= ${PORTVERSION}-1
post-patch:
@ ${PERL} -pi.orig -e \
- 's#<td><a[^>]*>(Windows|Mac ?OS)</a></td>##g; \
- s#UNIX</a>#compressed</a>#g;s#for UNIX \(#(#g; \
- s#<tr>(.(?!<tr>))*(Microsoft Word|Windows Help)(.(?!</tr>))*.</tr>##g; \
- s#<td>(.(?!<td>))*cn/(.(?!</td>))*.</td>##g; \
- s#zip#tgz#g' ${WRKSRC}/index.html
+ 's#<tr[^>]*>(.(?!<tr[^>]*>))*(Microsoft|Windows)(.(?!</tr>))*.</tr>##g; \
+ s#<td>(.(?!<td>))*(cn/|fr/[a-z]*\.html)(.(?!</td>))*.</td>##g' \
+ ${WRKSRC}/index.html
@ ${PERL} -pi -e \
- 's#http[^>]*(download/${PORTNAME}-examples-${VERSIONSTR}.tgz)#$$1#' \
+ 's#http[^>]*(download/${PORTNAME}-examples-${VERSIONSTR}.zip)#$$1#' \
${WRKSRC}/*.html
do-install:
@ ${MKDIR} ${DIPDLDIR}
@ cd ${WRKSRC} && find *.html *.css images \
- | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DIPDIR}
-.for format in html pdf txt
- @ ${INSTALL_DATA} ${WRKSRC}/${format}/${PORTNAME}.${format} \
- ${DIPDLDIR}
-.endfor
-.for format in html html-flat pdf text xml examples
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+.for format in html html-flat pdf text examples
@ ${INSTALL_DATA} \
- ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}-${format}-${VERSIONSTR}.tgz \
+ ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}-${format}-${VERSIONSTR}.zip \
${DIPDLDIR}
.endfor
diff --git a/lang/diveintopython/distinfo b/lang/diveintopython/distinfo
index 47c2f65c8b54..29436b21b97f 100644
--- a/lang/diveintopython/distinfo
+++ b/lang/diveintopython/distinfo
@@ -1,6 +1,5 @@
-MD5 (diveintopython/diveintopython-html-3.5-1.tgz) = e12053f26e661152d1af77ad5626591b
-MD5 (diveintopython/diveintopython-html-flat-3.5-1.tgz) = 6dcf5c824e41299e0ad945025f829cb9
-MD5 (diveintopython/diveintopython-pdf-3.5-1.tgz) = e6c945ca945abdb6af68eef188b76591
-MD5 (diveintopython/diveintopython-text-3.5-1.tgz) = d4c3257b89310ac544f2c83bae2d8766
-MD5 (diveintopython/diveintopython-xml-3.5-1.tgz) = 25c58b362521a9e7742da136651b1fb1
-MD5 (diveintopython/diveintopython-examples-3.5-1.tgz) = bb6ccadb3c02f5d82c691e90ed725f9c
+MD5 (diveintopython/diveintopython-html-3.6-1.zip) = 732609d4b9db085b4ddd70439e787015
+MD5 (diveintopython/diveintopython-html-flat-3.6-1.zip) = 06e631f6e4effa63d1314682e41b7ed8
+MD5 (diveintopython/diveintopython-pdf-3.6-1.zip) = d84eb988895f5c22bc807228ba8ae19c
+MD5 (diveintopython/diveintopython-text-3.6-1.zip) = d8f401ea297627bd3e4bfd057f6c0db3
+MD5 (diveintopython/diveintopython-examples-3.6-1.zip) = ad09c6ed21fdf2357489a2dd77b2628d
diff --git a/lang/diveintopython/pkg-descr b/lang/diveintopython/pkg-descr
index 77310e45e79c..e698695e883e 100644
--- a/lang/diveintopython/pkg-descr
+++ b/lang/diveintopython/pkg-descr
@@ -1,10 +1,10 @@
"Dive Into Python" is a Python tutorial for experienced programmers.
-The book is published under the GNU Free Documentation License, and is
+The book is published under the GNU Free Documentation License and is
available in a variety of formats. It is currently being translated into a
number of languages.
Author: Mark Pilgrim <f8dy@diveintopython.org>
WWW: http://diveintopython.org/
--- Johann Visagie <johann@egenetics.com>
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/lang/diveintopython/pkg-plist b/lang/diveintopython/pkg-plist
index ef89d1d2f591..34b54e594afd 100644
--- a/lang/diveintopython/pkg-plist
+++ b/lang/diveintopython/pkg-plist
@@ -20,16 +20,13 @@ share/doc/diveintopython/dialect_locals.html
share/doc/diveintopython/dialect_quoting.html
share/doc/diveintopython/dialect_re.html
share/doc/diveintopython/dialect_sgmllib.html
+share/doc/diveintopython/dialect_summary.html
share/doc/diveintopython/diveintopython.css
-share/doc/diveintopython/download/diveintopython-examples-3.5-1.tgz
-share/doc/diveintopython/download/diveintopython-html-3.5-1.tgz
-share/doc/diveintopython/download/diveintopython-html-flat-3.5-1.tgz
-share/doc/diveintopython/download/diveintopython-pdf-3.5-1.tgz
-share/doc/diveintopython/download/diveintopython-text-3.5-1.tgz
-share/doc/diveintopython/download/diveintopython-xml-3.5-1.tgz
-share/doc/diveintopython/download/diveintopython.html
-share/doc/diveintopython/download/diveintopython.pdf
-share/doc/diveintopython/download/diveintopython.txt
+share/doc/diveintopython/download/diveintopython-examples-3.6-1.zip
+share/doc/diveintopython/download/diveintopython-html-3.6-1.zip
+share/doc/diveintopython/download/diveintopython-html-flat-3.6-1.zip
+share/doc/diveintopython/download/diveintopython-pdf-3.6-1.zip
+share/doc/diveintopython/download/diveintopython-text-3.6-1.zip
share/doc/diveintopython/examples.html
share/doc/diveintopython/fdl.html
share/doc/diveintopython/fdl_aggregation.html
@@ -61,9 +58,6 @@ share/doc/diveintopython/fileinfo_summary.html
share/doc/diveintopython/fileinfo_userdict.html
share/doc/diveintopython/fudd.html
share/doc/diveintopython/furtherreading.html
-share/doc/diveintopython/gpl.html
-share/doc/diveintopython/gpl_howto.html
-share/doc/diveintopython/gpl_terms.html
share/doc/diveintopython/history.html
share/doc/diveintopython/images/callouts/1.png
share/doc/diveintopython/images/callouts/10.png
@@ -82,6 +76,10 @@ share/doc/diveintopython/images/note.png
share/doc/diveintopython/images/tip.png
share/doc/diveintopython/images/warning.png
share/doc/diveintopython/index.html
+share/doc/diveintopython/kgp_divein.html
+share/doc/diveintopython/kgp_dtd.html
+share/doc/diveintopython/license.html
+share/doc/diveintopython/license_terms.html
share/doc/diveintopython/odbchelper_dict.html
share/doc/diveintopython/odbchelper_divein.html
share/doc/diveintopython/odbchelper_docstring.html
@@ -99,11 +97,13 @@ share/doc/diveintopython/odbchelper_tuple.html
share/doc/diveintopython/odbchelper_vardef.html
share/doc/diveintopython/olde.html
share/doc/diveintopython/preface.html
+share/doc/diveintopython/regression_divein.html
+share/doc/diveintopython/regression_path.html
share/doc/diveintopython/roman_bugs.html
share/doc/diveintopython/roman_change.html
share/doc/diveintopython/roman_divein.html
share/doc/diveintopython/roman_failure.html
-share/doc/diveintopython/roman_getopt.html
+share/doc/diveintopython/roman_postscript.html
share/doc/diveintopython/roman_refactoring.html
share/doc/diveintopython/roman_romantest.html
share/doc/diveintopython/roman_sanity.html