aboutsummaryrefslogtreecommitdiff
path: root/lang/dmd2
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2015-12-23 19:25:48 +0000
committerCy Schubert <cy@FreeBSD.org>2015-12-23 19:25:48 +0000
commite70d3d67f87e32d0fbb7461bbdadd72c51dfa67d (patch)
treeb84fc27c6792f496a79dc3a02f90a8e419b5a960 /lang/dmd2
parent3b79030e80f96568b14dc944868d97353dc04573 (diff)
downloadports-e70d3d67f87e32d0fbb7461bbdadd72c51dfa67d.tar.gz
ports-e70d3d67f87e32d0fbb7461bbdadd72c51dfa67d.zip
Correctly locate the config file and use the correct complier when
linking. Submitted by: gahr Obtained from: https://people.freebsd.org/~gahr/lang-dmd2.diff
Notes
Notes: svn path=/head/; revision=404315
Diffstat (limited to 'lang/dmd2')
-rw-r--r--lang/dmd2/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index 56d8e3ea746e..679429bf05df 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dmd
-PKGNAMESUFFIX= 2
+PKGNAMESUFFIX= 3
PORTVERSION= 2.069.2
CATEGORIES= lang
MASTER_SITES= http://ftp.digitalmars.com/
@@ -55,7 +55,10 @@ MAKE_ARGS+= DEBUG_FLAGS=-g\ -DDEBUG=1\ -DUNITTEST
MODULEDIR= ${PREFIX}/include/d/phobos2
post-patch:
- @${REINPLACE_CMD} -e "s|g++|${CXX}|" ${WRKSRC}/posix.mak
+ @${REINPLACE_CMD} -e "s|g++|${CXX}|" \
+ -e "s|/etc|${PREFIX}/etc|" \
+ ${WRKSRC}/posix.mak
+ @${REINPLACE_CMD} -e "s|gcc|${CC}|" ${WRKSRC}/link.d
@${REINPLACE_CMD} -e "s|cc|${CC}|" ${WRKSRC}/../phobos/posix.mak
@${REINPLACE_CMD} -e "s|/etc|${PREFIX}/etc|" \
-e "s|\(dmd\)|\12|gI" \