aboutsummaryrefslogtreecommitdiff
path: root/lang/eperl
diff options
context:
space:
mode:
authorRalf S. Engelschall <rse@FreeBSD.org>1997-08-11 08:59:06 +0000
committerRalf S. Engelschall <rse@FreeBSD.org>1997-08-11 08:59:06 +0000
commit1810b2b484c53498656ebd602fcf978f1c3eb47f (patch)
tree2e6f77a6ee5b38f11447c92a8eecafe68b4764bb /lang/eperl
parent9a9845c6cfd2c862ae3370cf02ba02b914322d39 (diff)
downloadports-1810b2b484c53498656ebd602fcf978f1c3eb47f.tar.gz
ports-1810b2b484c53498656ebd602fcf978f1c3eb47f.zip
Upgrade to ePerl 2.2.1.
Reviewed by: Andreas Klemm Submitted by: Ralf S. Engelschall
Notes
Notes: svn path=/head/; revision=7528
Diffstat (limited to 'lang/eperl')
-rw-r--r--lang/eperl/Makefile80
-rw-r--r--lang/eperl/distinfo2
-rw-r--r--lang/eperl/pkg-descr9
-rw-r--r--lang/eperl/pkg-message7
-rw-r--r--lang/eperl/pkg-plist36
5 files changed, 66 insertions, 68 deletions
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
index 0ae8d9d37f0e..1fc93a438991 100644
--- a/lang/eperl/Makefile
+++ b/lang/eperl/Makefile
@@ -1,83 +1,65 @@
# New ports collection makefile for: eperl
-# Version required: 2.1.1
-# Date created: Fri May 2 13:16:31 MET DST 1997
+# Version required: 2.2.1
+# Date created: Sat Aug 2 17:22:46 MET DST 1997
# Whom: Ralf S. Engelschall <rse@engelschall.com>
#
-# $Id: Makefile,v 1.7 1997/07/18 05:04:15 asami Exp $
+# $Id$
#
-DISTNAME= eperl-2.1.1
+DISTNAME= eperl-2.2.1
CATEGORIES= lang www perl5
-MASTER_SITES= http://www.engelschall.com/sw/eperl/distrib/ \
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://www.engelschall.com/sw/eperl/distrib/ \
ftp://ftp.engelschall.com/sw/
+MASTER_SITE_SUBDIR=Parse
MAINTAINER= rse@engelschall.com
# User-controlled variables list
-#
-# Server-Side Scripting Language (SSSL) support:
-# INSTALL_ALSO_AS_SSSL - install ePerl also as SSSL for Apache
-# ENABLE_UID_SWITCHING - allow ePerl to switch the UID/GID to the
-# owner of the executed script when operating
-# as a SSSL. Implies usage of SetUID bit!
-#
-INSTALL_ALSO_AS_SSSL= yes
-#ENABLE_UID_SWITCHING= yes
+# INSTALL_ALSO_AS_SSSL
+# install ePerl also as a Server-Side
+# Scripting Language (SSSL) for Apache
+INSTALL_ALSO_AS_SSSL= no
.if defined(INSTALL_ALSO_AS_SSSL)
RUN_DEPENDS= ${PREFIX}/etc/apache/srm.conf:${PORTSDIR}/www/apache-stable
.endif
USE_PERL5= yes
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--with-perl=${PREFIX}/bin/perl
+MAN1= eperl.1
+
+post-patch:
+ rm -f ${WRKSRC}/eg/demo.errsync.phtml # remove bad file
+
+test:
+ @(cd ${WRKSRC}; make test)
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/eperl ${PREFIX}/bin/eperl
${INSTALL_MAN} ${WRKSRC}/eperl.1 ${PREFIX}/man/man1/eperl.1
-.if defined(INSTALL_ALSO_AS_SSSL)
- @if [ ! -d ${PREFIX}/www/cgi-bin ]; then \
- ${MKDIR} -p ${PREFIX}/www/cgi-bin; \
- fi
-.if defined(ENABLE_UID_SWITCHING)
- ${INSTALL_PROGRAM} -o root -m u+s ${WRKSRC}/eperl \
- ${PREFIX}/www/cgi-bin/nph-eperl
-.else
- ${INSTALL_PROGRAM} ${WRKSRC}/eperl ${PREFIX}/www/cgi-bin/nph-eperl
-.endif
-.endif
.if !defined(NOPORTDOCS)
@if [ ! -d ${PREFIX}/share/examples/eperl ]; then \
${MKDIR} -p ${PREFIX}/share/examples/eperl; \
fi
- ${INSTALL_DATA} ${WRKSRC}/eg/demo-01.phtml \
- ${PREFIX}/share/examples/eperl/demo-01.phtml
- ${INSTALL_DATA} ${WRKSRC}/eg/demo-02.phtml \
- ${PREFIX}/share/examples/eperl/demo-02.phtml
- ${INSTALL_DATA} ${WRKSRC}/eg/demo-03.phtml \
- ${PREFIX}/share/examples/eperl/demo-03.phtml
- ${INSTALL_DATA} ${WRKSRC}/eg/demo-04.phtml \
- ${PREFIX}/share/examples/eperl/demo-04.phtml
- ${INSTALL_DATA} ${WRKSRC}/eg/demo-05.phtml \
- ${PREFIX}/share/examples/eperl/demo-05.phtml
- ${INSTALL_DATA} ${WRKSRC}/eg/demo-06.phtml \
- ${PREFIX}/share/examples/eperl/demo-06.phtml
- ${INSTALL_DATA} ${WRKSRC}/eg/demo-07.phtml \
- ${PREFIX}/share/examples/eperl/demo-07.phtml
- ${INSTALL_DATA} ${WRKSRC}/eg/demo-08.phtml \
- ${PREFIX}/share/examples/eperl/demo-08.phtml
-.endif
-
+ ${CP} ${WRKSRC}/eg/* ${PREFIX}/share/examples/eperl/
+.endif
.if defined(INSTALL_ALSO_AS_SSSL)
+ @if [ ! -d ${PREFIX}/www/cgi-bin ]; then \
+ ${MKDIR} -p ${PREFIX}/www/cgi-bin; \
+ fi
+ ${INSTALL_PROGRAM} ${WRKSRC}/eperl ${PREFIX}/www/cgi-bin/nph-eperl
@if [ ".`grep x-httpd-eperl ${PREFIX}/etc/apache/srm.conf`" = . ]; then \
- echo "AddType application/x-httpd-eperl .phtml .eperl .epl" \
+ ${ECHO} "AddType application/x-httpd-eperl .phtml .eperl .epl" \
>>${PREFIX}/etc/apache/srm.conf; \
- echo "Action application/x-httpd-eperl /cgi-bin/nph-eperl" \
+ ${ECHO} "Action application/x-httpd-eperl /cgi-bin/nph-eperl" \
>>${PREFIX}/etc/apache/srm.conf; \
- echo "Added knowledge about ePerl to Apache's srm.conf"; \
+ ${ECHO} "Added knowledge about ePerl to Apache's srm.conf"; \
else \
- echo "Apache srm.conf is already aware of ePerl"; \
+ ${ECHO} "Apache srm.conf is already aware of ePerl"; \
fi
-.endif
+.endif
.include <bsd.port.mk>
diff --git a/lang/eperl/distinfo b/lang/eperl/distinfo
index ba41df3c300c..da9750b104ad 100644
--- a/lang/eperl/distinfo
+++ b/lang/eperl/distinfo
@@ -1 +1 @@
-MD5 (eperl-2.1.1.tar.gz) = 7a1836d348e4fce376f7d224528b4102
+MD5 (eperl-2.2.1.tar.gz) = da3d75d3816270c12941965a91f6466f
diff --git a/lang/eperl/pkg-descr b/lang/eperl/pkg-descr
index 5957bb79ea65..8e063209bc77 100644
--- a/lang/eperl/pkg-descr
+++ b/lang/eperl/pkg-descr
@@ -6,14 +6,13 @@
ePerl -- Embedded Perl 5 Language
- Version 2.1.1 (01-05-1997)
+ Version 2.2.1 (02-08-1997)
ePerl interprets an ASCII file bristled with Perl 5 program statements by
evaluating the Perl 5 code while passing through the plain ASCII data. It
- can operate both as a standard Unix filter for general file generation tasks
- and as a powerful Webserver scripting language for dynamic HTML page
- programming.
+ can operate in various ways: As a stand-alone Unix filter or integrated Perl
+ 5 module for general file generation tasks and as a powerful Webserver
+ scripting language for dynamic HTML page programming.
The documentation and latest release can be found on
http://www.engelschall.com/sw/eperl/
-
diff --git a/lang/eperl/pkg-message b/lang/eperl/pkg-message
index 72f0b2b38c04..ba6098db2cca 100644
--- a/lang/eperl/pkg-message
+++ b/lang/eperl/pkg-message
@@ -1,13 +1,14 @@
+
Copyright (c) 1996-1997 Ralf S. Engelschall, All rights reserved.
This program is free software; it may be redistributed and/or modified only
under the terms of either the Artistic License or the GNU General Public
License, which may be found in the ePerl source distribution. Look at the
- files ARTISTIC and COPYING or run ``eperl -l'' to receive a builtin copy of
+ files ARTISTIC and COPYING or run ``eperl -l'' to receive a built-in copy of
both license files.
This program is distributed in the hope that it will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
- FITNESS FOR A PARTICULAR PURPOSE. See either the GNU General Public License
- or the Artistic License for more details.
+ FITNESS FOR A PARTICULAR PURPOSE. See either the Artistic License or the
+ GNU General Public License for more details.
diff --git a/lang/eperl/pkg-plist b/lang/eperl/pkg-plist
index ad798f4eeb0e..7ce3fd311425 100644
--- a/lang/eperl/pkg-plist
+++ b/lang/eperl/pkg-plist
@@ -1,14 +1,30 @@
bin/eperl
www/cgi-bin/nph-eperl
-man/man1/eperl.1
-@exec echo "AddType application/x-httpd-eperl .phtml .eperl .epl" >>%D/etc/apache/srm.conf
+man/man1/eperl.1.gz
+@exec echo "AddType application/x-httpd-eperl .phtml .eperl .epl" >>%D/etc/apache/srm.conf
@exec echo "Action application/x-httpd-eperl /cgi-bin/nph-eperl" >>%D/etc/apache/srm.conf
@unexec grep -v "application/x-httpd-eperl" %D/etc/apache/srm.conf >%D/etc/apache/srm.conf.bak; mv %D/etc/apache/srm.conf.bak %D/etc/apache/srm.conf
-share/examples/eperl/demo-01.phtml
-share/examples/eperl/demo-02.phtml
-share/examples/eperl/demo-03.phtml
-share/examples/eperl/demo-04.phtml
-share/examples/eperl/demo-05.phtml
-share/examples/eperl/demo-06.phtml
-share/examples/eperl/demo-07.phtml
-share/examples/eperl/demo-08.phtml
+share/examples/eperl/00README
+share/examples/eperl/demo.cgipm.phtml
+share/examples/eperl/demo.cgipm.iphtml
+share/examples/eperl/demo.env.phtml
+share/examples/eperl/demo.env.iphtml
+share/examples/eperl/demo.errout.phtml
+share/examples/eperl/demo.errout.iphtml
+share/examples/eperl/demo.errsyn.phtml
+share/examples/eperl/demo.errsyn.iphtml
+share/examples/eperl/demo.func.phtml
+share/examples/eperl/demo.func.iphtml
+share/examples/eperl/demo.html.phtml
+share/examples/eperl/demo.html.iphtml
+share/examples/eperl/demo.image.phtml
+share/examples/eperl/demo.image.iphtml
+share/examples/eperl/demo.lwp.phtml
+share/examples/eperl/demo.lwp.iphtml
+share/examples/eperl/demo.net.phtml
+share/examples/eperl/demo.net.iphtml
+share/examples/eperl/demo.pp.phtml
+share/examples/eperl/demo.pp.iphtml
+share/examples/eperl/demo.table.phtml
+share/examples/eperl/demo.table.iphtml
+@dirrm share/examples/eperl