aboutsummaryrefslogtreecommitdiff
path: root/lang/expect
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-28 11:52:17 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-28 11:52:17 +0000
commit414adba8b1a0966caaac3ddec4a79f263515708e (patch)
treef93de004eb603174f43634a0af623513b2aba554 /lang/expect
parent8169902a2c7013552f691d9c9fb1c13acc4dca0c (diff)
downloadports-414adba8b1a0966caaac3ddec4a79f263515708e.tar.gz
ports-414adba8b1a0966caaac3ddec4a79f263515708e.zip
- Install expect scripts in DATADIR. This fixes the conflict with
astro/weather Suggested by: sunpoet
Notes
Notes: svn path=/head/; revision=346491
Diffstat (limited to 'lang/expect')
-rw-r--r--lang/expect/Makefile4
-rw-r--r--lang/expect/files/patch-Makefile.in14
-rw-r--r--lang/expect/pkg-plist43
3 files changed, 33 insertions, 28 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index e7e79498c638..db62ab0d81b6 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -3,6 +3,7 @@
PORTNAME= expect
PORTVERSION= 5.45
+PORTREVISION= 1
CATEGORIES= lang tcl tk
MASTER_SITES= SF/expect/Expect/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -10,8 +11,6 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= tcltk@FreeBSD.org
COMMENT= Sophisticated scripter based on Tcl/Tk
-CONFLICTS= weather-[0-9]*
-
LIBEXPECT_VER= ${PORTVERSION:S/.//}
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
@@ -21,6 +20,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
--exec-prefix=${PREFIX} \
+ --datadir=${DATADIR} \
--with-tclconfig=${TCL_LIBDIR} \
--with-tclinclude=${TCL_INCLUDEDIR}
PLIST_SUB+= EXPECT_VER=${PORTVERSION} \
diff --git a/lang/expect/files/patch-Makefile.in b/lang/expect/files/patch-Makefile.in
index 4ce083e57568..c8d6c04d1386 100644
--- a/lang/expect/files/patch-Makefile.in
+++ b/lang/expect/files/patch-Makefile.in
@@ -1,11 +1,15 @@
---- Makefile.in.orig 2014-02-21 14:51:15.000000000 +0100
-+++ Makefile.in 2014-02-21 14:55:44.000000000 +0100
-@@ -239,7 +239,7 @@
- @mkdir -p $(DESTDIR)$(prefix)/bin
+--- Makefile.in.orig 2010-09-30 19:14:07.000000000 +0200
++++ Makefile.in 2014-02-28 12:00:40.000000000 +0100
+@@ -236,10 +236,10 @@
+ $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir) ; \
+ done;
+ # install standalone scripts and their man pages, if requested
+- @mkdir -p $(DESTDIR)$(prefix)/bin
++ @mkdir -p $(DESTDIR)$(datadir)
-for i in $(SCRIPT_LIST) ; do \
if [ -f $$i ] ; then \
- $(INSTALL_PROGRAM) $$i $(DESTDIR)$(prefix)/bin/$$i ; \
-+ $(INSTALL_SCRIPT) $$i $(DESTDIR)$(prefix)/bin/$$i ; \
++ $(INSTALL_SCRIPT) $$i $(DESTDIR)$(datadir)/$$i ; \
rm -f $$i ; \
else true; fi ; \
done
diff --git a/lang/expect/pkg-plist b/lang/expect/pkg-plist
index 3da66a4e01ea..46d8674cbf4b 100644
--- a/lang/expect/pkg-plist
+++ b/lang/expect/pkg-plist
@@ -1,29 +1,29 @@
-bin/autoexpect
-bin/autopasswd
-bin/cryptdir
-bin/decryptdir
-bin/dislocate
bin/expect
-bin/ftp-rfc
-bin/kibitz
-bin/lpunlock
-bin/mkpasswd
-bin/multixterm
-bin/passmass
-bin/rftp
-bin/rlogin-cwd
-bin/timed-read
-bin/timed-run
-bin/tknewsbiff
-bin/tkpasswd
-bin/unbuffer
-bin/weather
-bin/xkibitz
-bin/xpstat
include/expect.h
include/expect_comm.h
include/expect_tcl.h
include/tcldbg.h
+%%DATADIR%%/autoexpect
+%%DATADIR%%/autopasswd
+%%DATADIR%%/cryptdir
+%%DATADIR%%/decryptdir
+%%DATADIR%%/dislocate
+%%DATADIR%%/ftp-rfc
+%%DATADIR%%/kibitz
+%%DATADIR%%/lpunlock
+%%DATADIR%%/mkpasswd
+%%DATADIR%%/multixterm
+%%DATADIR%%/passmass
+%%DATADIR%%/rftp
+%%DATADIR%%/rlogin-cwd
+%%DATADIR%%/timed-read
+%%DATADIR%%/timed-run
+%%DATADIR%%/tknewsbiff
+%%DATADIR%%/tkpasswd
+%%DATADIR%%/unbuffer
+%%DATADIR%%/weather
+%%DATADIR%%/xkibitz
+%%DATADIR%%/xpstat
man/man1/autoexpect.1.gz
man/man1/cryptdir.1.gz
man/man1/decryptdir.1.gz
@@ -42,3 +42,4 @@ lib/expect%%EXPECT_VER%%/libexpect%%LIBEXPECT_VER%%.so
lib/libexpect.so.1
lib/libexpect.so
@dirrm lib/expect%%EXPECT_VER%%
+@dirrm %%DATADIR%%