aboutsummaryrefslogtreecommitdiff
path: root/lang/fpc-base/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-12 21:58:15 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-12 21:58:15 +0000
commitcdcbfe77135f5c3d661cf7f2bf6b1fc576e2754d (patch)
tree4852f6626711d669889497aceb1c307e625b28e0 /lang/fpc-base/Makefile
parent84889e693f9f1c54c378826540010679dbcbd2ec (diff)
downloadports-cdcbfe77135f5c3d661cf7f2bf6b1fc576e2754d.tar.gz
ports-cdcbfe77135f5c3d661cf7f2bf6b1fc576e2754d.zip
Add fpc-base 1.0.10, meta package to install all of the
Free Pascal base. PR: 62623 Submitted by: John Merryweather Cooper <coop9211@uidaho.edu> Approved by: pav (mentor).
Notes
Notes: svn path=/head/; revision=106838
Diffstat (limited to 'lang/fpc-base/Makefile')
-rw-r--r--lang/fpc-base/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/lang/fpc-base/Makefile b/lang/fpc-base/Makefile
new file mode 100644
index 000000000000..e3c3588ddbe8
--- /dev/null
+++ b/lang/fpc-base/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: fpc-base
+# Date created: 10 February 2004
+# Whom: John Merryweather Cooper <coop9211@uidaho.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fpc-base
+PORTVERSION= 1.0.10
+CATEGORIES= lang devel
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Meta package to install all of the Free Pascal base
+
+RUN_DEPENDS= fp:${PORTSDIR}/editors/fpc-ide \
+ ${PAKGDIR}/ibase/ibase60.ppu:${PORTSDIR}/databases/fpc-ibase \
+ ${PAKGDIR}/mysql/mysql.ppu:${PORTSDIR}/databases/fpc-mysql \
+ ${PAKGDIR}/odbc/odbcsql.ppu:${PORTSDIR}/databases/fpc-odbc \
+ ${PAKGDIR}/postgres/postgres.ppu:${PORTSDIR}/databases/fpc-postgres \
+ ${PAKGDIR}/oracle/oraoci.ppu:${PORTSDIR}/databases/fpc-oracle \
+ ${PAKGDIR}/regexpr/regexpr.ppu:${PORTSDIR}/devel/fpc-regexpr \
+ ${PAKGDIR}/inet/inet.ppu:${PORTSDIR}/net/fpc-inet \
+ ${PAKGDIR}/md5/md5.ppu:${PORTSDIR}/security/fpc-md5 \
+ ${PAKGDIR}/paszlib/paszlib.ppu:${PORTSDIR}/archivers/fpc-paszlib
+
+PAKGDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/freebsd
+DOCSDIR= ${LOCALBASE}/share/doc/fpc
+EXAMPLESDIR= ${LOCALBASE}/share/examples/fpc
+
+.if !defined(NOPORTDOCS)
+RUN_DEPENDS+= ${DOCSDIR}/user.pdf:${PORTSDIR}/lang/fpc-docs \
+ ${EXAMPLESDIR}/Makefile.fpc:${PORTSDIR}/lang/fpc-demo
+.endif
+
+NO_BUILD= yes
+
+do-install: # empty
+
+.include <bsd.port.mk>