aboutsummaryrefslogtreecommitdiff
path: root/lang/gauche/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-09 18:47:42 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-09 18:47:42 +0000
commit47348c9693d57f04e54fcd287faa7b27d738bfcb (patch)
tree854654ed23ac0187d8ea6682ca1ff5cfead597d2 /lang/gauche/Makefile
parent576d2c872a30912fbba754341ed2035c893ffc13 (diff)
downloadports-47348c9693d57f04e54fcd287faa7b27d738bfcb.tar.gz
ports-47348c9693d57f04e54fcd287faa7b27d738bfcb.zip
Add gauche, a scheme script interpreter with multibyte character
handling.
Notes
Notes: svn path=/head/; revision=65934
Diffstat (limited to 'lang/gauche/Makefile')
-rw-r--r--lang/gauche/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
new file mode 100644
index 000000000000..e234999d7fa1
--- /dev/null
+++ b/lang/gauche/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: gauche
+# Date created: 9 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gauche
+PORTVERSION= 0.6.2
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Gauche-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= knu@FreeBSD.org
+
+# Choices are: "pthreads" and "no", but it seems that FreeBSD does not
+# yet fully support threads with Boehm GC.
+GAUCHE_THREADS?= no
+# Choices are: "utf-8", "euc-jp", "shift-jis" and "no"
+GAUCHE_ENCODING?= utf-8
+
+INFOSECTION= The Algorithmic Language Scheme
+
+MAN1= gosh.1 \
+ gauche-config.1
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-threads=${GAUCHE_THREADS} \
+ --enable-multibyte=${GAUCHE_ENCODING}
+INSTALL_TARGET= install-rpm
+PLIST_SUB= VERSION="${PORTVERSION}" \
+ TARGET="${CONFIGURE_TARGET}" \
+ INFOSECTION="${INFOSECTION}"
+
+post-install:
+ -${PREFIX}/bin/gosh -u slib -e "(require 'logical)" -e "(exit 0)" > /dev/null 2>&1
+.if !defined(NOPORTDOCS)
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${MANPREFIX}/man/man1/
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.info ${PREFIX}/info/
+.for info in gauche-refe.info gauche-refj.info
+ install-info --section="${INFOSECTION}" ${WRKSRC}/doc/${info} ${PREFIX}/info/dir
+.endfor
+.endif
+
+.include <bsd.port.mk>