aboutsummaryrefslogtreecommitdiff
path: root/lang/gawk
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2002-06-09 02:30:34 +0000
committerDima Dorfman <dd@FreeBSD.org>2002-06-09 02:30:34 +0000
commit76c38efeb9020b8b33adffe88d82bfbf2e8f261f (patch)
tree9ad5f2029e85809488f1bbe5ac4dfeb7c6217534 /lang/gawk
parent8ff4eda1d04da952dd4af236241806703b1fdc0f (diff)
downloadports-76c38efeb9020b8b33adffe88d82bfbf2e8f261f.tar.gz
ports-76c38efeb9020b8b33adffe88d82bfbf2e8f261f.zip
Update to 3.1.1.
PR: 38712 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=60940
Diffstat (limited to 'lang/gawk')
-rw-r--r--lang/gawk/Makefile12
-rw-r--r--lang/gawk/distinfo2
-rw-r--r--lang/gawk/files/patch-Makefile8
-rw-r--r--lang/gawk/files/patch-sec188
-rw-r--r--lang/gawk/pkg-plist27
5 files changed, 102 insertions, 35 deletions
diff --git a/lang/gawk/Makefile b/lang/gawk/Makefile
index c1b02f223399..6629f568252f 100644
--- a/lang/gawk/Makefile
+++ b/lang/gawk/Makefile
@@ -5,16 +5,20 @@
# $FreeBSD$
PORTNAME= gawk
-PORTVERSION= 3.1.0
+PORTVERSION= 3.1.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gawk
MAINTAINER= dd@FreeBSD.org
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-bitops \
- --enable-non-decimal-data
+BUILD_DEPENDS= ${LOCALBASE}/lib/libintl.a:${PORTSDIR}/devel/gettext
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
MAN1= gawk.1 igawk.1
+PLIST_SUB= VERSION=${PORTVERSION}
+
.include <bsd.port.mk>
diff --git a/lang/gawk/distinfo b/lang/gawk/distinfo
index 06b0f7cfa0fe..5a03aca539a8 100644
--- a/lang/gawk/distinfo
+++ b/lang/gawk/distinfo
@@ -1 +1 @@
-MD5 (gawk-3.1.0.tar.gz) = 789d223fc7ee4ada694071e04124a3ae
+MD5 (gawk-3.1.1.tar.gz) = 47e3754195bf32c8b78ad632bab903cd
diff --git a/lang/gawk/files/patch-Makefile b/lang/gawk/files/patch-Makefile
index cbc3d75a6b64..5f239c972b88 100644
--- a/lang/gawk/files/patch-Makefile
+++ b/lang/gawk/files/patch-Makefile
@@ -1,9 +1,9 @@
---- Makefile.in~ Wed Aug 1 15:12:53 2001
-+++ Makefile.in Wed Aug 1 15:13:00 2001
-@@ -755,7 +755,7 @@
- (fullname=gawk-`./gawk --version | sed 1q | awk '{print $$3}'` ; \
+--- Makefile.in.orig Mon Apr 29 23:36:46 2002
++++ Makefile.in Mon May 20 21:04:00 2002
+@@ -761,7 +761,7 @@
cd $(DESTDIR)$(bindir); \
$(LN) gawk $$fullname ; \
+ $(LN) pgawk p$$fullname ; \
- if [ ! -f awk ]; \
+ if ! /usr/bin/which -s awk; \
then $(LN_S) gawk awk; \
diff --git a/lang/gawk/files/patch-sec1 b/lang/gawk/files/patch-sec1
index a26de999c473..fc44a9d59368 100644
--- a/lang/gawk/files/patch-sec1
+++ b/lang/gawk/files/patch-sec1
@@ -1,6 +1,62 @@
---- doc/gawk.texi~ Wed Jul 11 01:44:15 2001
-+++ doc/gawk.texi Wed Jul 11 01:47:18 2001
-@@ -20336,8 +20336,7 @@
+--- doc/gawk.texi.orig Mon Apr 22 20:26:20 2002
++++ doc/gawk.texi Mon May 20 23:07:14 2002
+@@ -97,7 +97,7 @@
+ @finalout
+ @end iftex
+
+-@copying
++@ifinfo
+ Copyright @copyright{} 1989, 1991, 1992, 1993, 1996, 1997, 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
+ @sp 2
+
+@@ -122,7 +122,7 @@
+ software. Copies published by the Free Software Foundation raise
+ funds for GNU development.''
+ @end enumerate
+-@end copying
++@end ifinfo
+
+ @c Comment out the "smallbook" for technical review. Saves
+ @c considerable paper. Remember to turn it back on *before*
+@@ -184,8 +184,24 @@
+
+ @c This one is correct for gawk 3.1.0 from the FSF
+ ISBN 1-882114-28-0 @*
+-@sp 2
+-@insertcopying
++
++Permission is granted to copy, distribute and/or modify this document
++under the terms of the GNU Free Documentation License, Version 1.1 or
++any later version published by the Free Software Foundation; with the
++Invariant Sections being ``GNU General Public License'', the Front-Cover
++texts being (a) (see below), and with the Back-Cover Texts being (b)
++(see below). A copy of the license is included in the section entitled
++``GNU Free Documentation License''.
++
++@enumerate a
++@item
++``A GNU Manual''
++
++@item
++``You have freedom to copy and modify this GNU Manual, like GNU
++software. Copies published by the Free Software Foundation raise
++funds for GNU development.''
++@end enumerate
+ @sp 2
+ Cover art by Etienne Suvasa.
+ @end titlepage
+@@ -228,7 +244,9 @@
+ This file documents @command{awk}, a program that you can use to select
+ particular records in a file and perform operations upon them.
+
+-@insertcopying
++This is Edition @value{EDITION} of @cite{@value{TITLE}: @value{SUBTITLE}},
++for the @value{VERSION}.@value{PATCHLEVEL} (or later) version of the GNU
++implementation of AWK.
+
+ @end ifnottex
+
+@@ -21418,8 +21436,7 @@
arranges to clean up any temporary files on program exit or upon an
interrupt.
@@ -10,7 +66,7 @@
The next part loops through all the command-line arguments.
There are several cases of interest:
-@@ -20358,13 +20357,13 @@
+@@ -21440,13 +21457,13 @@
These are saved and passed on to @command{gawk}.
@item -f@r{,} --file@r{,} --file=@r{,} -Wfile=
@@ -26,8 +82,8 @@
@item --version@r{,} -Wversion
@command{igawk} prints its version number, runs @samp{gawk --version}
-@@ -20375,17 +20374,12 @@
- or @option{-Wsource} arguments are supplied, then the first non-option argument
+@@ -21457,17 +21474,12 @@
+ or @option{-Wsource} arguments are supplied, then the first nonoption argument
should be the @command{awk} program. If there are no command-line
arguments left, @command{igawk} prints an error message and exits.
-Otherwise, the first argument is echoed into @file{/tmp/ig.s.$$}.
@@ -35,11 +91,11 @@
In any case, after the arguments have been processed,
-@file{/tmp/ig.s.$$} contains the complete text of the original @command{awk}
-program.
-+the complete text of the original @code{awk} program
++the complete text of the original @command{awk} program
+is contained in a temporary file.
@cindex @command{sed} utility
--@cindex stream editor
+-@cindex stream editors
-The @samp{$$} in @command{sh} represents the current process ID number.
-It is often used in shell programs to generate unique temporary @value{FN}s.
-This allows multiple users to run @command{igawk} without worrying
@@ -47,7 +103,7 @@
The program is as follows:
@cindex @code{igawk.sh} program
-@@ -20400,6 +20394,18 @@
+@@ -21482,6 +21494,18 @@
# Arnold Robbins, arnold@@gnu.org, Public Domain
# July 1993
@@ -66,7 +122,7 @@
@c endfile
@end ignore
@c file eg/prog/igawk.sh
-@@ -20409,7 +20415,7 @@
+@@ -21491,7 +21515,7 @@
shift
else
# cleanup on exit, hangup, interrupt, quit, termination
@@ -75,7 +131,7 @@
fi
while [ $# -ne 0 ] # loop over arguments
-@@ -20426,26 +20432,26 @@
+@@ -21508,26 +21532,26 @@
-[vF]*) opts="$opts '$1'" ;;
@@ -108,7 +164,7 @@
shift;;
-?version)
-@@ -20460,7 +20466,7 @@
+@@ -21542,7 +21566,7 @@
shift
done
@@ -117,7 +173,7 @@
then
@group
if [ -z "$1" ]
-@@ -20469,12 +20475,12 @@
+@@ -21551,12 +21575,12 @@
exit 1
@end group
else
@@ -132,7 +188,7 @@
@c endfile
@end example
-@@ -20553,7 +20559,7 @@
+@@ -21635,7 +21659,7 @@
@c endfile
@end example
@@ -141,7 +197,7 @@
The main loop comes next. Input lines are read in succession. Lines that
do not start with @samp{@@include} are printed verbatim.
If the line does start with @samp{@@include}, the @value{FN} is in @code{$2}.
-@@ -20599,7 +20605,7 @@
+@@ -21681,7 +21705,7 @@
@}
close(input[stackptr])
@}
@@ -150,7 +206,7 @@
@c endfile
@end example
-@@ -20625,7 +20631,7 @@
+@@ -21707,7 +21731,7 @@
@example
@c file eg/prog/igawk.sh
diff --git a/lang/gawk/pkg-plist b/lang/gawk/pkg-plist
index efbc23fa2079..a1001b85d5f0 100644
--- a/lang/gawk/pkg-plist
+++ b/lang/gawk/pkg-plist
@@ -1,13 +1,16 @@
bin/gawk
-bin/pgawk
-bin/gawk-3.1.0
+bin/gawk-%%VERSION%%
bin/igawk
+bin/pgawk
+bin/pgawk-%%VERSION%%
+@unexec install-info --delete %D/info/gawk.info %D/info/dir
info/gawk.info
+@exec install-info %D/info/gawk.info %D/info/dir
+@unexec install-info --delete %D/info/gawkinet.info %D/info/dir
info/gawkinet.info
-libexec/awk/pwcat
+@exec install-info %D/info/gawkinet.info %D/info/dir
libexec/awk/grcat
-share/awk/passwd.awk
-share/awk/group.awk
+libexec/awk/pwcat
share/awk/assert.awk
share/awk/bits2str.awk
share/awk/cliff_rand.awk
@@ -15,18 +18,22 @@ share/awk/ctime.awk
share/awk/ftrans.awk
share/awk/getopt.awk
share/awk/gettime.awk
+share/awk/group.awk
share/awk/join.awk
share/awk/libintl.awk
share/awk/nextfile.awk
share/awk/noassign.awk
share/awk/ord.awk
+share/awk/passwd.awk
share/awk/readable.awk
share/awk/rewind.awk
share/awk/round.awk
+share/locale/de/LC_MESSAGES/gawk.mo
+share/locale/es/LC_MESSAGES/gawk.mo
+share/locale/fr/LC_MESSAGES/gawk.mo
share/locale/he/LC_MESSAGES/gawk.mo
-@exec install-info %D/info/gawk.info %D/info/dir
-@unexec install-info --delete %D/info/gawk.info %D/info/dir
-@exec install-info %D/info/gawkinet.info %D/info/dir
-@unexec install-info --delete %D/info/gawkinet.info %D/info/dir
-@dirrm libexec/awk
+share/locale/it/LC_MESSAGES/gawk.mo
+share/locale/sv/LC_MESSAGES/gawk.mo
+share/locale/tr/LC_MESSAGES/gawk.mo
@dirrm share/awk
+@dirrm libexec/awk