aboutsummaryrefslogtreecommitdiff
path: root/lang/gawk
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-11 04:09:47 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-11 04:09:47 +0000
commitf106a0addf5edb05b032b4bde75c919491b417e4 (patch)
treeaac745664d99aea7c5b189d21786055bf4c856ee /lang/gawk
parent21b00c4d9a872a4b9e9dcb5cacb94c9ce12c07dc (diff)
downloadports-f106a0addf5edb05b032b4bde75c919491b417e4.tar.gz
ports-f106a0addf5edb05b032b4bde75c919491b417e4.zip
On recent 5-CURRENT, stop configure from detecting wchar support,
since gawk fails to build with wchar/mbstring support due to lack of wcscoll(). Approved by: dd (MAINTAINER)
Notes
Notes: svn path=/head/; revision=66103
Diffstat (limited to 'lang/gawk')
-rw-r--r--lang/gawk/Makefile8
-rw-r--r--lang/gawk/files/extra-patch-nowchar11
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/gawk/Makefile b/lang/gawk/Makefile
index 6629f568252f..be3ebfc6dfb4 100644
--- a/lang/gawk/Makefile
+++ b/lang/gawk/Makefile
@@ -14,6 +14,12 @@ MAINTAINER= dd@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libintl.a:${PORTSDIR}/devel/gettext
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500039
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-nowchar
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE}
@@ -21,4 +27,4 @@ MAN1= gawk.1 igawk.1
PLIST_SUB= VERSION=${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/gawk/files/extra-patch-nowchar b/lang/gawk/files/extra-patch-nowchar
new file mode 100644
index 000000000000..2ca72233ddaa
--- /dev/null
+++ b/lang/gawk/files/extra-patch-nowchar
@@ -0,0 +1,11 @@
+--- configure.orig Mon Apr 29 23:36:47 2002
++++ configure Wed Sep 11 02:22:41 2002
+@@ -4789,7 +4789,7 @@
+ for ac_hdr in fcntl.h limits.h locale.h libintl.h mcheck.h \
+ netdb.h netinet/in.h signum.h stdarg.h string.h \
+ sys/param.h sys/socket.h sys/time.h unistd.h \
+- wchar.h wctype.h
++
+ do
+ ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
+ echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6