aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc10-devel/Makefile
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2019-12-01 00:03:18 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2019-12-01 00:03:18 +0000
commit5e91787f443ce5f2e66fdde29e99a876228f80b1 (patch)
treec8a72c4bd03b1e1978a28e813631d02bac9d7dca /lang/gcc10-devel/Makefile
parent6361804dbfda228264dddc24bcf2e5a84b7de3d6 (diff)
downloadports-5e91787f443ce5f2e66fdde29e99a876228f80b1.tar.gz
ports-5e91787f443ce5f2e66fdde29e99a876228f80b1.zip
On versions of FreeBSD that that are new enough and made that switch
already, use ELFv2 ABI on powerpc64. This already is part of lang/gcc8 and lang/gcc9 (and their -devel siblings); given this is the future of powerpc64 on FreeBSD ensure GCC development trunk is adopting this as early as possible.
Notes
Notes: svn path=/head/; revision=518744
Diffstat (limited to 'lang/gcc10-devel/Makefile')
-rw-r--r--lang/gcc10-devel/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/gcc10-devel/Makefile b/lang/gcc10-devel/Makefile
index 7803bc2d43f2..660d0ca4f18b 100644
--- a/lang/gcc10-devel/Makefile
+++ b/lang/gcc10-devel/Makefile
@@ -68,7 +68,11 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.elif ${ARCH} == powerpc64
CONFIGURE_ENV+= UNAME_m="powerpc64"
+. if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
+CONFIGURE_ARGS+= --with-abi=elfv2
+. else
USE_GCC= yes
+. endif
.endif
LANGUAGES:= c,c++,objc,fortran