aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc30
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1999-06-15 07:31:21 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1999-06-15 07:31:21 +0000
commit2f3c81d522e1ca33e19d056f8d2c3b9d9f980f93 (patch)
treeb5a940aeccb2e821104480faab5c0bcca1b16a89 /lang/gcc30
parent3aa5224366663f616123810b1f2e58e5a4bdbfae (diff)
downloadports-2f3c81d522e1ca33e19d056f8d2c3b9d9f980f93.tar.gz
ports-2f3c81d522e1ca33e19d056f8d2c3b9d9f980f93.zip
Update to the 1999-06-08 (gcc 2.95 prerelease).
Notes
Notes: svn path=/head/; revision=19484
Diffstat (limited to 'lang/gcc30')
-rw-r--r--lang/gcc30/Makefile5
-rw-r--r--lang/gcc30/distinfo12
-rw-r--r--lang/gcc30/files/patch-ad35
-rw-r--r--lang/gcc30/files/patch-af84
-rw-r--r--lang/gcc30/files/patch-ak21
-rw-r--r--lang/gcc30/files/patch-al43
6 files changed, 82 insertions, 118 deletions
diff --git a/lang/gcc30/Makefile b/lang/gcc30/Makefile
index 9ffb90147064..52237d21c051 100644
--- a/lang/gcc30/Makefile
+++ b/lang/gcc30/Makefile
@@ -4,10 +4,10 @@
# Date created: 9 Jan 1998
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.61 1999/06/05 22:30:28 mharo Exp $
+# $Id: Makefile,v 1.62 1999/06/10 14:31:08 simokawa Exp $
#
-SNAPDATE= 1999-05-24
+SNAPDATE= 1999-06-08
SNAPVER= ${SNAPDATE:S/-//g}
DISTNAME= egcs-${SNAPVER}
@@ -60,7 +60,6 @@ ALL_TARGET= bootstrap
MAN1= cccp.1 eg++.1 eg77.1 egcc.1
pre-patch:
- ${MV} ${WRKSRC}/gcc/config/i386/t-freebsd ${WRKSRC}/gcc/config/
${MV} ${WRKSRC}/gcc/config/i386/freebsd.h ${WRKSRC}/gcc/config/i386/freebsd-aout.h
${MV} ${WRKSRC}/gcc/config/i386/freebsd-elf.h ${WRKSRC}/gcc/config/i386/freebsd.h
${CP} ${FILESDIR}/alpha-freebsd.h ${WRKSRC}/gcc/config/alpha/freebsd.h
diff --git a/lang/gcc30/distinfo b/lang/gcc30/distinfo
index e00c6072a432..24d7fe3493b8 100644
--- a/lang/gcc30/distinfo
+++ b/lang/gcc30/distinfo
@@ -1,6 +1,6 @@
-MD5 (egcs-chill-19990524.tar.gz) = bc50557736795cefe6b50c02be3caac2
-MD5 (egcs-core-19990524.tar.gz) = d23a6bae74f2dec380306e4fce48834d
-MD5 (egcs-g++-19990524.tar.gz) = 8b88afbe4ce43462f35de8a3f372ceea
-MD5 (egcs-g77-19990524.tar.gz) = 2b854d664d253a4f60d074efee3e23c4
-MD5 (egcs-java-19990524.tar.gz) = 9e85cc0d4b6dafb0d126a42954e00daf
-MD5 (egcs-objc-19990524.tar.gz) = 45fb7383fd304b1d84b7f96aacf612de
+MD5 (egcs-chill-19990608.tar.gz) = 9a29050c8838fe7be70282ce2a56bd44
+MD5 (egcs-core-19990608.tar.gz) = 1e08bc2c0673cc415b85aaea8a59b837
+MD5 (egcs-g++-19990608.tar.gz) = 921e8fba270e2265c5ce450d6c7dd699
+MD5 (egcs-g77-19990608.tar.gz) = bf03ee0ea29db9e7ff4bf95d49778bcf
+MD5 (egcs-java-19990608.tar.gz) = 23697a855b42a88a39cdbaaa4b752ece
+MD5 (egcs-objc-19990608.tar.gz) = 4d05cce37f5f5ff3292a4080739ae920
diff --git a/lang/gcc30/files/patch-ad b/lang/gcc30/files/patch-ad
index dcddb18e53b4..f8a3b90fdb1a 100644
--- a/lang/gcc30/files/patch-ad
+++ b/lang/gcc30/files/patch-ad
@@ -1,5 +1,5 @@
---- gcc/config/i386/freebsd-aout.h.orig Tue Mar 23 13:34:48 1999
-+++ gcc/config/i386/freebsd-aout.h Mon Apr 19 15:10:47 1999
+--- gcc/config/i386/freebsd-aout.h.orig Tue Jun 1 17:02:37 1999
++++ gcc/config/i386/freebsd-aout.h Mon Jun 14 14:11:20 1999
@@ -20,6 +20,10 @@
the Free Software Foundation, 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA. */
@@ -85,34 +85,9 @@
/* Write the extra assembler code needed to declare a function's result.
Most svr4 assemblers don't require any special declaration of the
result value, but there are exceptions. */
-@@ -246,29 +246,4 @@
+@@ -245,3 +245,5 @@
+ #define STARTFILE_SPEC \
"%{shared:c++rt0.o%s} \
%{!shared:%{pg:gcrt0.o%s}%{!pg:%{static:scrt0.o%s}%{!static:crt0.o%s}}}"
-
--/* This is defined when gcc is compiled in the BSD-directory-tree, and must
-- * make up for the gap to all the stuff done in the GNU-makefiles.
-- */
--
--#ifdef FREEBSD_NATIVE
--
--#define INCLUDE_DEFAULTS { \
-- { "/usr/include", 0, 0, 0 }, \
-- { "/usr/include/g++", "G++", 1, 1 }, \
-- { 0, 0, 0, 0} \
-- }
--
--#undef MD_EXEC_PREFIX
--#define MD_EXEC_PREFIX "/usr/libexec/"
--
--#undef STANDARD_STARTFILE_PREFIX
--#define STANDARD_STARTFILE_PREFIX "/usr/lib"
--
--#if 0 /* This is very wrong!!! */
--#define DEFAULT_TARGET_MACHINE "i386-unknown-freebsd_1.0"
--#define GPLUSPLUS_INCLUDE_DIR "/usr/local/lib/gcc-lib/i386-unknown-freebsd_1.0/2.5.8/include"
--#define TOOL_INCLUDE_DIR "/usr/local/i386-unknown-freebsd_1.0/include"
--#define GCC_INCLUDE_DIR "/usr/local/lib/gcc-lib/i386-unknown-freebsd_1.0/2.5.8/include"
--#endif
--
--#endif /* FREEBSD_NATIVE */
++
+#define MD_STARTFILE_PREFIX "/usr/lib/aout/"
diff --git a/lang/gcc30/files/patch-af b/lang/gcc30/files/patch-af
index 0fc62fd3e4de..2e918ac92f9a 100644
--- a/lang/gcc30/files/patch-af
+++ b/lang/gcc30/files/patch-af
@@ -1,24 +1,6 @@
---- gcc/config/i386/freebsd.h.orig Sun May 23 12:42:51 1999
-+++ gcc/config/i386/freebsd.h Wed May 26 02:08:55 1999
-@@ -21,6 +21,17 @@
- the Free Software Foundation, 59 Temple Place - Suite 330,
- Boston, MA 02111-1307, USA. */
-
-+
-+#include "i386/att.h" /* Use the i386 AT&T assembler syntax */
-+
-+/* Use stabs instead of DWARF debug format. */
-+#undef PREFERRED_DEBUGGING_TYPE
-+#define PREFERRED_DEBUGGING_TYPE DBX_DEBUG
-+#include "svr4.h"
-+
-+/* Get generic FreeBSD definitions. */
-+#include <freebsd.h>
-+
- #undef TARGET_VERSION
- #define TARGET_VERSION fprintf (stderr, " (i386 FreeBSD/ELF)");
-
-@@ -113,22 +124,19 @@
+--- gcc/config/i386/freebsd.h.orig Thu Jun 3 16:18:41 1999
++++ gcc/config/i386/freebsd.h Mon Jun 14 19:19:42 1999
+@@ -135,22 +135,19 @@
: ((n) >= FIRST_STACK_REG && (n) <= LAST_STACK_REG) ? (n)+3 \
: (-1))
@@ -45,7 +27,7 @@
} \
}
-@@ -145,27 +153,31 @@
+@@ -170,10 +167,30 @@
#define WCHAR_TYPE_SIZE BITS_PER_WORD
#undef CPP_PREDEFINES
@@ -54,6 +36,34 @@
#undef CPP_SPEC
-#define CPP_SPEC "%(cpp_cpu) %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{posix:-D_POSIX_SOURCE}"
++#if TARGET_CPU_DEFAULT == 2
++#define CPP_SPEC "\
++ %{!maout: -D__ELF__} \
++ %{munderscores: -D__UNDERSCORES__} \
++ %{maout: %{!mno-underscores: -D__UNDERSCORES__}} \
++ %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{!m386:-D__i486__}"
++#else
++#define CPP_SPEC "\
++ %{!maout: -D__ELF__} \
++ %{munderscores: -D__UNDERSCORES__} \
++ %{maout: %{!mno-underscores: -D__UNDERSCORES__}} \
++ %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{m486:-D__i486__}"
++#endif
++
++#undef CC1_SPEC
++#define CC1_SPEC "\
++ %{gline:%{!g:%{!g0:%{!g1:%{!g2: -g1}}}}} \
++ %{maout: %{!mno-underscores: %{!munderscores: -munderscores }}}"
++
++#undef ASM_SPEC
++#define ASM_SPEC "%{v*: -v} %{maout: %{fpic:-k} %{fPIC:-k}}"
+
+ /* This defines which switch letters take arguments. On FreeBSD, most of
+ the normal cases (defined in gcc.c) apply, and we also have -h* and
+@@ -210,23 +227,6 @@
+ #define ENDFILE_SPEC \
+ "%{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s"
+
-
-#undef LIB_SPEC
-#if 1
@@ -64,36 +74,17 @@
-#define LIB_SPEC \
- "%{!shared: %{mieee-fp:-lieee} %{p:-lgmon} %{pg:-lgmon} \
- %{!ggdb:-lc} %{ggdb:-lg}}"
-+#if TARGET_CPU_DEFAULT == 2
-+#define CPP_SPEC "\
-+%{!maout: -D__ELF__} \
-+%{munderscores: -D__UNDERSCORES__} \
-+%{maout: %{!mno-underscores: -D__UNDERSCORES__}} \
-+%{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{!m386:-D__i486__}"
- #else
+-#else
-#define LIB_SPEC \
- "%{!shared: \
- %{mieee-fp:-lieee} %{p:-lgmon -lc_p} %{pg:-lgmon -lc_p} \
- %{!p:%{!pg:%{!g*:-lc} %{g*:-lg}}}}"
-+#define CPP_SPEC "\
-+%{!maout: -D__ELF__} \
-+%{munderscores: -D__UNDERSCORES__} \
-+%{maout: %{!mno-underscores: -D__UNDERSCORES__}} \
-+%{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{m486:-D__i486__}"
- #endif
-
-+#undef CC1_SPEC
-+#define CC1_SPEC "\
-+%{gline:%{!g:%{!g0:%{!g1:%{!g2: -g1}}}}} \
-+%{maout: %{!mno-underscores: %{!munderscores: -munderscores }}}"
-+
-+#undef ASM_SPEC
-+#define ASM_SPEC "%{v*: -v} %{maout: %{fpic:-k} %{fPIC:-k}}"
-+
+-#endif
+-
/* Provide a LINK_SPEC appropriate for FreeBSD. Here we provide support
for the special GCC options -static and -shared, which allow us to
link things in one of these three modes by applying the appropriate
-@@ -181,13 +193,23 @@
+@@ -242,13 +242,24 @@
done. */
#undef LINK_SPEC
@@ -102,6 +93,7 @@
- %{!ibcs: \
+#define LINK_SPEC "\
+ %{p:%e`-p' not supported; use `-pg' and gprof(1)} \
++ %{v:-V} \
+ %{maout: %{shared:-Bshareable} \
+ %{!shared:%{!nostdlib:%{!r:%{!e*:-e start}}} -dc -dp %{static:-Bstatic} \
+ %{pg:-Bstatic} %{Z}} \
@@ -121,7 +113,7 @@
/* A C statement to output to the stdio stream FILE an assembler
command to advance the location counter to a multiple of 1<<LOG
-@@ -202,3 +224,15 @@
+@@ -263,3 +274,15 @@
else fprintf ((FILE), "\t.p2align %d,,%d\n", (LOG), (MAX_SKIP)); \
}
#endif
diff --git a/lang/gcc30/files/patch-ak b/lang/gcc30/files/patch-ak
index b2c7ce166ba5..b8eaba90c2fa 100644
--- a/lang/gcc30/files/patch-ak
+++ b/lang/gcc30/files/patch-ak
@@ -1,5 +1,5 @@
---- gcc/configure.orig Mon May 17 04:57:01 1999
-+++ gcc/configure Tue May 18 03:55:08 1999
+--- gcc/configure.orig Tue Jun 8 02:19:23 1999
++++ gcc/configure Mon Jun 14 23:54:18 1999
@@ -3058,6 +3058,15 @@
thread_file='posix'
fi
@@ -16,28 +16,27 @@
alpha*-*-netbsd*)
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
target_cpu_default="MASK_GAS"
-@@ -3535,17 +3544,17 @@
+@@ -3536,17 +3545,17 @@
# Next line turned off because both 386BSD and BSD/386 use GNU ld.
# use_collect2=yes
;;
- i[34567]86-*-freebsdelf*)
-- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
-- extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
+- tm_file="i386/i386.h i386/att.h svr4.h i386/freebsd-elf.h i386/perform.h"
+ i[34567]86-*-freebsd[12].* | i[34567]86-*-freebsd[12] | i[34567]86-*-freebsdaout*)
-+ tm_file=i386/freebsd-aout.h
- tmake_file=i386/t-freebsd
++ tm_file=i386/freebsd.h
++ tmake_file=t-freebsd
+ ;;
+ i[34567]86-*-freebsd[3-9].* | i[34567]86-*-freebsd[3-9] | i[34567]86-*-freebsd* | i[34567]86-*-freebsdelf*)
-+ tm_file="i386/i386.h i386/freebsd.h i386/perform.h"
-+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
-+ tmake_file=t-freebsd
++ tm_file="i386/i386.h i386/att.h svr4.h freebsd.h i386/freebsd.h i386/perform.h"
+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
+ tmake_file=t-freebsd
gas=yes
gnu_ld=yes
stabs=yes
- ;;
- i[34567]86-*-freebsd*)
- tm_file=i386/freebsd.h
-- tmake_file=i386/t-freebsd
+- tmake_file=t-freebsd
;;
i[34567]86-*-netbsd*)
tm_file=i386/netbsd.h
diff --git a/lang/gcc30/files/patch-al b/lang/gcc30/files/patch-al
index a8163b10efd6..de95c4439b95 100644
--- a/lang/gcc30/files/patch-al
+++ b/lang/gcc30/files/patch-al
@@ -1,5 +1,5 @@
---- gcc/configure.in.orig Wed May 12 10:38:26 1999
-+++ gcc/configure.in Tue May 18 03:57:11 1999
+--- gcc/configure.in.orig Mon Jun 7 14:37:24 1999
++++ gcc/configure.in Mon Jun 14 19:25:53 1999
@@ -625,6 +625,15 @@
thread_file='posix'
fi
@@ -16,33 +16,32 @@
alpha*-*-netbsd*)
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
target_cpu_default="MASK_GAS"
-@@ -1135,20 +1144,20 @@
+@@ -1136,20 +1145,20 @@
# use_collect2=yes
;;
changequote(,)dnl
- i[34567]86-*-freebsdelf*)
-+ i[34567]86-*-freebsd[12].* | i[34567]86-*-freebsd[12] | i[34567]86-*-freebsdaout*)
-+changequote([,])dnl
-+ tm_file=i386/freebsd.h
-+ tmake_file=t-freebsd
-+ ;;
-+changequote(,)dnl
-+ i[34567]86-*-freebsd[3-9].* | i[34567]86-*-freebsd[3-9] | i[34567]86-*-freebsd* | i[34567]86-*-freebsdelf*)
+++ i[34567]86-*-freebsd[12].* | i[34567]86-*-freebsd[12] | i[34567]86-*-freebsdaout*)
changequote([,])dnl
-- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
-+ tm_file="i386/i386.h i386/freebsd.h i386/perform.h"
- extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
-- tmake_file=i386/t-freebsd
-+ tmake_file=t-freebsd
- gas=yes
- gnu_ld=yes
- stabs=yes
-- ;;
--changequote(,)dnl
+- tm_file="i386/i386.h i386/att.h svr4.h i386/freebsd-elf.h i386/perform.h"
+- extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
++ tm_file=i386/freebsd.h
+ tmake_file=t-freebsd
+- gas=yes
+- gnu_ld=yes
+- stabs=yes
+ ;;
+ changequote(,)dnl
- i[34567]86-*-freebsd*)
--changequote([,])dnl
++ i[34567]86-*-freebsd[3-9].* | i[34567]86-*-freebsd[3-9] | i[34567]86-*-freebsd* | i[34567]86-*-freebsdelf* | i[34567]86-*-freebsd*)
+ changequote([,])dnl
- tm_file=i386/freebsd.h
-- tmake_file=i386/t-freebsd
++ tm_file="i386/i386.h i386/att.h svr4.h freebsd.h i386/freebsd.h i386/perform.h"
++ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
+ tmake_file=t-freebsd
++ gas=yes
++ gnu_ld=yes
++ stabs=yes
;;
changequote(,)dnl
i[34567]86-*-netbsd*)