aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc32
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1999-06-24 19:11:57 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1999-06-24 19:11:57 +0000
commit5b92de7d875a82a89693dffddef0c71ee5b44300 (patch)
tree2856637afaad4aaa2a65c1b2f46ded8cf7155fbd /lang/gcc32
parent03f5f957c232a8ac835f898e06512d8c635ea839 (diff)
downloadports-5b92de7d875a82a89693dffddef0c71ee5b44300.tar.gz
ports-5b92de7d875a82a89693dffddef0c71ee5b44300.zip
Upgrade to the 19990623 GCC 2.95 pre-release snapshot.
Notes
Notes: svn path=/head/; revision=19752
Diffstat (limited to 'lang/gcc32')
-rw-r--r--lang/gcc32/Makefile4
-rw-r--r--lang/gcc32/distinfo12
-rw-r--r--lang/gcc32/files/patch-af46
3 files changed, 17 insertions, 45 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index 83c1386a2af6..133008fda197 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -4,10 +4,10 @@
# Date created: 9 Jan 1998
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.63 1999/06/15 07:31:08 obrien Exp $
+# $Id: Makefile,v 1.64 1999/06/21 18:17:51 obrien Exp $
#
-SNAPDATE= 1999-06-16
+SNAPDATE= 1999-06-23
SNAPVER= ${SNAPDATE:S/-//g}
DISTNAME= egcs-${SNAPVER}
diff --git a/lang/gcc32/distinfo b/lang/gcc32/distinfo
index b56881e16267..5aa481fc7c94 100644
--- a/lang/gcc32/distinfo
+++ b/lang/gcc32/distinfo
@@ -1,6 +1,6 @@
-MD5 (egcs-chill-19990616.tar.gz) = 01e3e755daf034ba0f5af01ebb7c9e83
-MD5 (egcs-core-19990616.tar.gz) = 7876fbe2b76a7b09656939bc237a0468
-MD5 (egcs-g++-19990616.tar.gz) = 4198e212d6b3606b8f6ad4a3e443b1a5
-MD5 (egcs-g77-19990616.tar.gz) = 4fc255f38ae0a753de7d6f362b464c63
-MD5 (egcs-java-19990616.tar.gz) = 838cf9d40fe5166584d86fb7a68bc456
-MD5 (egcs-objc-19990616.tar.gz) = 6e2025c7fe06c0422f04e478a21a1629
+MD5 (egcs-chill-19990623.tar.gz) = 9f4b0b8e8434ff77cbc858aa15e06f6f
+MD5 (egcs-core-19990623.tar.gz) = 561b461f3ede6ebbd40c3af9717594ea
+MD5 (egcs-g++-19990623.tar.gz) = 992ae5ccd85e42dd97baea007c7d92cd
+MD5 (egcs-g77-19990623.tar.gz) = f1d6b9846a73e3ce73eff9061e5e9c35
+MD5 (egcs-java-19990623.tar.gz) = ddc6838cee49fd7c43895be3177db7b5
+MD5 (egcs-objc-19990623.tar.gz) = 1f242db9a83e8a2a10b77b3a9b4c8c24
diff --git a/lang/gcc32/files/patch-af b/lang/gcc32/files/patch-af
index ea62731fd980..4423399d221c 100644
--- a/lang/gcc32/files/patch-af
+++ b/lang/gcc32/files/patch-af
@@ -1,34 +1,15 @@
---- gcc/config/i386/freebsd.h.orig Mon Jun 14 17:58:11 1999
-+++ gcc/config/i386/freebsd.h Mon Jun 21 05:18:57 1999
-@@ -135,23 +135,16 @@
- : ((n) >= FIRST_STACK_REG && (n) <= LAST_STACK_REG) ? (n)+3 \
- : (-1))
+--- gcc/config/i386/freebsd.h.orig Thu Jun 17 05:33:32 1999
++++ gcc/config/i386/freebsd.h Thu Jun 24 11:16:34 1999
+@@ -137,6 +137,8 @@
--/* Output assembler code to FILE to increment profiler label # LABELNO
-- for profiling a function entry. */
-+/* Tell final.c that we don't need a label passed to mcount. */
-+#define NO_PROFILE_DATA
+ /* Tell final.c that we don't need a label passed to mcount. */
++#define NO_PROFILE_DATA
++
#undef FUNCTION_PROFILER
#define FUNCTION_PROFILER(FILE, LABELNO) \
{ \
- if (flag_pic) \
-- { \
-- fprintf (FILE, "\tleal %sP%d@GOTOFF(%%ebx),%%edx\n", \
-- LPREFIX, (LABELNO)); \
-- fprintf (FILE, "\tcall *mcount@GOT(%%ebx)\n"); \
-- } \
-+ fprintf (FILE, "\tcall *.mcount@GOT(%%ebx)\n"); \
- else \
-- { \
-- fprintf (FILE, "\tmovl $%sP%d,%%edx\n", LPREFIX, (LABELNO)); \
-- fprintf (FILE, "\tcall mcount\n"); \
-- } \
-+ fprintf (FILE, "\tcall .mcount\n"); \
- }
-
- #undef SIZE_TYPE
-@@ -170,10 +163,30 @@
+@@ -162,10 +164,30 @@
#define WCHAR_TYPE_SIZE BITS_PER_WORD
#undef CPP_PREDEFINES
@@ -61,7 +42,7 @@
/* This defines which switch letters take arguments. On FreeBSD, most of
the normal cases (defined in gcc.c) apply, and we also have -h* and
-@@ -194,11 +207,11 @@
+@@ -186,11 +208,11 @@
#undef STARTFILE_SPEC
#define STARTFILE_SPEC \
@@ -78,7 +59,7 @@
/* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
the magical crtend.o file (see crtstuff.c) which provides part of
-@@ -208,7 +221,7 @@
+@@ -200,7 +222,7 @@
#undef ENDFILE_SPEC
#define ENDFILE_SPEC \
@@ -87,12 +68,3 @@
/* Provide a LIB_SPEC appropriate for FreeBSD. Just select the appropriate
libc, depending on whether we're doing profiling or need threads support.
-@@ -247,7 +260,7 @@
- %{!static: \
- %{rdynamic:-export-dynamic} \
- %{!dynamic-linker:-dynamic-linker /usr/libexec/ld-elf.so.1}} \
-- %{static:-Bstatic}}} \
-+ %{static:-Bstatic}} \
- %{symbolic:-Bsymbolic}"
-
- /* A C statement to output to the stdio stream FILE an assembler