aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc47
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1999-02-09 18:24:50 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1999-02-09 18:24:50 +0000
commit9740802749731bb28d0e38b06023350192e85a09 (patch)
tree773743b9fd0f78392da8f7652ec57cf0f6eea8b8 /lang/gcc47
parentf21b34b03975545024b342ad9c0f70852e66a09a (diff)
downloadports-9740802749731bb28d0e38b06023350192e85a09.tar.gz
ports-9740802749731bb28d0e38b06023350192e85a09.zip
GNUHOST is now "i386-unknown-freebsd" for an ELF machine, and
"i386-unknown-freebsdaout" for an a.out machine.
Notes
Notes: svn path=/head/; revision=16573
Diffstat (limited to 'lang/gcc47')
-rw-r--r--lang/gcc47/Makefile27
-rw-r--r--lang/gcc47/files/patch-ad4
-rw-r--r--lang/gcc47/files/patch-af4
-rw-r--r--lang/gcc47/files/patch-ak30
-rw-r--r--lang/gcc47/files/patch-al29
5 files changed, 78 insertions, 16 deletions
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 6d3d2c199ab1..1f920d8d12d8 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -4,7 +4,7 @@
# Date created: 9 Jan 1998
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.42 1998/12/26 20:10:02 obrien Exp $
+# $Id: Makefile,v 1.43 1999/02/03 11:11:52 asami Exp $
#
DISTNAME= egcs-1.1.1
@@ -26,11 +26,11 @@ LIBSTDCPP_REV= 2.9.0
.if ${PORTOBJFORMAT} == "elf"
PLIST= ${WRKDIR}/PLIST
-#GNUHOST= ${ARCH}-unknown-freebsdelf${OSREL}
-GNUHOST= ${ARCH}-unknown-freebsdelf
-.else
#GNUHOST= ${ARCH}-unknown-freebsd${OSREL}
GNUHOST= ${ARCH}-unknown-freebsd
+.else
+#GNUHOST= ${ARCH}-unknown-freebsdaout${OSREL}
+GNUHOST= ${ARCH}-unknown-freebsdaout
.endif
PLIST_SUB= EGCS_REV=${EGCS_REV} GNU_HOST=${GNUHOST}
@@ -41,13 +41,26 @@ CONFIGURE_ARGS= --with-gnu-as --with-gnu-ld ${GNUHOST} \
ALL_TARGET= bootstrap
MAN1= cccp.1 g++.1 g77.1 gcc.1
+pre-patch:
+ @${MV} ${WRKSRC}/gcc/config/i386/freebsd.h ${WRKSRC}/gcc/config/i386/freebsd-aout.h
+ @${MV} ${WRKSRC}/gcc/config/i386/freebsd-elf.h ${WRKSRC}/gcc/config/i386/freebsd.h
+ # If I touch configure.in in any way, the build scafolding wants to
+ # run `autoconf' to regenerate `configure'. I thought a simple `touch'
+ # of `configure' would do the trick, but it didn't.
+ ##${CP} -p ${WRKSRC}/gcc/configure.in ${WRKSRC}/gcc/configure.in-changed
+
pre-configure:
+ @# Keep from running `autoconf' and `autoheader' since we modified
+ @# configure.in by patching it.
+ touch ${WRKSRC}/gcc/configure
+ touch ${WRKSRC}/gcc/cstamp-h.in
@(cd ${WRKSRC}/gcc/config/${ARCH}/ ; \
MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
+ ${MV} freebsd-aout.h freebsd-aout.h.in ; \
+ ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" freebsd-aout.h.in \
+ >freebsd-aout.h ; \
${MV} freebsd.h freebsd.h.in ; \
- ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" freebsd.h.in >freebsd.h ; \
- ${MV} freebsd-elf.h freebsd-elf.h.in ; \
- ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" freebsd-elf.h.in >freebsd-elf.h)
+ ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" freebsd.h.in >freebsd.h )
.if ${PORTOBJFORMAT} == "elf"
@${SED} -e 's/^@comment ELF-only://' ${PKGDIR}/PLIST >${PLIST}
.endif
diff --git a/lang/gcc47/files/patch-ad b/lang/gcc47/files/patch-ad
index 7b42a720728b..3fa37c95418b 100644
--- a/lang/gcc47/files/patch-ad
+++ b/lang/gcc47/files/patch-ad
@@ -1,5 +1,5 @@
---- gcc/config/i386/freebsd.h.orig Tue Jun 30 15:52:18 1998
-+++ gcc/config/i386/freebsd.h Fri Jan 22 04:08:44 1999
+--- gcc/config/i386/freebsd-aout.h.orig Tue Jun 30 15:52:18 1998
++++ gcc/config/i386/freebsd-aout.h Fri Jan 22 04:08:44 1999
@@ -89,6 +89,10 @@
/* Don't default to pcc-struct-return, because gcc is the only compiler, and
we want to retain compatibility with older gcc versions. */
diff --git a/lang/gcc47/files/patch-af b/lang/gcc47/files/patch-af
index b342bb4a6b4a..e9d23249070c 100644
--- a/lang/gcc47/files/patch-af
+++ b/lang/gcc47/files/patch-af
@@ -1,5 +1,5 @@
---- gcc/config/i386/freebsd-elf.h.orig Mon Jul 13 15:38:36 1998
-+++ gcc/config/i386/freebsd-elf.h Fri Jan 22 04:11:03 1999
+--- gcc/config/i386/freebsd.h.orig Mon Jul 13 15:38:36 1998
++++ gcc/config/i386/freebsd.h Fri Jan 22 04:11:03 1999
@@ -26,8 +26,13 @@
/* The svr4 ABI for the i386 says that records and unions are returned
diff --git a/lang/gcc47/files/patch-ak b/lang/gcc47/files/patch-ak
index f2c8058c74ca..817e789e8f53 100644
--- a/lang/gcc47/files/patch-ak
+++ b/lang/gcc47/files/patch-ak
@@ -1,10 +1,30 @@
--- gcc/configure.orig Wed Dec 2 11:22:52 1998
-+++ gcc/configure Fri Dec 25 00:35:40 1998
-@@ -2752,6 +2752,7 @@
- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
++++ gcc/configure Tue Feb 9 02:21:19 1999
+@@ -2748,20 +2748,21 @@
+ # Next line turned off because both 386BSD and BSD/386 use GNU ld.
+ # use_collect2=yes
+ ;;
+- i[34567]86-*-freebsdelf*)
+- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
++ i[34567]86-*-freebsdaout*)
++ tm_file=i386/freebsd.h
+ # On FreeBSD, the headers are already ok, except for math.h.
+ fixincludes=fixinc.wrap
+ tmake_file=i386/t-freebsd
+- gas=yes
+- gnu_ld=yes
+- stabs=yes
+ ;;
+ i[34567]86-*-freebsd*)
+- tm_file=i386/freebsd.h
++ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
# On FreeBSD, the headers are already ok, except for math.h.
fixincludes=fixinc.wrap
+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
tmake_file=i386/t-freebsd
- gas=yes
- gnu_ld=yes
++ gas=yes
++ gnu_ld=yes
++ stabs=yes
+ ;;
+ i[34567]86-*-netbsd*)
+ tm_file=i386/netbsd.h
diff --git a/lang/gcc47/files/patch-al b/lang/gcc47/files/patch-al
new file mode 100644
index 000000000000..5630ff63f6d5
--- /dev/null
+++ b/lang/gcc47/files/patch-al
@@ -0,0 +1,29 @@
+--- gcc/configure.in.orig Thu Aug 27 17:19:04 1998
++++ gcc/configure.in Tue Feb 9 02:22:10 1999
+@@ -846,20 +846,20 @@
+ # Next line turned off because both 386BSD and BSD/386 use GNU ld.
+ # use_collect2=yes
+ ;;
+- i[[34567]]86-*-freebsdelf*)
+- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
++ i[[34567]]86-*-freebsdaout*)
++ tm_file=i386/freebsd.h
+ # On FreeBSD, the headers are already ok, except for math.h.
+ fixincludes=fixinc.wrap
+ tmake_file=i386/t-freebsd
+- gas=yes
+- gnu_ld=yes
+- stabs=yes
+ ;;
+ i[[34567]]86-*-freebsd*)
+- tm_file=i386/freebsd.h
++ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
+ # On FreeBSD, the headers are already ok, except for math.h.
+ fixincludes=fixinc.wrap
+ tmake_file=i386/t-freebsd
++ gas=yes
++ gnu_ld=yes
++ stabs=yes
+ ;;
+ i[[34567]]86-*-netbsd*)
+ tm_file=i386/netbsd.h