aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc5
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2018-09-30 07:35:17 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2018-09-30 07:35:17 +0000
commit604d3d8bbb0815c5e56cdbe64e88eab0f7400c37 (patch)
tree5c3afc5d0f36d8b05c6002f5fb48be4681786d7c /lang/gcc5
parent13f41e075608c13b95332e4df5e9ef0d74a1c5ce (diff)
downloadports-604d3d8bbb0815c5e56cdbe64e88eab0f7400c37.tar.gz
ports-604d3d8bbb0815c5e56cdbe64e88eab0f7400c37.zip
Recommend the use of GCC 7 or later over this port, since that is now
the default version of GCC for the Ports Collection. And backport r478722 | gerald | 2018-09-01 from lang/gcc7: [1] Disable the build/use of libssp/gets-chk since FreeBSD 12 and later do not feature gets() any longer. PR: 222796, 231066 [1] Differential Revision: https://reviews.freebsd.org/D12298 [1]
Notes
Notes: svn path=/head/; revision=480939
Diffstat (limited to 'lang/gcc5')
-rw-r--r--lang/gcc5/Makefile4
-rw-r--r--lang/gcc5/files/patch-gets-no-more47
2 files changed, 49 insertions, 2 deletions
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index 5c49f45056df..dc7e07193cc6 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gcc
PORTVERSION= 5.5.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}
@@ -14,7 +14,7 @@ COMMENT= GNU Compiler Collection 5
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
-DEPRECATED= Unsupported by upstream. Use GCC 6 or newer instead.
+DEPRECATED= Unsupported by upstream. Use GCC 7 or newer instead.
ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 i386 powerpc powerpc64 powerpcspe sparc64
BROKEN_sparc64= Does not build: bootstrap comparison failure
diff --git a/lang/gcc5/files/patch-gets-no-more b/lang/gcc5/files/patch-gets-no-more
new file mode 100644
index 000000000000..4b49aba3ca28
--- /dev/null
+++ b/lang/gcc5/files/patch-gets-no-more
@@ -0,0 +1,47 @@
+Disable the build/use of libssp/gets-chk since FreeBSD 12 and later
+do not feature gets() any longer.
+
+--- UTC
+Index: libssp/Makefile.am
+===================================================================
+--- libssp/Makefile.am (revision 263319)
++++ libssp/Makefile.am (working copy)
+@@ -42,7 +42,7 @@
+ nobase_libsubinclude_HEADERS = ssp/ssp.h ssp/string.h ssp/stdio.h ssp/unistd.h
+
+ libssp_la_SOURCES = \
+- ssp.c gets-chk.c memcpy-chk.c memmove-chk.c mempcpy-chk.c \
++ ssp.c memcpy-chk.c memmove-chk.c mempcpy-chk.c \
+ memset-chk.c snprintf-chk.c sprintf-chk.c stpcpy-chk.c \
+ strcat-chk.c strcpy-chk.c strncat-chk.c strncpy-chk.c \
+ vsnprintf-chk.c vsprintf-chk.c
+Index: libssp/Makefile.in
+===================================================================
+--- libssp/Makefile.in (revision 263319)
++++ libssp/Makefile.in (working copy)
+@@ -108,7 +108,7 @@
+ am__installdirs = "$(DESTDIR)$(toolexeclibdir)" \
+ "$(DESTDIR)$(libsubincludedir)"
+ LTLIBRARIES = $(toolexeclib_LTLIBRARIES)
+-am_libssp_la_OBJECTS = ssp.lo gets-chk.lo memcpy-chk.lo memmove-chk.lo \
++am_libssp_la_OBJECTS = ssp.lo memcpy-chk.lo memmove-chk.lo \
+ mempcpy-chk.lo memset-chk.lo snprintf-chk.lo sprintf-chk.lo \
+ stpcpy-chk.lo strcat-chk.lo strcpy-chk.lo strncat-chk.lo \
+ strncpy-chk.lo vsnprintf-chk.lo vsprintf-chk.lo
+@@ -291,7 +291,7 @@
+ libsubincludedir = $(libdir)/gcc/$(target_noncanonical)/$(gcc_version)/include
+ nobase_libsubinclude_HEADERS = ssp/ssp.h ssp/string.h ssp/stdio.h ssp/unistd.h
+ libssp_la_SOURCES = \
+- ssp.c gets-chk.c memcpy-chk.c memmove-chk.c mempcpy-chk.c \
++ ssp.c memcpy-chk.c memmove-chk.c mempcpy-chk.c \
+ memset-chk.c snprintf-chk.c sprintf-chk.c stpcpy-chk.c \
+ strcat-chk.c strcpy-chk.c strncat-chk.c strncpy-chk.c \
+ vsnprintf-chk.c vsprintf-chk.c
+@@ -452,7 +452,6 @@
+ distclean-compile:
+ -rm -f *.tab.c
+
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/gets-chk.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/libssp_nonshared_la-ssp-local.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/memcpy-chk.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/memmove-chk.Plo@am__quote@