aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc5
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-18 10:39:04 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-18 10:39:04 +0000
commit716e5c49e9ff4a63f6bfb441105cb463d5019b19 (patch)
tree7b2c486b406069a4064684b7c8774dfb76572e0c /lang/gcc5
parentb2e6644be3159df3e6cb24da28fde17f8c50b11e (diff)
downloadports-716e5c49e9ff4a63f6bfb441105cb463d5019b19.tar.gz
ports-716e5c49e9ff4a63f6bfb441105cb463d5019b19.zip
lang/gcc5: Support DragonFly's gcc50 base compiler in specific scenario
Notes
Notes: svn path=/head/; revision=381535
Diffstat (limited to 'lang/gcc5')
-rw-r--r--lang/gcc5/Makefile.DragonFly8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/gcc5/Makefile.DragonFly b/lang/gcc5/Makefile.DragonFly
index 78bc57da0ad5..5342d32b33f5 100644
--- a/lang/gcc5/Makefile.DragonFly
+++ b/lang/gcc5/Makefile.DragonFly
@@ -1,3 +1,11 @@
# $FreeBSD$
OPTIONS_EXCLUDE= JAVA
+
+# The following modification to CXXFLAGS is needed in the case of DragonFly
+# 4.1+ building lang/gcc5 with the gcc50 base compiler when the system
+# libraries were built by the gcc47 base compiler. The sys.mk file
+# automatically adds -D_GLIBCXX_USE_CXX11_ABI=0 to CXXFLAGS in that case,
+# which will break the build.
+
+CXXFLAGS:= ${CXXFLAGS:N-D_GLIBCXX_USE_CXX11_ABI*}