aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc5
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-26 20:36:04 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-26 20:36:04 +0000
commitbd64a4f18c29713b4e270a9dff7f912d13a12e58 (patch)
tree699e63834cca5b95087b6d57383fe37b6abdd52f /lang/gcc5
parentd2d0618fc29aedfd850fb9df8ffae4afd87dfa6c (diff)
downloadports-bd64a4f18c29713b4e270a9dff7f912d13a12e58.tar.gz
ports-bd64a4f18c29713b4e270a9dff7f912d13a12e58.zip
lang/gcc(46,47,48,49,5): Use OPTIONS_EXCLUDE_DragonFly to block JAVA
The JAVA frontend doesn't build on DragonFly on any release. The new OPTIONS_EXCLUDE_${OPSYS} feature is a nice way to avoid the use of Makefile.DragonFly (most are in dports, but one is in lang/gcc5). The recent addition of CXXFLAGS to lang/gcc5 prevents Makefile.DragonFly on lang/gcc5 from being removed outright. There are a couple of options available to allow its removal, but I'll need to discuss with Gerald. Approved by: DragonFly blanket
Notes
Notes: svn path=/head/; revision=382341
Diffstat (limited to 'lang/gcc5')
-rw-r--r--lang/gcc5/Makefile1
-rw-r--r--lang/gcc5/Makefile.DragonFly2
2 files changed, 1 insertions, 2 deletions
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index 0adde13c2a71..d0d3eef96bc7 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -51,6 +51,7 @@ OPTIONS_DEFINE_amd64= JAVA
OPTIONS_DEFAULT= BOOTSTRAP
OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
+OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
.include <bsd.port.pre.mk>
diff --git a/lang/gcc5/Makefile.DragonFly b/lang/gcc5/Makefile.DragonFly
index 5342d32b33f5..7163f7d76237 100644
--- a/lang/gcc5/Makefile.DragonFly
+++ b/lang/gcc5/Makefile.DragonFly
@@ -1,7 +1,5 @@
# $FreeBSD$
-OPTIONS_EXCLUDE= JAVA
-
# The following modification to CXXFLAGS is needed in the case of DragonFly
# 4.1+ building lang/gcc5 with the gcc50 base compiler when the system
# libraries were built by the gcc47 base compiler. The sys.mk file