aboutsummaryrefslogtreecommitdiff
path: root/lang/gdc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-21 21:51:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-21 21:51:49 +0000
commit4762df3c8838a7b0168355f5d4d521abb2ca0b70 (patch)
tree1c23a91c90689f03ea78e9eb6ee7891690b49b04 /lang/gdc
parente6478749517470f2b7f6b20a49940375c18e154a (diff)
downloadports-4762df3c8838a7b0168355f5d4d521abb2ca0b70.tar.gz
ports-4762df3c8838a7b0168355f5d4d521abb2ca0b70.zip
- Remove alpha from list of supported architectures. The compiler will compile
and run, but produce 32-bit code. - Use same gcc as gcc34 port - Move library test to check: target - Cleanup PR: ports/87690 Submitted by: Alejandro Pulver <alejandro@varnet.biz> Approved by: Masanori OZAWA <ozawa@ongs.co.jp> (maintainer)
Notes
Notes: svn path=/head/; revision=146073
Diffstat (limited to 'lang/gdc')
-rw-r--r--lang/gdc/Makefile98
-rw-r--r--lang/gdc/distinfo8
-rw-r--r--lang/gdc/pkg-plist404
3 files changed, 249 insertions, 261 deletions
diff --git a/lang/gdc/Makefile b/lang/gdc/Makefile
index d3ae895d0c55..4babb63d6cab 100644
--- a/lang/gdc/Makefile
+++ b/lang/gdc/Makefile
@@ -11,17 +11,15 @@ PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC} \
http://home.earthlink.net/~dvdfrdmn/d/:gdc
-MASTER_SITE_SUBDIR= snapshots/${__GCC_VERSIONSTRING}
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.bz2:gdc \
- gcc-core-${__GCC_VERSIONSTRING}.tar.bz2 \
- gcc-g++-${__GCC_VERSIONSTRING}.tar.bz2
-EXTRACT_ONLY= gcc-core-${__GCC_VERSIONSTRING}.tar.bz2 \
- gcc-g++-${__GCC_VERSIONSTRING}.tar.bz2
+MASTER_SITE_SUBDIR= snapshots/${GCC_VERSIONSTRING}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:gdc \
+ gcc-core-${GCC_VERSIONSTRING}${EXTRACT_SUFX} \
+ gcc-g++-${GCC_VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER= ozawa@ongs.co.jp
COMMENT= D Front End for GCC
-ONLY_FOR_ARCHS= i386 alpha
+ONLY_FOR_ARCHS= i386
USE_BISON= yes
USE_BZIP2= yes
@@ -29,75 +27,65 @@ USE_GCC= 3.4
USE_GMAKE= yes
USE_REINPLACE= yes
-__GCC_VERSION= 3.4.5
-__GCC_REVISION= 20050719
-__GCC_VERSIONSTRING= 3.4-${__GCC_REVISION}
+WRKSRC= ${WRKDIR}/gcc-${GCC_VERSIONSTRING}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--disable-nls \
+ --with-system-zlib \
+ --with-libiconv-prefix=${LOCALBASE} \
+ --disable-shared \
+ --enable-languages=c,c++,d
+
+PLIST_SUB= GCC_VER=${GCC_VERSION} CONF_TARGET=${CONFIGURE_TARGET}
+
+MAN1= gdc.1
+
+GCCDIR= ${WRKSRC}/gcc
+GCC_VERSION= 3.4.5
+GCC_REVISION= 20050920
+GCC_VERSIONSTRING= 3.4-${GCC_REVISION}
+GDC_INC= ${PREFIX}/include/d/${GCC_VERSION}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-IGNORE= It is supported on FreeBSD 5.x and later.
+IGNORE= It is supported on FreeBSD 5.x and later.
.endif
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
-.else
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-.endif
-
-GXX_INC=${PREFIX}/lib/gcc/${CONFIGURE_TARGET}/${__GCC_VERSION}/include/c++/
-GDC_INC=${PREFIX}/include/d/${__GCC_VERSION}
-CONFIGURE_ARGS+=--disable-nls --with-system-zlib \
- --with-libiconv-prefix=${LOCALBASE} \
- --with-gxx-include-dir=${GXX_INC} \
- --disable-shared --prefix=${PREFIX} \
- --enable-languages=c,c++,d
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-GNU_CONFIGURE= yes
-PLIST_SUB= __GCC_VER=${__GCC_VERSION} CONF_TARGET=${CONFIGURE_TARGET}
-
-.if defined(_GCC_BUILD_DEPENDS)
-RUN_DEPENDS+= ${_GCC_BUILD_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
-SUFFIX= 34
-CONFIGURE_ARGS+= --program-suffix=${SUFFIX}
-.endif
-
-WRKSRC= ${WRKDIR}/gcc-${__GCC_VERSIONSTRING}
-GCCDIR= ${WRKSRC}/gcc
-
-pre-fetch:
-.ifdef WITH_UNITTEST
- @echo ""
- @echo "Warning:"
- @echo " WITH_UNITTEST enabled."
- @echo " On FreeBSD, some unit tests will fail."
- @echo ""
- @sleep 5
.endif
post-extract:
- @${TAR} xjf ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
- -C ${GCCDIR}
+ @${MV} ${WRKDIR}/d ${GCCDIR}
post-patch:
- @cd ${WRKSRC} && ${SH} ./gcc/d/setup-gcc.sh
+ @(cd ${WRKSRC} && ${SH} ./gcc/d/setup-gcc.sh)
@${REINPLACE_CMD} -e \
's|\(const char version_string.*\)";|\1 [FreeBSD]";|' \
${GCCDIR}/version.c
@${REINPLACE_CMD} -e \
- '/^gcc_d_include_dir/s|^.*$$|gcc_d_include_dir = ${GDC_INC}|' \
+ 's|^\(gcc_d_include_dir\).*|\1 = ${GDC_INC}|' \
${GCCDIR}/d/Make-lang.in
post-build:
-.ifdef WITH_UNITTEST
- @cd ${WRKSRC} && ${GMAKE} check-target-libphobos
-.endif
+ @${ECHO_CMD}
+ @${ECHO_CMD} "======================================================="
+ @${ECHO_CMD}
+ @${ECHO_CMD} "To test the Phobos run-time library run 'make check'."
+ @${ECHO_CMD}
+ @${ECHO_CMD} "Note that some tests will fail."
+ @${ECHO_CMD}
+ @${ECHO_CMD} "======================================================="
+ @${ECHO_CMD}
do-install:
- ${INSTALL_PROGRAM} -o root -g wheel -m 755 ${GCCDIR}/gdc ${PREFIX}/bin/
- @${STRIP_CMD} ${PREFIX}/bin/gdc
- ${INSTALL_PROGRAM} -o root -g wheel -m 755 ${GCCDIR}/cc1d ${PREFIX}/bin/
- @${STRIP_CMD} ${PREFIX}/bin/cc1d
- @cd ${WRKSRC} && ${GMAKE} install-target-libphobos
+ ${INSTALL_PROGRAM} ${GCCDIR}/gdc ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${GCCDIR}/cc1d ${PREFIX}/bin
+ ${INSTALL_MAN} ${GCCDIR}/d/gdc.1 ${PREFIX}/man/man1
+ @(cd ${WRKSRC} && ${GMAKE} install-target-libphobos)
+
+check: build
+ @(cd ${WRKSRC} && ${GMAKE} check-target-libphobos)
.include <bsd.port.post.mk>
diff --git a/lang/gdc/distinfo b/lang/gdc/distinfo
index da55ec9e9af9..5d242ac96b6b 100644
--- a/lang/gdc/distinfo
+++ b/lang/gdc/distinfo
@@ -1,6 +1,6 @@
MD5 (gdc-0.15.tar.bz2) = 443e3b8faf86f21ef2c7f6bf584466f1
SIZE (gdc-0.15.tar.bz2) = 858620
-MD5 (gcc-core-3.4-20050719.tar.bz2) = 43abb63b96a3bab180655b63d0569ac9
-SIZE (gcc-core-3.4-20050719.tar.bz2) = 11102006
-MD5 (gcc-g++-3.4-20050719.tar.bz2) = 522a022f60d08ad52152ea08083a4a69
-SIZE (gcc-g++-3.4-20050719.tar.bz2) = 2482995
+MD5 (gcc-core-3.4-20050920.tar.bz2) = d1323b6dc41d28f67b724823fc7244ca
+SIZE (gcc-core-3.4-20050920.tar.bz2) = 11115747
+MD5 (gcc-g++-3.4-20050920.tar.bz2) = 6640e827ec158e2df44d4ae58b771765
+SIZE (gcc-g++-3.4-20050920.tar.bz2) = 2480879
diff --git a/lang/gdc/pkg-plist b/lang/gdc/pkg-plist
index 767fcee7dfb5..124a84b9625c 100644
--- a/lang/gdc/pkg-plist
+++ b/lang/gdc/pkg-plist
@@ -1,207 +1,207 @@
bin/gdc
bin/cc1d
-include/d/%%__GCC_VER%%/etc/c/zlib.d
-include/d/%%__GCC_VER%%/etc/c/recls/recls.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_assert.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_compiler.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_compiler_dmc.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_compiler_gcc.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_debug.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_defs.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_internal.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_language.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_platform.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_platform_types.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_retcodes.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_unix.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_util.h
-include/d/%%__GCC_VER%%/etc/c/recls/recls_win32.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft_cccap_dmc.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft_cccap_gcc.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft_iterator.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft_lock_scope.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft_null.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft_null_mutex.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft_nulldef.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/stlsoft_static_initialisers.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_current_directory.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_current_directory_scope.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_environment_variable.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_filesystem_traits.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_findfile_sequence.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_functionals.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_glob_sequence.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_limits.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_process_mutex.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_readdir_sequence.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_spin_mutex.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_string_access.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/unixstl_thread_mutex.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/winstl.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/winstl_atomic_functions.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/winstl_filesystem_traits.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/winstl_findfile_sequence.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/winstl_spin_mutex.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/winstl_system_version.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/winstl_thread_mutex.h
-include/d/%%__GCC_VER%%/etc/c/stlsoft/winstl_tls_index.h
-include/d/%%__GCC_VER%%/etc/c/zlib/crc32.h
-include/d/%%__GCC_VER%%/etc/c/zlib/deflate.h
-include/d/%%__GCC_VER%%/etc/c/zlib/infblock.h
-include/d/%%__GCC_VER%%/etc/c/zlib/infcodes.h
-include/d/%%__GCC_VER%%/etc/c/zlib/inffast.h
-include/d/%%__GCC_VER%%/etc/c/zlib/inffixed.h
-include/d/%%__GCC_VER%%/etc/c/zlib/inflate.h
-include/d/%%__GCC_VER%%/etc/c/zlib/inftrees.h
-include/d/%%__GCC_VER%%/etc/c/zlib/infutil.h
-include/d/%%__GCC_VER%%/etc/c/zlib/trees.h
-include/d/%%__GCC_VER%%/etc/c/zlib/zconf.h
-include/d/%%__GCC_VER%%/etc/c/zlib/zconf.in.h
-include/d/%%__GCC_VER%%/etc/c/zlib/zlib.h
-include/d/%%__GCC_VER%%/etc/c/zlib/zutil.h
-include/d/%%__GCC_VER%%/gcc/aix_float.h
-include/d/%%__GCC_VER%%/gcc/builtins.d
-include/d/%%__GCC_VER%%/gcc/configext.d
-include/d/%%__GCC_VER%%/gcc/deh.d
-include/d/%%__GCC_VER%%/gcc/support.d
-include/d/%%__GCC_VER%%/gcc/threadsem.d
-include/d/%%__GCC_VER%%/gcc/unwind.d
-include/d/%%__GCC_VER%%/std/array.d
-include/d/%%__GCC_VER%%/std/asserterror.d
-include/d/%%__GCC_VER%%/std/base64.d
-include/d/%%__GCC_VER%%/std/boxer.d
-include/d/%%__GCC_VER%%/std/compiler.d
-include/d/%%__GCC_VER%%/std/conv.d
-include/d/%%__GCC_VER%%/std/cstream.d
-include/d/%%__GCC_VER%%/std/ctype.d
-include/d/%%__GCC_VER%%/std/date.d
-include/d/%%__GCC_VER%%/std/dateparse.d
-include/d/%%__GCC_VER%%/std/file.d
-include/d/%%__GCC_VER%%/std/format.d
-include/d/%%__GCC_VER%%/std/gc.d
-include/d/%%__GCC_VER%%/std/intrinsic.d
-include/d/%%__GCC_VER%%/std/loader.d
-include/d/%%__GCC_VER%%/std/math.d
-include/d/%%__GCC_VER%%/std/math2.d
-include/d/%%__GCC_VER%%/std/md5.d
-include/d/%%__GCC_VER%%/std/mmfile.d
-include/d/%%__GCC_VER%%/std/moduleinit.d
-include/d/%%__GCC_VER%%/std/openrj.d
-include/d/%%__GCC_VER%%/std/outbuffer.d
-include/d/%%__GCC_VER%%/std/outofmemory.d
-include/d/%%__GCC_VER%%/std/path.d
-include/d/%%__GCC_VER%%/std/perf.d
-include/d/%%__GCC_VER%%/std/process.d
-include/d/%%__GCC_VER%%/std/random.d
-include/d/%%__GCC_VER%%/std/recls.d
-include/d/%%__GCC_VER%%/std/regexp.d
-include/d/%%__GCC_VER%%/std/socket.d
-include/d/%%__GCC_VER%%/std/socketstream.d
-include/d/%%__GCC_VER%%/std/stdarg.d
-include/d/%%__GCC_VER%%/std/stdint.d
-include/d/%%__GCC_VER%%/std/stdio.d
-include/d/%%__GCC_VER%%/std/stream.d
-include/d/%%__GCC_VER%%/std/string.d
-include/d/%%__GCC_VER%%/std/switcherr.d
-include/d/%%__GCC_VER%%/std/syserror.d
-include/d/%%__GCC_VER%%/std/system.d
-include/d/%%__GCC_VER%%/std/thread.d
-include/d/%%__GCC_VER%%/std/uni.d
-include/d/%%__GCC_VER%%/std/uri.d
-include/d/%%__GCC_VER%%/std/utf.d
-include/d/%%__GCC_VER%%/std/zip.d
-include/d/%%__GCC_VER%%/std/zlib.d
-include/d/%%__GCC_VER%%/std/c/dirent.d
-include/d/%%__GCC_VER%%/std/c/math.d
-include/d/%%__GCC_VER%%/std/c/process.d
-include/d/%%__GCC_VER%%/std/c/stdarg.d
-include/d/%%__GCC_VER%%/std/c/stddef.d
-include/d/%%__GCC_VER%%/std/c/stdio.d
-include/d/%%__GCC_VER%%/std/c/stdlib.d
-include/d/%%__GCC_VER%%/std/c/time.d
-include/d/%%__GCC_VER%%/std/c/darwin/darwin.d
-include/d/%%__GCC_VER%%/std/c/linux/linux.d
-include/d/%%__GCC_VER%%/std/c/linux/linuxextern.d
-include/d/%%__GCC_VER%%/std/c/linux/socket.d
-include/d/%%__GCC_VER%%/std/c/mach/mach.d
-include/d/%%__GCC_VER%%/std/c/mach/mach_extern.d
-include/d/%%__GCC_VER%%/std/c/unix/unix.d
-include/d/%%__GCC_VER%%/std/c/windows/com.d
-include/d/%%__GCC_VER%%/std/c/windows/windows.d
-include/d/%%__GCC_VER%%/std/c/windows/winsock.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_AC.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Aa.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Abit.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Acdouble.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Acfloat.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Acreal.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Adchar.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Adouble.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Afloat.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Ag.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Aint.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Along.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Areal.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Ashort.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Aubyte.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Auint.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Aulong.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Aushort.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_Awchar.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_C.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_bit.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_byte.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_cdouble.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_cfloat.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_char.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_creal.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_dchar.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_delegate.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_double.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_float.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_idouble.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_ifloat.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_int.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_ireal.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_long.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_ptr.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_real.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_short.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_ubyte.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_uint.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_ulong.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_ushort.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_void.d
-include/d/%%__GCC_VER%%/std/typeinfo/ti_wchar.d
-include/d/%%__GCC_VER%%/std/windows/iunknown.d
-include/d/%%__GCC_VER%%/std/windows/registry.d
-include/d/%%__GCC_VER%%/std/windows/syserror.d
-include/d/%%__GCC_VER%%/crc32.d
-include/d/%%__GCC_VER%%/gcstats.d
-include/d/%%__GCC_VER%%/object.d
-include/d/%%__GCC_VER%%/%%CONF_TARGET%%/gcc/config.d
-include/d/%%__GCC_VER%%/%%CONF_TARGET%%/gcc/configunix.d
-include/d/%%__GCC_VER%%/%%CONF_TARGET%%/phobos-ver-syms
+include/d/%%GCC_VER%%/etc/c/zlib.d
+include/d/%%GCC_VER%%/etc/c/recls/recls.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_assert.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_compiler.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_compiler_dmc.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_compiler_gcc.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_debug.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_defs.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_internal.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_language.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_platform.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_platform_types.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_retcodes.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_unix.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_util.h
+include/d/%%GCC_VER%%/etc/c/recls/recls_win32.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft_cccap_dmc.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft_cccap_gcc.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft_iterator.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft_lock_scope.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft_null.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft_null_mutex.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft_nulldef.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/stlsoft_static_initialisers.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_current_directory.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_current_directory_scope.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_environment_variable.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_filesystem_traits.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_findfile_sequence.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_functionals.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_glob_sequence.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_limits.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_process_mutex.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_readdir_sequence.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_spin_mutex.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_string_access.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/unixstl_thread_mutex.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/winstl.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/winstl_atomic_functions.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/winstl_filesystem_traits.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/winstl_findfile_sequence.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/winstl_spin_mutex.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/winstl_system_version.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/winstl_thread_mutex.h
+include/d/%%GCC_VER%%/etc/c/stlsoft/winstl_tls_index.h
+include/d/%%GCC_VER%%/etc/c/zlib/crc32.h
+include/d/%%GCC_VER%%/etc/c/zlib/deflate.h
+include/d/%%GCC_VER%%/etc/c/zlib/infblock.h
+include/d/%%GCC_VER%%/etc/c/zlib/infcodes.h
+include/d/%%GCC_VER%%/etc/c/zlib/inffast.h
+include/d/%%GCC_VER%%/etc/c/zlib/inffixed.h
+include/d/%%GCC_VER%%/etc/c/zlib/inflate.h
+include/d/%%GCC_VER%%/etc/c/zlib/inftrees.h
+include/d/%%GCC_VER%%/etc/c/zlib/infutil.h
+include/d/%%GCC_VER%%/etc/c/zlib/trees.h
+include/d/%%GCC_VER%%/etc/c/zlib/zconf.h
+include/d/%%GCC_VER%%/etc/c/zlib/zconf.in.h
+include/d/%%GCC_VER%%/etc/c/zlib/zlib.h
+include/d/%%GCC_VER%%/etc/c/zlib/zutil.h
+include/d/%%GCC_VER%%/gcc/aix_float.h
+include/d/%%GCC_VER%%/gcc/builtins.d
+include/d/%%GCC_VER%%/gcc/configext.d
+include/d/%%GCC_VER%%/gcc/deh.d
+include/d/%%GCC_VER%%/gcc/support.d
+include/d/%%GCC_VER%%/gcc/threadsem.d
+include/d/%%GCC_VER%%/gcc/unwind.d
+include/d/%%GCC_VER%%/std/array.d
+include/d/%%GCC_VER%%/std/asserterror.d
+include/d/%%GCC_VER%%/std/base64.d
+include/d/%%GCC_VER%%/std/boxer.d
+include/d/%%GCC_VER%%/std/compiler.d
+include/d/%%GCC_VER%%/std/conv.d
+include/d/%%GCC_VER%%/std/cstream.d
+include/d/%%GCC_VER%%/std/ctype.d
+include/d/%%GCC_VER%%/std/date.d
+include/d/%%GCC_VER%%/std/dateparse.d
+include/d/%%GCC_VER%%/std/file.d
+include/d/%%GCC_VER%%/std/format.d
+include/d/%%GCC_VER%%/std/gc.d
+include/d/%%GCC_VER%%/std/intrinsic.d
+include/d/%%GCC_VER%%/std/loader.d
+include/d/%%GCC_VER%%/std/math.d
+include/d/%%GCC_VER%%/std/math2.d
+include/d/%%GCC_VER%%/std/md5.d
+include/d/%%GCC_VER%%/std/mmfile.d
+include/d/%%GCC_VER%%/std/moduleinit.d
+include/d/%%GCC_VER%%/std/openrj.d
+include/d/%%GCC_VER%%/std/outbuffer.d
+include/d/%%GCC_VER%%/std/outofmemory.d
+include/d/%%GCC_VER%%/std/path.d
+include/d/%%GCC_VER%%/std/perf.d
+include/d/%%GCC_VER%%/std/process.d
+include/d/%%GCC_VER%%/std/random.d
+include/d/%%GCC_VER%%/std/recls.d
+include/d/%%GCC_VER%%/std/regexp.d
+include/d/%%GCC_VER%%/std/socket.d
+include/d/%%GCC_VER%%/std/socketstream.d
+include/d/%%GCC_VER%%/std/stdarg.d
+include/d/%%GCC_VER%%/std/stdint.d
+include/d/%%GCC_VER%%/std/stdio.d
+include/d/%%GCC_VER%%/std/stream.d
+include/d/%%GCC_VER%%/std/string.d
+include/d/%%GCC_VER%%/std/switcherr.d
+include/d/%%GCC_VER%%/std/syserror.d
+include/d/%%GCC_VER%%/std/system.d
+include/d/%%GCC_VER%%/std/thread.d
+include/d/%%GCC_VER%%/std/uni.d
+include/d/%%GCC_VER%%/std/uri.d
+include/d/%%GCC_VER%%/std/utf.d
+include/d/%%GCC_VER%%/std/zip.d
+include/d/%%GCC_VER%%/std/zlib.d
+include/d/%%GCC_VER%%/std/c/dirent.d
+include/d/%%GCC_VER%%/std/c/math.d
+include/d/%%GCC_VER%%/std/c/process.d
+include/d/%%GCC_VER%%/std/c/stdarg.d
+include/d/%%GCC_VER%%/std/c/stddef.d
+include/d/%%GCC_VER%%/std/c/stdio.d
+include/d/%%GCC_VER%%/std/c/stdlib.d
+include/d/%%GCC_VER%%/std/c/time.d
+include/d/%%GCC_VER%%/std/c/darwin/darwin.d
+include/d/%%GCC_VER%%/std/c/linux/linux.d
+include/d/%%GCC_VER%%/std/c/linux/linuxextern.d
+include/d/%%GCC_VER%%/std/c/linux/socket.d
+include/d/%%GCC_VER%%/std/c/mach/mach.d
+include/d/%%GCC_VER%%/std/c/mach/mach_extern.d
+include/d/%%GCC_VER%%/std/c/unix/unix.d
+include/d/%%GCC_VER%%/std/c/windows/com.d
+include/d/%%GCC_VER%%/std/c/windows/windows.d
+include/d/%%GCC_VER%%/std/c/windows/winsock.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_AC.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Aa.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Abit.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Acdouble.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Acfloat.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Acreal.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Adchar.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Adouble.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Afloat.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Ag.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Aint.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Along.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Areal.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Ashort.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Aubyte.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Auint.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Aulong.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Aushort.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_Awchar.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_C.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_bit.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_byte.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_cdouble.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_cfloat.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_char.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_creal.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_dchar.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_delegate.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_double.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_float.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_idouble.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_ifloat.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_int.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_ireal.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_long.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_ptr.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_real.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_short.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_ubyte.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_uint.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_ulong.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_ushort.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_void.d
+include/d/%%GCC_VER%%/std/typeinfo/ti_wchar.d
+include/d/%%GCC_VER%%/std/windows/iunknown.d
+include/d/%%GCC_VER%%/std/windows/registry.d
+include/d/%%GCC_VER%%/std/windows/syserror.d
+include/d/%%GCC_VER%%/crc32.d
+include/d/%%GCC_VER%%/gcstats.d
+include/d/%%GCC_VER%%/object.d
+include/d/%%GCC_VER%%/%%CONF_TARGET%%/gcc/config.d
+include/d/%%GCC_VER%%/%%CONF_TARGET%%/gcc/configunix.d
+include/d/%%GCC_VER%%/%%CONF_TARGET%%/phobos-ver-syms
lib/libgphobos.a
lib/libgphobos.spec
-@dirrm include/d/%%__GCC_VER%%/etc/c/recls
-@dirrm include/d/%%__GCC_VER%%/etc/c/stlsoft
-@dirrm include/d/%%__GCC_VER%%/etc/c/zlib
-@dirrm include/d/%%__GCC_VER%%/etc/c
-@dirrm include/d/%%__GCC_VER%%/etc
-@dirrm include/d/%%__GCC_VER%%/gcc
-@dirrm include/d/%%__GCC_VER%%/std/c/darwin
-@dirrm include/d/%%__GCC_VER%%/std/c/linux
-@dirrm include/d/%%__GCC_VER%%/std/c/mach
-@dirrm include/d/%%__GCC_VER%%/std/c/unix
-@dirrm include/d/%%__GCC_VER%%/std/c/windows
-@dirrm include/d/%%__GCC_VER%%/std/typeinfo
-@dirrm include/d/%%__GCC_VER%%/std/windows
-@dirrm include/d/%%__GCC_VER%%/std/c
-@dirrm include/d/%%__GCC_VER%%/std
-@dirrm include/d/%%__GCC_VER%%/%%CONF_TARGET%%/gcc
-@dirrm include/d/%%__GCC_VER%%/%%CONF_TARGET%%
-@dirrm include/d/%%__GCC_VER%%
+@dirrm include/d/%%GCC_VER%%/etc/c/recls
+@dirrm include/d/%%GCC_VER%%/etc/c/stlsoft
+@dirrm include/d/%%GCC_VER%%/etc/c/zlib
+@dirrm include/d/%%GCC_VER%%/etc/c
+@dirrm include/d/%%GCC_VER%%/etc
+@dirrm include/d/%%GCC_VER%%/gcc
+@dirrm include/d/%%GCC_VER%%/std/c/darwin
+@dirrm include/d/%%GCC_VER%%/std/c/linux
+@dirrm include/d/%%GCC_VER%%/std/c/mach
+@dirrm include/d/%%GCC_VER%%/std/c/unix
+@dirrm include/d/%%GCC_VER%%/std/c/windows
+@dirrm include/d/%%GCC_VER%%/std/typeinfo
+@dirrm include/d/%%GCC_VER%%/std/windows
+@dirrm include/d/%%GCC_VER%%/std/c
+@dirrm include/d/%%GCC_VER%%/std
+@dirrm include/d/%%GCC_VER%%/%%CONF_TARGET%%/gcc
+@dirrm include/d/%%GCC_VER%%/%%CONF_TARGET%%
+@dirrm include/d/%%GCC_VER%%
@dirrm include/d