aboutsummaryrefslogtreecommitdiff
path: root/lang/harbour
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-11-15 03:22:56 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-11-15 03:22:56 +0000
commit891c8a0c26aa4315a495a3dd4d46d79207dda0e3 (patch)
tree093a4f7ef4f0c488805b6a527812be120a7b28a7 /lang/harbour
parenta29eaea609e4c19409e705122da6343427c070da (diff)
downloadports-891c8a0c26aa4315a495a3dd4d46d79207dda0e3.tar.gz
ports-891c8a0c26aa4315a495a3dd4d46d79207dda0e3.zip
Fix build on gcc-based archs.
Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=484993
Diffstat (limited to 'lang/harbour')
-rw-r--r--lang/harbour/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/lang/harbour/Makefile b/lang/harbour/Makefile
index 58e55e321c42..c3611f3d4cd8 100644
--- a/lang/harbour/Makefile
+++ b/lang/harbour/Makefile
@@ -12,7 +12,8 @@ COMMENT= Open source Clipper-compatible compiler
BROKEN_mips= does not build: clang: Command not found
BROKEN_mips64= does not build: clang: Command not found
-BROKEN_powerpc64= does not build: clang: Command not found
+# XXX MCL 20181112
+#BROKEN_powerpc64= does not build: clang: Command not found
BROKEN_sparc64= does not compile: assertion failed
LIB_DEPENDS= libslang.so:devel/libslang2\
@@ -108,4 +109,11 @@ post-patch:
${REINPLACE_CMD} \
-e 's|utmp.h|utmpx.h|g' ${WRKSRC}/src/rtl/gtcrs/gtcrs.h
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# override default for gcc-based archs
+.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+HB_COMPILER= gcc
+.endif
+
+.include <bsd.port.post.mk>