aboutsummaryrefslogtreecommitdiff
path: root/lang/hs-epic
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-01-09 21:32:12 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-01-09 21:32:12 +0000
commit1a75cb1d44d0e805336b016a92a4b2d8d564fdda (patch)
tree604f06bea271b71fb7be1993c1c2ba323b4506e1 /lang/hs-epic
parentf27ca4d0f1e1df6ff92a7455ddea39730ec30f60 (diff)
downloadports-1a75cb1d44d0e805336b016a92a4b2d8d564fdda.tar.gz
ports-1a75cb1d44d0e805336b016a92a4b2d8d564fdda.zip
- Stagify lang/ghc and all the Haskell Cabal ports
- Update HACKAGE_SITE to follow changes in upstream - MAKE_ENV now sets LC_ALL and DESTDIR for Haskell Cabal ports - Further minor cosmetical changes: replace USE_GMAKE with USES, get rid of ${DO_NADA}, some refactoring Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=339286
Diffstat (limited to 'lang/hs-epic')
-rw-r--r--lang/hs-epic/Makefile1
-rw-r--r--lang/hs-epic/files/patch-Setup.hs32
2 files changed, 32 insertions, 1 deletions
diff --git a/lang/hs-epic/Makefile b/lang/hs-epic/Makefile
index 4d8c118e4581..79c873221a82 100644
--- a/lang/hs-epic/Makefile
+++ b/lang/hs-epic/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS+= boehm-gc>=7.1:${PORTSDIR}/devel/boehm-gc \
EXECUTABLE= epic
-NO_STAGE= yes
post-patch::
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/evm/Makefile
diff --git a/lang/hs-epic/files/patch-Setup.hs b/lang/hs-epic/files/patch-Setup.hs
new file mode 100644
index 000000000000..9e14cf10a5eb
--- /dev/null
+++ b/lang/hs-epic/files/patch-Setup.hs
@@ -0,0 +1,32 @@
+--- Setup.hs.orig 2012-02-27 23:44:30.000000000 +0000
++++ Setup.hs 2013-12-08 15:39:13.067013368 +0000
+@@ -1,10 +1,12 @@
+ import Distribution.Simple
+ import Distribution.Simple.InstallDirs
+ import Distribution.Simple.LocalBuildInfo
+-import Distribution.PackageDescription
++import Distribution.Simple.Setup
++import Distribution.PackageDescription hiding (Flag)
+
+ import System.Exit
+ import System.Process
++import System.FilePath.Posix
+
+ -- After Epic is built, we need a run time system.
+
+@@ -33,7 +35,14 @@
+ = do let pfx = prefix (installDirTemplates local)
+ system' $ "make -C evm install PREFIX=" ++ show pfx
+
++postCopyLib args flags desc local = do
++ let pfix = prefix (installDirTemplates local)
++ let (Flag (CopyTo destDir)) = copyDest flags
++ putStrLn $ "PREFIX=" ++ (show destDir </> show pfix)
++ system' $ "make -C evm install PREFIX=" ++ (destDir </> show pfix)
++
+ main = defaultMainWithHooks (simpleUserHooks { postBuild = buildLib,
+ postConf = postConfLib,
+- postInst = postInstLib })
++ postInst = postInstLib,
++ postCopy = postCopyLib })
+