aboutsummaryrefslogtreecommitdiff
path: root/lang/hugs
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-11-19 21:14:04 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-11-19 21:14:04 +0000
commit36e68529f260445f3fce81274e05ee3c2b21f8eb (patch)
treee85638d7997d0b3d750cd07b5a72e74f3196ca2b /lang/hugs
parent0873528d9da6d87f88ac4171214c1a1242ca64e7 (diff)
downloadports-36e68529f260445f3fce81274e05ee3c2b21f8eb.tar.gz
ports-36e68529f260445f3fce81274e05ee3c2b21f8eb.zip
Add OPTION for compiling hugs with OpenGL/GLUT support.
Requested by: Jan Rochel <jannisan@t-online.de>
Notes
Notes: svn path=/head/; revision=121979
Diffstat (limited to 'lang/hugs')
-rw-r--r--lang/hugs/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index 2174c6eced1f..7e525f673faa 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -17,6 +17,7 @@ COMMENT= An interpreter for the functional programming language Haskell 98
WRKSRC= ${WRKDIR}/${DISTNAME}/src
+OPTIONS= HUGS_OPENGL "OpenGL/GLUT support" off
HUGS_DATE= Nov2003
USE_REINPLACE= yes
USE_BISON= yes
@@ -24,10 +25,17 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} --enable-ffi
CONFIGURE_ENV+= CC="${CC}" CFLAGS="${CFLAGS}"
ALL_TARGET= default ffihugs
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_HUGS_OPENGL)
+CONFIGURE_ARGS+= --enable-hopengl --enable-mesa
+USE_GL= yes
+.endif
+
MAN1= hugs.1 hugs-package.1
.if ${MACHINE_ARCH:L} == "amd64"
-CFLAGS+= "-fPIC"
+CFLAGS+= "-fPIC"
.endif
post-patch:
@@ -48,4 +56,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/../Readme ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>