aboutsummaryrefslogtreecommitdiff
path: root/lang/icc/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2002-11-08 20:17:54 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2002-11-08 20:17:54 +0000
commite5d621e43e962aa88fcf20f140c5587f8c2f4fdf (patch)
tree45ca690eb604fa16cfa35d39d8e2f2e1f4652725 /lang/icc/Makefile
parent23d157a7518747d2bbbbd71a6714c26a0c4c9321 (diff)
downloadports-e5d621e43e962aa88fcf20f140c5587f8c2f4fdf.tar.gz
ports-e5d621e43e962aa88fcf20f140c5587f8c2f4fdf.zip
- mark BROKEN when linux_devtools or ifc is installed
- make it more clear that you shouldn't install linux_devtools in the post install message
Notes
Notes: svn path=/head/; revision=69748
Diffstat (limited to 'lang/icc/Makefile')
-rw-r--r--lang/icc/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index d8c8d35d6456..13349856529d 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -43,6 +43,11 @@ OBJCOPY?= /usr/bin/objcopy
IGNORE= "Please manually download ${DISTFILES} from ${ICC_SITE}, ${ICC_SITE}c60l/noncom.htm or https://premier.intel.com/ \(whichever has the file, to access premier.intel.com you have to register at http://www.intel.com/software/products/registrationcenter/index.htm\). With a little bit of luck it may also be available from ftp://download.intel.com/software/products/compilers/downloads/. Put it into ${DISTDIR} and run make again"
.endif
+.if exists(${LINUXBASE}/boot/kernel.h) || \
+ exists(${PREFIX}/intel/compiler60/bin/ifc)
+BROKEN= Can not coexist with linux_devtools or ifc
+.endif
+
post-extract:
.for i in \
intel-icc6-6.0.1-304.i386.rpm \
@@ -141,7 +146,7 @@ post-install:
@${ECHO_CMD} "in your kernel config (have a look at http://www.FreeBSD.org/handbook/"
@${ECHO_CMD} "if you do not know how to do this), else icc will hang forever."
@${ECHO_CMD}
- @${ECHO_CMD} "WARNING: If you use icc while having linux-devtools installed, icc will use"
- @${ECHO_CMD} "the wrong includes and therefore will generate bogus binaries!"
+ @${ECHO_CMD} "WARNING: If you use icc while having linux_devtools installed, icc will use"
+ @${ECHO_CMD} "the wrong includes and therefore will generate bogus (not working) binaries!"
.include <bsd.port.post.mk>