aboutsummaryrefslogtreecommitdiff
path: root/lang/intel-compute-runtime
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-09-17 14:06:15 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-10-03 09:54:49 +0000
commit484d5a925f45edee3e5c6621500d9da73d87ecbb (patch)
treea3ef04aa5f585cd828db8894f4ed2aa7bb637844 /lang/intel-compute-runtime
parente9f32a93276ef361d3acd1702464e470b416a9e5 (diff)
downloadports-484d5a925f45edee3e5c6621500d9da73d87ecbb.tar.gz
ports-484d5a925f45edee3e5c6621500d9da73d87ecbb.zip
lang/intel-compute-runtime: update to 21.39.21127
Diffstat (limited to 'lang/intel-compute-runtime')
-rw-r--r--lang/intel-compute-runtime/Makefile5
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-arch19
3 files changed, 26 insertions, 4 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index ebd3ab1e73e2..d997dbc39fba 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,5 +1,5 @@
PORTNAME= compute-runtime
-DISTVERSION= 21.37.20939
+DISTVERSION= 21.39.21127
CATEGORIES= lang
PKGNAMEPREFIX= intel-
PKGNAMESUFFIX= -${FLAVOR}
@@ -15,6 +15,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Only Intel GPUs on x86 are supported
+BROKEN_i386= shared/source/kernel/implicit_args.h:35:1: error: static_assert failed \
+ due to requirement '(sizeof(NEO::ImplicitArgs) & 31) == 0' \
+ "Implicit args size need to be aligned to 32"
LIB_DEPENDS= libigc.so:devel/intel-graphics-compiler@${FLAVOR} \
libigdgmm.so:multimedia/gmmlib
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 1c7b088321da..261e7986800d 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1631283767
-SHA256 (intel-compute-runtime-21.37.20939_GH0.tar.gz) = 306fac63d58fd08c9ae1e5fceab8bb89c2c892c6e1579f66c4d936e5b581eb4b
-SIZE (intel-compute-runtime-21.37.20939_GH0.tar.gz) = 4576917
+TIMESTAMP = 1632493414
+SHA256 (intel-compute-runtime-21.39.21127_GH0.tar.gz) = 914623adc6a37cae3c84393dcf7ee6f6b5e23425c823398f446e9c15e7fd28fe
+SIZE (intel-compute-runtime-21.39.21127_GH0.tar.gz) = 4666632
SHA256 (aa5a39a2db79.patch) = fc2290d950fed2bcde8fd6ce13cefb64d90ca348ae364a46a480c1d2509f67f9
SIZE (aa5a39a2db79.patch) = 1691
diff --git a/lang/intel-compute-runtime/files/patch-arch b/lang/intel-compute-runtime/files/patch-arch
new file mode 100644
index 000000000000..4b9b30f7ef4b
--- /dev/null
+++ b/lang/intel-compute-runtime/files/patch-arch
@@ -0,0 +1,19 @@
+Add more architecture names
+
+CMake Error at CMakeLists.txt:164 (message):
+ Unsupported target processor: amd64
+ Unsupported target processor: i386
+
+--- CMakeLists.txt.orig 2021-09-17 14:06:15 UTC
++++ CMakeLists.txt
+@@ -154,6 +154,10 @@ if(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "x86_64")
+ set(NEO_TARGET_PROCESSOR "x86_64")
+ elseif(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "AMD64")
+ set(NEO_TARGET_PROCESSOR "x86_64")
++elseif(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "amd64")
++ set(NEO_TARGET_PROCESSOR "x86_64")
++elseif(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "i386")
++ set(NEO_TARGET_PROCESSOR "x86_64") # pre-895e9e511653 code
+ elseif(${CMAKE_SYSTEM_PROCESSOR} STREQUAL "aarch64")
+ set(NEO_TARGET_PROCESSOR "aarch64")
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/third_party/sse2neon)