aboutsummaryrefslogtreecommitdiff
path: root/lang/io/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-12-13 08:46:32 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-12-13 08:46:32 +0000
commit01d18dfe53b916adb3d476b76c0de44c5107edfe (patch)
tree7f8f1e5910027e1e8ec1f09b78f3def9de8d4147 /lang/io/Makefile
parentf2c3d5e619f06e3e67ff3ca5ee6ee80ea1a944fd (diff)
downloadports-01d18dfe53b916adb3d476b76c0de44c5107edfe.tar.gz
ports-01d18dfe53b916adb3d476b76c0de44c5107edfe.zip
- Convert to OPTIONSng
- STAGE-clean - Fix build on current [1] Suggested by: gnn [1]
Notes
Notes: svn path=/head/; revision=336326
Diffstat (limited to 'lang/io/Makefile')
-rw-r--r--lang/io/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/lang/io/Makefile b/lang/io/Makefile
index de928261cbf2..c8ec5ab7bcf3 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -11,9 +11,15 @@ COMMENT= Small prototype-based programming language
LICENSE= BSD
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_GROUP= ADDONS
+
+USE_GCC= yes
USE_GITHUB= yes
GH_ACCOUNT= stevedekorte
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 23afbcc
+MAKE_JOBS_UNSAFE=yes
USE_LDCONFIG= yes
USES= cmake:outsource
@@ -21,7 +27,6 @@ USES= cmake:outsource
PORTDOCS= *
PORTEXAMPLES= *
-NO_STAGE= yes
.include "${.CURDIR}/Makefile.addons"
post-patch:
@@ -33,13 +38,13 @@ post-patch:
${FIND} ${WRKSRC}/addons -name "*.bak" -o -name "*.orig" -delete
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>