aboutsummaryrefslogtreecommitdiff
path: root/lang/io/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-11-11 10:24:01 +0000
committerJohn Marino <marino@FreeBSD.org>2015-11-11 10:24:01 +0000
commit7b56a62b83d9a94e2dd3fc43ed1ab952783ad3a1 (patch)
tree5ca5a1a575aeac618b414b98bcfa346ca6cb31cc /lang/io/Makefile
parentbc38a6cff27d9ab56453b6e9e776d491ceec3788 (diff)
downloadports-7b56a62b83d9a94e2dd3fc43ed1ab952783ad3a1.tar.gz
ports-7b56a62b83d9a94e2dd3fc43ed1ab952783ad3a1.zip
lang/io: uses optios framework, fix couple of bugs
During the conversion to use option handlers, I found a couple of typos and obsolete code which caused errors. I also switched to USES+= readline libedit when their options were selected.
Notes
Notes: svn path=/head/; revision=401234
Diffstat (limited to 'lang/io/Makefile')
-rw-r--r--lang/io/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/io/Makefile b/lang/io/Makefile
index f3e6c8345d2e..9b3d948f9568 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -3,7 +3,7 @@
PORTNAME= io
PORTVERSION= 2013.12.04
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang
MAINTAINER= ports@FreeBSD.org
@@ -25,6 +25,7 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_GROUP= ADDONS
+OPTIONS_SUB= yes
.include "${.CURDIR}/Makefile.addons"
@@ -37,7 +38,7 @@ post-patch:
${FIND} ${WRKSRC}/addons -name "*.bak" -o -name "*.orig" -delete
post-install:
- ${FIND} -d ${STAGEDIR}${PREFIX}/lib/io/addons -type d -empty -exec rmdir {} \;
+ ${FIND} -d ${STAGEDIR}${PREFIX}/lib/io/addons -type d -empty -delete
${FIND} ${STAGEDIR}${PREFIX}/lib/io/addons -type f -name "*.so" -exec \
${STRIP_CMD} {} \;
${MKDIR} ${STAGEDIR}${DOCSDIR}