aboutsummaryrefslogtreecommitdiff
path: root/lang/itcl
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-06-24 11:42:32 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-06-24 11:42:32 +0000
commitd530b271d96cde879c3eb6ed8d1f6e86dee25919 (patch)
tree0f3bfcde4180f0885c812fc77254f8b7feaded8f /lang/itcl
parent9688e7d314996de30b87685f76c328a1a1064cd3 (diff)
downloadports-d530b271d96cde879c3eb6ed8d1f6e86dee25919.tar.gz
ports-d530b271d96cde879c3eb6ed8d1f6e86dee25919.zip
Add
post-install: pkg_add -m ${PREFIX}/lib to Makefiles and @exec ldconfig -m %D to packing lists of ports that install shared libraries. This should get rid of a huge chunk of confusion for novice users! All hail Paul Kranenburg! :)
Notes
Notes: svn path=/head/; revision=1871
Diffstat (limited to 'lang/itcl')
-rw-r--r--lang/itcl/Makefile5
-rw-r--r--lang/itcl/pkg-plist1
2 files changed, 5 insertions, 1 deletions
diff --git a/lang/itcl/Makefile b/lang/itcl/Makefile
index 1c366d119667..f02527f176d3 100644
--- a/lang/itcl/Makefile
+++ b/lang/itcl/Makefile
@@ -3,7 +3,7 @@
# Date created: Mon Oct 3 22:06:21 EDT 1994
# Whom: rww
#
-# $Id: Makefile,v 1.5 1995/04/15 05:44:39 asami Exp $
+# $Id: Makefile,v 1.6 1995/05/13 07:53:08 asami Exp $
#
DISTNAME= itcl-1.5
@@ -16,4 +16,7 @@ LIB_DEPENDS= tk\\.3\\.:${PORTSDIR}/x11/tk
PATCH_STRIP= -p1
+post-install:
+ ldconfig -m ${PREFIX}/lib
+
.include <bsd.port.mk>
diff --git a/lang/itcl/pkg-plist b/lang/itcl/pkg-plist
index bbfcfe45f641..6cf25c3d1f6d 100644
--- a/lang/itcl/pkg-plist
+++ b/lang/itcl/pkg-plist
@@ -2,6 +2,7 @@
include/itcl.h
lib/libitcl.a
lib/libitcl.so.1.5
+@exec ldconfig -m %B
bin/itcl_wish
bin/itcl_sh
man/mann/incrTcl.n